aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/qtqml
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-06-17 15:42:05 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-06-24 18:26:14 +0200
commit36df81b3bc6d721d5598d5163b0a9659de4a69ee (patch)
treed9032e08f4d27daa9e4b16a2c2e622ed2fa6951b /src/imports/qtqml
parent6de0287d7c3aa4251fe6eb4f970d73ce11cf07fc (diff)
Discern between "auto" and versioned imports in qmldirs
You can now import the latest version, a specific version, or, "auto" which is the same version as the parent module. [ChangeLog][QtQml] You can now procedurally add module imports to modules, using qmlRegisterModuleImport(). However, actual import statements in qmldir files should be preferred wherever possible. Fixes: QTBUG-84899 Change-Id: I3b32dd8b07a19d31b6538b9a6bb436840862f345 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports/qtqml')
-rw-r--r--src/imports/qtqml/CMakeLists.txt4
-rw-r--r--src/imports/qtqml/qtqml.pro4
2 files changed, 4 insertions, 4 deletions
diff --git a/src/imports/qtqml/CMakeLists.txt b/src/imports/qtqml/CMakeLists.txt
index f50f2f69f5..c33aad5cc4 100644
--- a/src/imports/qtqml/CMakeLists.txt
+++ b/src/imports/qtqml/CMakeLists.txt
@@ -1,12 +1,12 @@
# Generated from qtqml.pro.
set(module_dynamic_qml_imports
- QtQml.Models
+ QtQml.Models/auto
)
if (QT_FEATURE_qml_worker_script)
list(APPEND module_dynamic_qml_imports
- QtQml.WorkerScript
+ QtQml.WorkerScript/auto
)
endif()
diff --git a/src/imports/qtqml/qtqml.pro b/src/imports/qtqml/qtqml.pro
index eac19954b6..ca162e65a9 100644
--- a/src/imports/qtqml/qtqml.pro
+++ b/src/imports/qtqml/qtqml.pro
@@ -15,9 +15,9 @@ DYNAMIC_QMLDIR = \
"classname QtQmlPlugin" \
"typeinfo plugins.qmltypes" \
"designersupported" \
- "import QtQml.Models"
+ "import QtQml.Models auto"
qtConfig(qml-worker-script): DYNAMIC_QMLDIR += \
- "import QtQml.WorkerScript"
+ "import QtQml.WorkerScript auto"
load(qml_plugin)