aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/settings/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-01-20 14:48:05 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2021-01-20 17:28:10 +0100
commit0fb373c9a2ebc31f76b27bfa5c2e59dadefeaf08 (patch)
tree8df5099729d1e7fd9a973b4caf8fa1db7ca31de0 /src/imports/settings/CMakeLists.txt
parenta738c3566790c6e9abeea3c4c3dacfceaa82f66a (diff)
Qt.labs.settings: Make plugin optional
This moves the settings types into a new library and is meant to make them availabe to the QML compiler at some point in the future. Task-number: QTBUG-90487 Change-Id: I986615b08ea8c1a7312b9d9c6ae0b13c03fb5497 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports/settings/CMakeLists.txt')
-rw-r--r--src/imports/settings/CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/src/imports/settings/CMakeLists.txt b/src/imports/settings/CMakeLists.txt
index c5c76135ba..f49e741106 100644
--- a/src/imports/settings/CMakeLists.txt
+++ b/src/imports/settings/CMakeLists.txt
@@ -9,14 +9,13 @@ qt_internal_add_qml_module(qmlsettingsplugin
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QmlSettingsPlugin
SKIP_TYPE_REGISTRATION
- GENERATE_QMLTYPES
- INSTALL_QMLTYPES
+ PLUGIN_OPTIONAL
SOURCES
plugin.cpp
- qqmlsettings.cpp qqmlsettings_p.h
PUBLIC_LIBRARIES
Qt::Core
Qt::Qml
+ Qt::LabsSettingsPrivate
)
#### Keys ignored in scope 1:.:.:settings.pro:<TRUE>: