aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/shapes/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-06-05 13:35:02 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-07-24 12:02:30 +0000
commit78254be6cbd239a3de332c5660b2c408d9f3e674 (patch)
treefeca8f2213db8da240158000b03a3d61b1f77469 /src/imports/shapes/CMakeLists.txt
parent55cc9396e0832d84ce231c0f608c2b6850d7ef78 (diff)
Build projects from src/import
Add support to build the projects under src/imports. All the CMakeLists.txt were generate with pro2cmake, except for src/imports/builtins. Change-Id: I06046ede82ba5b1e677e92b7548f543d020b0354 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/imports/shapes/CMakeLists.txt')
-rw-r--r--src/imports/shapes/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/imports/shapes/CMakeLists.txt b/src/imports/shapes/CMakeLists.txt
new file mode 100644
index 0000000000..465183e0b3
--- /dev/null
+++ b/src/imports/shapes/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Generated from shapes.pro.
+
+#####################################################################
+## qmlshapesplugin Plugin:
+#####################################################################
+
+add_qml_module(qmlshapesplugin
+ TARGET_PATH "QtQuick/Shapes"
+ IMPORT_VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ SOURCES
+ plugin.cpp
+ LIBRARIES
+ Qt::GuiPrivate
+ Qt::QuickPrivate
+ Qt::QuickShapesPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ Qt::QuickShapes
+)
+
+#### Keys ignored in scope 1:.:.:shapes.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# TARGETPATH = "QtQuick/Shapes"
+# _LOADED = "qml_plugin"