aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports/sharedimage/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-01-21 16:11:08 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2021-01-25 11:22:04 +0100
commitcd8ae755c2762cedc98f7f389f13ab827e125e11 (patch)
tree39dd5be850fad42f66cf2c344bf8bd33feb77f86 /src/imports/sharedimage/CMakeLists.txt
parent9eda73354c6caf0b974febc7bdbee136d59a4e36 (diff)
Qt.labs.sharedimage: Make plugin optional
This moves the sharedimage types into a new library and is meant to make them availabe to the QML compiler at some point in the future. Task-number: QTBUG-90487 Change-Id: If79425a43cb8c1831422631791d35c1f329c7e80 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'src/imports/sharedimage/CMakeLists.txt')
-rw-r--r--src/imports/sharedimage/CMakeLists.txt10
1 files changed, 2 insertions, 8 deletions
diff --git a/src/imports/sharedimage/CMakeLists.txt b/src/imports/sharedimage/CMakeLists.txt
index 90020be7ee..70f3abb76e 100644
--- a/src/imports/sharedimage/CMakeLists.txt
+++ b/src/imports/sharedimage/CMakeLists.txt
@@ -9,19 +9,13 @@ qt_internal_add_qml_module(sharedimageplugin
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuickSharedImagePlugin
SKIP_TYPE_REGISTRATION
- GENERATE_QMLTYPES
- INSTALL_QMLTYPES
+ PLUGIN_OPTIONAL
SOURCES
plugin.cpp
- qsharedimageloader.cpp qsharedimageloader_p.h
- sharedimageprovider.cpp sharedimageprovider.h
PUBLIC_LIBRARIES
Qt::Core
- Qt::CorePrivate
- Qt::Gui
- Qt::GuiPrivate
Qt::Qml
- Qt::QuickPrivate
+ Qt::LabsSharedImagePrivate
)
#### Keys ignored in scope 1:.:.:sharedimage.pro:<TRUE>: