aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-09-22 15:23:08 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-10-06 13:19:37 +0200
commit08adbefa131ef1c934f55cd61716c8ea836ddf02 (patch)
tree0ae21548926596fb41e7e71c4bb14d1973245bde /src/imports
parentc52a857c2b6b89abeddeee8489110ab9dd363e53 (diff)
CMake: Regenerate projects to use new qt_internal_ API
Modify special case locations to use the new API as well. Task-number: QTBUG-86815 Change-Id: I3b964e3baf0cc7040830156dac30358ea1152801 Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/folderlistmodel/CMakeLists.txt2
-rw-r--r--src/imports/labsanimation/CMakeLists.txt2
-rw-r--r--src/imports/labsmodels/CMakeLists.txt6
-rw-r--r--src/imports/layouts/CMakeLists.txt2
-rw-r--r--src/imports/localstorage/CMakeLists.txt2
-rw-r--r--src/imports/models/CMakeLists.txt2
-rw-r--r--src/imports/particles/CMakeLists.txt2
-rw-r--r--src/imports/qtqml/.prev_CMakeLists.txt2
-rw-r--r--src/imports/qtqml/CMakeLists.txt2
-rw-r--r--src/imports/qtquick2/CMakeLists.txt4
-rw-r--r--src/imports/settings/CMakeLists.txt2
-rw-r--r--src/imports/shapes/CMakeLists.txt2
-rw-r--r--src/imports/sharedimage/CMakeLists.txt2
-rw-r--r--src/imports/testlib/CMakeLists.txt2
-rw-r--r--src/imports/wavefrontmesh/CMakeLists.txt2
-rw-r--r--src/imports/workerscript/CMakeLists.txt2
16 files changed, 19 insertions, 19 deletions
diff --git a/src/imports/folderlistmodel/CMakeLists.txt b/src/imports/folderlistmodel/CMakeLists.txt
index 0bc9f28da6..0c431374e8 100644
--- a/src/imports/folderlistmodel/CMakeLists.txt
+++ b/src/imports/folderlistmodel/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlfolderlistmodelplugin Plugin:
#####################################################################
-qt_add_qml_module(qmlfolderlistmodelplugin
+qt_internal_add_qml_module(qmlfolderlistmodelplugin
URI "Qt.labs.folderlistmodel"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QmlFolderListModelPlugin
diff --git a/src/imports/labsanimation/CMakeLists.txt b/src/imports/labsanimation/CMakeLists.txt
index a4de38267e..b1df75b946 100644
--- a/src/imports/labsanimation/CMakeLists.txt
+++ b/src/imports/labsanimation/CMakeLists.txt
@@ -4,7 +4,7 @@
## labsanimationplugin Plugin:
#####################################################################
-qt_add_qml_module(labsanimationplugin
+qt_internal_add_qml_module(labsanimationplugin
URI "Qt.labs.animation"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtLabsAnimationPlugin
diff --git a/src/imports/labsmodels/CMakeLists.txt b/src/imports/labsmodels/CMakeLists.txt
index efd3339e2f..164583dd1e 100644
--- a/src/imports/labsmodels/CMakeLists.txt
+++ b/src/imports/labsmodels/CMakeLists.txt
@@ -4,7 +4,7 @@
## labsmodelsplugin Plugin:
#####################################################################
-qt_add_qml_module(labsmodelsplugin
+qt_internal_add_qml_module(labsmodelsplugin
URI "Qt.labs.qmlmodels"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQmlLabsModelsPlugin
@@ -25,13 +25,13 @@ qt_add_qml_module(labsmodelsplugin
## Scopes:
#####################################################################
-qt_extend_target(labsmodelsplugin CONDITION QT_FEATURE_qml_table_model
+qt_internal_extend_target(labsmodelsplugin CONDITION QT_FEATURE_qml_table_model
SOURCES
qqmltablemodel.cpp qqmltablemodel_p.h
qqmltablemodelcolumn.cpp qqmltablemodelcolumn_p.h
)
-qt_extend_target(labsmodelsplugin CONDITION QT_FEATURE_qml_delegate_model
+qt_internal_extend_target(labsmodelsplugin CONDITION QT_FEATURE_qml_delegate_model
SOURCES
qqmldelegatecomponent.cpp qqmldelegatecomponent_p.h
)
diff --git a/src/imports/layouts/CMakeLists.txt b/src/imports/layouts/CMakeLists.txt
index ffde82d340..445914b71e 100644
--- a/src/imports/layouts/CMakeLists.txt
+++ b/src/imports/layouts/CMakeLists.txt
@@ -4,7 +4,7 @@
## qquicklayoutsplugin Plugin:
#####################################################################
-qt_add_qml_module(qquicklayoutsplugin
+qt_internal_add_qml_module(qquicklayoutsplugin
URI "QtQuick.Layouts"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
diff --git a/src/imports/localstorage/CMakeLists.txt b/src/imports/localstorage/CMakeLists.txt
index d3fd8ff290..abbe484874 100644
--- a/src/imports/localstorage/CMakeLists.txt
+++ b/src/imports/localstorage/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmllocalstorageplugin Plugin:
#####################################################################
-qt_add_qml_module(qmllocalstorageplugin
+qt_internal_add_qml_module(qmllocalstorageplugin
URI "QtQuick.LocalStorage"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QQmlLocalStoragePlugin
diff --git a/src/imports/models/CMakeLists.txt b/src/imports/models/CMakeLists.txt
index 89d65a22dc..4070ad365b 100644
--- a/src/imports/models/CMakeLists.txt
+++ b/src/imports/models/CMakeLists.txt
@@ -4,7 +4,7 @@
## modelsplugin Plugin:
#####################################################################
-qt_add_qml_module(modelsplugin
+qt_internal_add_qml_module(modelsplugin
URI "QtQml.Models"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
diff --git a/src/imports/particles/CMakeLists.txt b/src/imports/particles/CMakeLists.txt
index 6d5e71f7d1..7e754a2cee 100644
--- a/src/imports/particles/CMakeLists.txt
+++ b/src/imports/particles/CMakeLists.txt
@@ -4,7 +4,7 @@
## particlesplugin Plugin:
#####################################################################
-qt_add_qml_module(particlesplugin
+qt_internal_add_qml_module(particlesplugin
URI "QtQuick.Particles"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuick2ParticlesPlugin
diff --git a/src/imports/qtqml/.prev_CMakeLists.txt b/src/imports/qtqml/.prev_CMakeLists.txt
index 52e6d3e1e0..99e76596ea 100644
--- a/src/imports/qtqml/.prev_CMakeLists.txt
+++ b/src/imports/qtqml/.prev_CMakeLists.txt
@@ -14,7 +14,7 @@ endif()
## qmlplugin Plugin:
#####################################################################
-qt_add_qml_module(qmlplugin
+qt_internal_add_qml_module(qmlplugin
URI "QtQml"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
diff --git a/src/imports/qtqml/CMakeLists.txt b/src/imports/qtqml/CMakeLists.txt
index 8ad8c0e111..15e66fd53e 100644
--- a/src/imports/qtqml/CMakeLists.txt
+++ b/src/imports/qtqml/CMakeLists.txt
@@ -14,7 +14,7 @@ endif()
## qmlplugin Plugin:
#####################################################################
-qt_add_qml_module(qmlplugin
+qt_internal_add_qml_module(qmlplugin
URI "QtQml"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
diff --git a/src/imports/qtquick2/CMakeLists.txt b/src/imports/qtquick2/CMakeLists.txt
index aed797189a..e7e29bf9ae 100644
--- a/src/imports/qtquick2/CMakeLists.txt
+++ b/src/imports/qtquick2/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquick2plugin Plugin:
#####################################################################
-qt_add_qml_module(qtquick2plugin
+qt_internal_add_qml_module(qtquick2plugin
URI "QtQuick"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
@@ -31,7 +31,7 @@ qt_add_qml_module(qtquick2plugin
## Scopes:
#####################################################################
-qt_extend_target(qtquick2plugin CONDITION QT_FEATURE_qml_worker_script
+qt_internal_extend_target(qtquick2plugin CONDITION QT_FEATURE_qml_worker_script
PUBLIC_LIBRARIES
Qt::QmlWorkerScriptPrivate
)
diff --git a/src/imports/settings/CMakeLists.txt b/src/imports/settings/CMakeLists.txt
index 0243e2cf8f..bb1c1aae8b 100644
--- a/src/imports/settings/CMakeLists.txt
+++ b/src/imports/settings/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlsettingsplugin Plugin:
#####################################################################
-qt_add_qml_module(qmlsettingsplugin
+qt_internal_add_qml_module(qmlsettingsplugin
URI "Qt.labs.settings"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QmlSettingsPlugin
diff --git a/src/imports/shapes/CMakeLists.txt b/src/imports/shapes/CMakeLists.txt
index 92ad133fd8..78f6d9f448 100644
--- a/src/imports/shapes/CMakeLists.txt
+++ b/src/imports/shapes/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlshapesplugin Plugin:
#####################################################################
-qt_add_qml_module(qmlshapesplugin
+qt_internal_add_qml_module(qmlshapesplugin
URI "QtQuick.Shapes"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QmlShapesPlugin
diff --git a/src/imports/sharedimage/CMakeLists.txt b/src/imports/sharedimage/CMakeLists.txt
index c840fda85f..5ec8533b23 100644
--- a/src/imports/sharedimage/CMakeLists.txt
+++ b/src/imports/sharedimage/CMakeLists.txt
@@ -4,7 +4,7 @@
## sharedimageplugin Plugin:
#####################################################################
-qt_add_qml_module(sharedimageplugin
+qt_internal_add_qml_module(sharedimageplugin
URI "Qt.labs.sharedimage"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QtQuickSharedImagePlugin
diff --git a/src/imports/testlib/CMakeLists.txt b/src/imports/testlib/CMakeLists.txt
index 2ce7598f62..27d0446405 100644
--- a/src/imports/testlib/CMakeLists.txt
+++ b/src/imports/testlib/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmltestplugin Plugin:
#####################################################################
-qt_add_qml_module(qmltestplugin
+qt_internal_add_qml_module(qmltestplugin
URI "QtTest"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QTestQmlModule
diff --git a/src/imports/wavefrontmesh/CMakeLists.txt b/src/imports/wavefrontmesh/CMakeLists.txt
index 3790b7d53e..b6b0008fb6 100644
--- a/src/imports/wavefrontmesh/CMakeLists.txt
+++ b/src/imports/wavefrontmesh/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlwavefrontmeshplugin Plugin:
#####################################################################
-qt_add_qml_module(qmlwavefrontmeshplugin
+qt_internal_add_qml_module(qmlwavefrontmeshplugin
URI "Qt.labs.wavefrontmesh"
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QmlWavefrontMeshPlugin
diff --git a/src/imports/workerscript/CMakeLists.txt b/src/imports/workerscript/CMakeLists.txt
index 2d437a04da..b2a6d0f444 100644
--- a/src/imports/workerscript/CMakeLists.txt
+++ b/src/imports/workerscript/CMakeLists.txt
@@ -4,7 +4,7 @@
## workerscriptplugin Plugin:
#####################################################################
-qt_add_qml_module(workerscriptplugin
+qt_internal_add_qml_module(workerscriptplugin
URI "QtQml.WorkerScript"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED