aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-07-09 14:09:06 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-07-09 15:51:40 +0200
commit0f19f571ee307dbe5fdebeb489d0c6cfcc8fa5ef (patch)
tree838ebcbebc0429dfeba724a1b052e577f5908b06 /src/imports
parent360a22838a9f6127702c35d9feb67560692df128 (diff)
CMake: Regenerate projects
We need the qt_add_tool changes to successfully configure qemu builds. The rest of the changes are just to be in sync with the .pro files. Change-Id: I7bcc08ac58f57a5761aedef09761428c55235289 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/models/.prev_CMakeLists.txt24
-rw-r--r--src/imports/models/CMakeLists.txt3
-rw-r--r--src/imports/workerscript/.prev_CMakeLists.txt24
-rw-r--r--src/imports/workerscript/CMakeLists.txt3
4 files changed, 52 insertions, 2 deletions
diff --git a/src/imports/models/.prev_CMakeLists.txt b/src/imports/models/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..89d65a22dc
--- /dev/null
+++ b/src/imports/models/.prev_CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from models.pro.
+
+#####################################################################
+## modelsplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(modelsplugin
+ URI "QtQml.Models"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlModelsPlugin
+ SKIP_TYPE_REGISTRATION
+ PLUGIN_OPTIONAL
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+)
+
+#### Keys ignored in scope 1:.:.:models.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQml/Models"
diff --git a/src/imports/models/CMakeLists.txt b/src/imports/models/CMakeLists.txt
index 7d08563f59..89d65a22dc 100644
--- a/src/imports/models/CMakeLists.txt
+++ b/src/imports/models/CMakeLists.txt
@@ -9,7 +9,8 @@ qt_add_qml_module(modelsplugin
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
CLASSNAME QtQmlModelsPlugin
- PLUGIN_OPTIONAL # special case
+ SKIP_TYPE_REGISTRATION
+ PLUGIN_OPTIONAL
SOURCES
plugin.cpp
PUBLIC_LIBRARIES
diff --git a/src/imports/workerscript/.prev_CMakeLists.txt b/src/imports/workerscript/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..2d437a04da
--- /dev/null
+++ b/src/imports/workerscript/.prev_CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from workerscript.pro.
+
+#####################################################################
+## workerscriptplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(workerscriptplugin
+ URI "QtQml.WorkerScript"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlWorkerScriptPlugin
+ SKIP_TYPE_REGISTRATION
+ PLUGIN_OPTIONAL
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::QmlPrivate
+ Qt::QmlWorkerScriptPrivate
+)
+
+#### Keys ignored in scope 1:.:.:workerscript.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQml/WorkerScript"
diff --git a/src/imports/workerscript/CMakeLists.txt b/src/imports/workerscript/CMakeLists.txt
index b1e98b2af6..2d437a04da 100644
--- a/src/imports/workerscript/CMakeLists.txt
+++ b/src/imports/workerscript/CMakeLists.txt
@@ -9,7 +9,8 @@ qt_add_qml_module(workerscriptplugin
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
CLASSNAME QtQmlWorkerScriptPlugin
- PLUGIN_OPTIONAL # special case
+ SKIP_TYPE_REGISTRATION
+ PLUGIN_OPTIONAL
SOURCES
plugin.cpp
PUBLIC_LIBRARIES