aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-06-02 16:50:20 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-06-09 08:01:02 +0200
commit5dc14c88f9510795835fb4f0a0d46d67c40f7020 (patch)
tree937173d548a6ad0d4c46cf75914adb6f6b140254 /src/imports
parent6a48a81319b886c8a3f85e1eb024186b05d0f3af (diff)
Allow QML plugins to be optional
If a plugin does nothing but load the library that provides the types, we can skip the plugin loading by linking the library directly. State that in the qmldir file, and evaluate it when loading the module. Task-number: QTBUG-84639 Change-Id: I2097237866a50f66c55e4653ad119fe10e18a893 Reviewed-by: Paul Wicking <paul.wicking@qt.io> Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/models/CMakeLists.txt2
-rw-r--r--src/imports/models/qmldir2
-rw-r--r--src/imports/workerscript/CMakeLists.txt2
-rw-r--r--src/imports/workerscript/qmldir2
4 files changed, 4 insertions, 4 deletions
diff --git a/src/imports/models/CMakeLists.txt b/src/imports/models/CMakeLists.txt
index a6d4065202..7d08563f59 100644
--- a/src/imports/models/CMakeLists.txt
+++ b/src/imports/models/CMakeLists.txt
@@ -9,7 +9,7 @@ qt_add_qml_module(modelsplugin
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
CLASSNAME QtQmlModelsPlugin
- SKIP_TYPE_REGISTRATION
+ PLUGIN_OPTIONAL # special case
SOURCES
plugin.cpp
PUBLIC_LIBRARIES
diff --git a/src/imports/models/qmldir b/src/imports/models/qmldir
index 2dd20b923e..341694a34d 100644
--- a/src/imports/models/qmldir
+++ b/src/imports/models/qmldir
@@ -1,4 +1,4 @@
module QtQml.Models
-plugin modelsplugin
+optional plugin modelsplugin
classname QtQmlModelsPlugin
designersupported
diff --git a/src/imports/workerscript/CMakeLists.txt b/src/imports/workerscript/CMakeLists.txt
index 57b2739a10..b1e98b2af6 100644
--- a/src/imports/workerscript/CMakeLists.txt
+++ b/src/imports/workerscript/CMakeLists.txt
@@ -9,7 +9,7 @@ qt_add_qml_module(workerscriptplugin
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
CLASSNAME QtQmlWorkerScriptPlugin
- SKIP_TYPE_REGISTRATION
+ PLUGIN_OPTIONAL # special case
SOURCES
plugin.cpp
PUBLIC_LIBRARIES
diff --git a/src/imports/workerscript/qmldir b/src/imports/workerscript/qmldir
index 02ff9ea188..f1ff798d75 100644
--- a/src/imports/workerscript/qmldir
+++ b/src/imports/workerscript/qmldir
@@ -1,4 +1,4 @@
module QtQml.WorkerScript
-plugin workerscriptplugin
+optional plugin workerscriptplugin
classname QtQmlWorkerScriptPlugin
designersupported