aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-09-03 13:25:05 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-09-19 08:06:24 +0000
commitec57196980e6a32fce3c56ec3c9f8183c7bcaad1 (patch)
treee416385c724ca5ca07ae57e5c8c77ec58e79f0a1 /src/imports
parent92025df4a52a2cf82e9a538968a8969cac08554c (diff)
Add qt6_add_qml_module() public API
Add qt6_add_qml_module() as a public API for building QML modules. Since the shared implementation details are small, it was easier to just reimplement the shared code than to unmangle the more complicated version we use to build Qt from QtBuild. This patch includes an example conversion. Changes for pro2cmake will follow in a separate patch in qtbase. Change-Id: I942526cc7d978e2d8309b506e785f9c1509d0bbc Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/folderlistmodel/CMakeLists.txt2
-rw-r--r--src/imports/labsanimation/CMakeLists.txt2
-rw-r--r--src/imports/labsmodels/CMakeLists.txt2
-rw-r--r--src/imports/layouts/CMakeLists.txt3
-rw-r--r--src/imports/localstorage/CMakeLists.txt2
-rw-r--r--src/imports/models/CMakeLists.txt3
-rw-r--r--src/imports/particles/CMakeLists.txt2
-rw-r--r--src/imports/qtqml/.prev_CMakeLists.txt6
-rw-r--r--src/imports/qtqml/CMakeLists.txt6
-rw-r--r--src/imports/qtquick2/CMakeLists.txt5
-rw-r--r--src/imports/settings/CMakeLists.txt2
-rw-r--r--src/imports/shapes/CMakeLists.txt2
-rw-r--r--src/imports/sharedimage/CMakeLists.txt2
-rw-r--r--src/imports/statemachine/CMakeLists.txt2
-rw-r--r--src/imports/testlib/.prev_CMakeLists.txt53
-rw-r--r--src/imports/testlib/CMakeLists.txt44
-rw-r--r--src/imports/wavefrontmesh/CMakeLists.txt2
-rw-r--r--src/imports/window/CMakeLists.txt3
-rw-r--r--src/imports/workerscript/CMakeLists.txt3
19 files changed, 113 insertions, 33 deletions
diff --git a/src/imports/folderlistmodel/CMakeLists.txt b/src/imports/folderlistmodel/CMakeLists.txt
index aca79ab471..7fba885fd9 100644
--- a/src/imports/folderlistmodel/CMakeLists.txt
+++ b/src/imports/folderlistmodel/CMakeLists.txt
@@ -5,9 +5,9 @@
#####################################################################
add_qml_module(qmlfolderlistmodelplugin
- CPP_PLUGIN
URI "Qt.labs.folderlistmodel"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QmlFolderListModelPlugin
SOURCES
fileinfothread.cpp fileinfothread_p.h
fileproperty_p.h
diff --git a/src/imports/labsanimation/CMakeLists.txt b/src/imports/labsanimation/CMakeLists.txt
index 972bbd72c5..9e3768ad75 100644
--- a/src/imports/labsanimation/CMakeLists.txt
+++ b/src/imports/labsanimation/CMakeLists.txt
@@ -5,9 +5,9 @@
#####################################################################
add_qml_module(labsanimationplugin
- CPP_PLUGIN
URI "Qt.labs.animation"
VERSION "1.0"
+ CLASSNAME QtLabsAnimationPlugin
SOURCES
plugin.cpp
LIBRARIES
diff --git a/src/imports/labsmodels/CMakeLists.txt b/src/imports/labsmodels/CMakeLists.txt
index a5f8670c46..84e778843f 100644
--- a/src/imports/labsmodels/CMakeLists.txt
+++ b/src/imports/labsmodels/CMakeLists.txt
@@ -5,9 +5,9 @@
#####################################################################
add_qml_module(labsmodelsplugin
- CPP_PLUGIN
URI "Qt.labs.qmlmodels"
VERSION "1.0"
+ CLASSNAME QtQmlLabsModelsPlugin
SOURCES
plugin.cpp
LIBRARIES
diff --git a/src/imports/layouts/CMakeLists.txt b/src/imports/layouts/CMakeLists.txt
index 1606740451..f75ec2eb9a 100644
--- a/src/imports/layouts/CMakeLists.txt
+++ b/src/imports/layouts/CMakeLists.txt
@@ -5,9 +5,10 @@
#####################################################################
add_qml_module(qquicklayoutsplugin
- CPP_PLUGIN
URI "QtQuick.Layouts"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQuickLayoutsPlugin
SOURCES
plugin.cpp
qquickgridlayoutengine.cpp qquickgridlayoutengine_p.h
diff --git a/src/imports/localstorage/CMakeLists.txt b/src/imports/localstorage/CMakeLists.txt
index 30830d66f4..2727b4dfa0 100644
--- a/src/imports/localstorage/CMakeLists.txt
+++ b/src/imports/localstorage/CMakeLists.txt
@@ -5,9 +5,9 @@
#####################################################################
add_qml_module(qmllocalstorageplugin
- CPP_PLUGIN
URI "QtQuick.LocalStorage"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QQmlLocalStoragePlugin
SOURCES
plugin.cpp
LIBRARIES
diff --git a/src/imports/models/CMakeLists.txt b/src/imports/models/CMakeLists.txt
index 0eacd2d5e0..9b06e998c9 100644
--- a/src/imports/models/CMakeLists.txt
+++ b/src/imports/models/CMakeLists.txt
@@ -5,10 +5,11 @@
#####################################################################
add_qml_module(modelsplugin
- CPP_PLUGIN
TARGET_PATH "QtQml/Models.2"
URI "QtQml.Models"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlModelsPlugin
SOURCES
plugin.cpp
LIBRARIES
diff --git a/src/imports/particles/CMakeLists.txt b/src/imports/particles/CMakeLists.txt
index 2643f6434e..f519891b49 100644
--- a/src/imports/particles/CMakeLists.txt
+++ b/src/imports/particles/CMakeLists.txt
@@ -5,10 +5,10 @@
#####################################################################
add_qml_module(particlesplugin
- CPP_PLUGIN
TARGET_PATH "QtQuick/Particles.2"
URI "QtQuick.Particles"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQuick2ParticlesPlugin
SOURCES
plugin.cpp
LIBRARIES
diff --git a/src/imports/qtqml/.prev_CMakeLists.txt b/src/imports/qtqml/.prev_CMakeLists.txt
index 2f64891d2b..5e5be848bd 100644
--- a/src/imports/qtqml/.prev_CMakeLists.txt
+++ b/src/imports/qtqml/.prev_CMakeLists.txt
@@ -5,9 +5,13 @@
#####################################################################
add_qml_module(qmlplugin
- CPP_PLUGIN
URI "QtQml"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlPlugin
+ IMPORTS
+ QtQml.Models
+ QtQml.WorkerScript
SOURCES
plugin.cpp
LIBRARIES
diff --git a/src/imports/qtqml/CMakeLists.txt b/src/imports/qtqml/CMakeLists.txt
index 03ef5a353c..855be1b62b 100644
--- a/src/imports/qtqml/CMakeLists.txt
+++ b/src/imports/qtqml/CMakeLists.txt
@@ -5,9 +5,13 @@
#####################################################################
add_qml_module(qmlplugin
- CPP_PLUGIN
URI "QtQml"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlPlugin
+ IMPORTS
+ QtQml.Models
+ QtQml.WorkerScript
SOURCES
plugin.cpp
LIBRARIES
diff --git a/src/imports/qtquick2/CMakeLists.txt b/src/imports/qtquick2/CMakeLists.txt
index 8612327795..f9026d5774 100644
--- a/src/imports/qtquick2/CMakeLists.txt
+++ b/src/imports/qtquick2/CMakeLists.txt
@@ -5,10 +5,13 @@
#####################################################################
add_qml_module(qtquick2plugin
- CPP_PLUGIN
TARGET_PATH "QtQuick.2"
URI "QtQuick"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQuick2Plugin
+ IMPORTS
+ QtQml
SOURCES
plugin.cpp
LIBRARIES
diff --git a/src/imports/settings/CMakeLists.txt b/src/imports/settings/CMakeLists.txt
index 0fc17698eb..f90b1a1040 100644
--- a/src/imports/settings/CMakeLists.txt
+++ b/src/imports/settings/CMakeLists.txt
@@ -5,9 +5,9 @@
#####################################################################
add_qml_module(qmlsettingsplugin
- CPP_PLUGIN
URI "Qt.labs.settings"
VERSION "1.1"
+ CLASSNAME QmlSettingsPlugin
SOURCES
plugin.cpp
qqmlsettings.cpp qqmlsettings_p.h
diff --git a/src/imports/shapes/CMakeLists.txt b/src/imports/shapes/CMakeLists.txt
index 6111f87d5e..9274fd14e7 100644
--- a/src/imports/shapes/CMakeLists.txt
+++ b/src/imports/shapes/CMakeLists.txt
@@ -5,9 +5,9 @@
#####################################################################
add_qml_module(qmlshapesplugin
- CPP_PLUGIN
URI "QtQuick.Shapes"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QmlShapesPlugin
SOURCES
plugin.cpp
LIBRARIES
diff --git a/src/imports/sharedimage/CMakeLists.txt b/src/imports/sharedimage/CMakeLists.txt
index ef49189923..266faa6dc5 100644
--- a/src/imports/sharedimage/CMakeLists.txt
+++ b/src/imports/sharedimage/CMakeLists.txt
@@ -5,9 +5,9 @@
#####################################################################
add_qml_module(sharedimageplugin
- CPP_PLUGIN
URI "Qt.labs.sharedimage"
VERSION "1.0"
+ CLASSNAME QtQuickSharedImagePlugin
SOURCES
plugin.cpp
qsharedimageloader.cpp qsharedimageloader_p.h
diff --git a/src/imports/statemachine/CMakeLists.txt b/src/imports/statemachine/CMakeLists.txt
index 02a1941b79..245c4aa681 100644
--- a/src/imports/statemachine/CMakeLists.txt
+++ b/src/imports/statemachine/CMakeLists.txt
@@ -5,9 +5,9 @@
#####################################################################
add_qml_module(qtqmlstatemachine
- CPP_PLUGIN
URI "QtQml.StateMachine"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QtQmlStateMachinePlugin
SOURCES
childrenprivate.h
finalstate.cpp finalstate.h
diff --git a/src/imports/testlib/.prev_CMakeLists.txt b/src/imports/testlib/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..7674568e16
--- /dev/null
+++ b/src/imports/testlib/.prev_CMakeLists.txt
@@ -0,0 +1,53 @@
+# Generated from testlib.pro.
+
+#####################################################################
+## qmltestplugin Plugin:
+#####################################################################
+
+add_qml_module(qmltestplugin
+ URI "QtTest"
+ VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QTestQmlModule
+ DEPENDENCIES
+ QtQuick.Window/2.0
+ SOURCES
+ main.cpp
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ Qt::QuickTestPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::Quick
+ Qt::QuickTest
+ Qt::Test
+)
+
+#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# OTHER_FILES = "testlib.json"
+# QML_FILES = "TestCase.qml" "SignalSpy.qml" "testlogger.js"
+# TARGETPATH = "QtTest"
+# _LOADED = "qml_plugin"
+
+set(qml_files
+ "TestCase.qml"
+ "SignalSpy.qml"
+ "testlogger.js"
+)
+set_source_files_properties(TestCase.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.2"
+ QT_QML_SOURCE_INSTALL TRUE
+)
+set_source_files_properties(SignalSpy.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+ QT_QML_SOURCE_INSTALL TRUE
+)
+
+qt6_target_qml_files(qmltestplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/testlib/CMakeLists.txt b/src/imports/testlib/CMakeLists.txt
index 89dd13ca0a..bbff88e788 100644
--- a/src/imports/testlib/CMakeLists.txt
+++ b/src/imports/testlib/CMakeLists.txt
@@ -5,9 +5,11 @@
#####################################################################
add_qml_module(qmltestplugin
- CPP_PLUGIN
URI "QtTest"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QTestQmlModule
+ DEPENDENCIES
+ QtQuick.Window/2.0
SOURCES
main.cpp
LIBRARIES
@@ -23,24 +25,34 @@ add_qml_module(qmltestplugin
Qt::Test
)
+#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
+# OTHER_FILES = "testlib.json"
+# QML_FILES = "TestCase.qml" "SignalSpy.qml" "testlogger.js"
+# TARGETPATH = "QtTest"
+# _LOADED = "qml_plugin"
+
set(qml_files
- TestCase.qml
- SignalSpy.qml
- testlogger.js
+ "TestCase.qml"
+ "SignalSpy.qml"
+ "testlogger.js"
+)
+set_source_files_properties(TestCase.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.2"
+ QT_QML_SOURCE_INSTALL TRUE
+)
+set_source_files_properties(SignalSpy.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+ QT_QML_SOURCE_INSTALL TRUE
+)
+# special case begin
+set_source_files_properties(testlogger.js PROPERTIES
+ QT_QML_SOURCE_INSTALL TRUE
)
+# special case end
-add_qt_resource(qmltestplugin qmake_QtTest
+qt6_target_qml_files(qmltestplugin
FILES
${qml_files}
)
-
-qt_install_qml_files(qmltestplugin
- FILES ${qml_files}
-)
-
-
-#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
-# CXX_MODULE = "qml"
-# IMPORT_VERSION = "1.$$QT_MINOR_VERSION"
-# OTHER_FILES = "testlib.json"
-# _LOADED = "qml_plugin"
diff --git a/src/imports/wavefrontmesh/CMakeLists.txt b/src/imports/wavefrontmesh/CMakeLists.txt
index 3162873b1a..8700cf9343 100644
--- a/src/imports/wavefrontmesh/CMakeLists.txt
+++ b/src/imports/wavefrontmesh/CMakeLists.txt
@@ -5,9 +5,9 @@
#####################################################################
add_qml_module(qmlwavefrontmeshplugin
- CPP_PLUGIN
URI "Qt.labs.wavefrontmesh"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
+ CLASSNAME QmlWavefrontMeshPlugin
SOURCES
plugin.cpp
qwavefrontmesh.cpp qwavefrontmesh.h
diff --git a/src/imports/window/CMakeLists.txt b/src/imports/window/CMakeLists.txt
index 7dd022a385..3c42234360 100644
--- a/src/imports/window/CMakeLists.txt
+++ b/src/imports/window/CMakeLists.txt
@@ -5,10 +5,11 @@
#####################################################################
add_qml_module(windowplugin
- CPP_PLUGIN
TARGET_PATH "QtQuick/Window.2"
URI "QtQuick.Window"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQuick2WindowPlugin
SOURCES
plugin.cpp
LIBRARIES
diff --git a/src/imports/workerscript/CMakeLists.txt b/src/imports/workerscript/CMakeLists.txt
index 6a8efc4d38..c17b76edc6 100644
--- a/src/imports/workerscript/CMakeLists.txt
+++ b/src/imports/workerscript/CMakeLists.txt
@@ -5,10 +5,11 @@
#####################################################################
add_qml_module(workerscriptplugin
- CPP_PLUGIN
TARGET_PATH "QtQml/WorkerScript.2"
URI "QtQml.WorkerScript"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlWorkerScriptPlugin
SOURCES
plugin.cpp
LIBRARIES