aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-12 15:27:58 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-12 15:28:15 +0100
commit8592ae4096f3f9c2b08b87ad2fcbbbfadf75f2d7 (patch)
treea757c1d80ec77952eae2cc4de5d89c01f14760fc /src/imports
parente7decc7637e9eb7e66a0d19705090f18488028c0 (diff)
parent14492ecee2e34843efd3ef070503a43a48552055 (diff)
Merge remote-tracking branch 'origin/wip/cmake' into dev
Conflicts: dependencies.yaml Change-Id: Ifff48b9d0e7962d481e63c49399e2d304e1011e5
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/CMakeLists.txt42
-rw-r--r--src/imports/builtins/.prev_CMakeLists.txt2
-rw-r--r--src/imports/builtins/CMakeLists.txt18
-rw-r--r--src/imports/folderlistmodel/CMakeLists.txt26
-rw-r--r--src/imports/labsanimation/CMakeLists.txt24
-rw-r--r--src/imports/labsmodels/CMakeLists.txt37
-rw-r--r--src/imports/layouts/CMakeLists.txt33
-rw-r--r--src/imports/localstorage/CMakeLists.txt26
-rw-r--r--src/imports/models/CMakeLists.txt23
-rw-r--r--src/imports/particles/CMakeLists.txt25
-rw-r--r--src/imports/qtqml/.prev_CMakeLists.txt41
-rw-r--r--src/imports/qtqml/CMakeLists.txt42
-rw-r--r--src/imports/qtquick2/CMakeLists.txt36
-rw-r--r--src/imports/settings/CMakeLists.txt24
-rw-r--r--src/imports/shapes/CMakeLists.txt25
-rw-r--r--src/imports/sharedimage/CMakeLists.txt29
-rw-r--r--src/imports/statemachine/CMakeLists.txt30
-rw-r--r--src/imports/testlib/.prev_CMakeLists.txt52
-rw-r--r--src/imports/testlib/CMakeLists.txt57
-rw-r--r--src/imports/wavefrontmesh/CMakeLists.txt25
-rw-r--r--src/imports/window/CMakeLists.txt26
-rw-r--r--src/imports/workerscript/CMakeLists.txt23
22 files changed, 666 insertions, 0 deletions
diff --git a/src/imports/CMakeLists.txt b/src/imports/CMakeLists.txt
new file mode 100644
index 0000000000..020f683e41
--- /dev/null
+++ b/src/imports/CMakeLists.txt
@@ -0,0 +1,42 @@
+# Generated from imports.pro.
+
+add_subdirectory(builtins)
+add_subdirectory(qtqml)
+add_subdirectory(models)
+add_subdirectory(labsmodels)
+if(QT_FEATURE_qml_itemmodel)
+ add_subdirectory(folderlistmodel)
+endif()
+if(QT_FEATURE_qml_worker_script)
+ add_subdirectory(workerscript)
+endif()
+if(TARGET Qt::Sql)
+ add_subdirectory(localstorage)
+endif()
+if(QT_FEATURE_settings)
+ add_subdirectory(settings)
+endif()
+if(QT_FEATURE_statemachine)
+ add_subdirectory(statemachine)
+endif()
+if(TARGET Qt::Quick)
+ add_subdirectory(labsanimation)
+ add_subdirectory(layouts)
+ add_subdirectory(qtquick2)
+ add_subdirectory(window)
+endif()
+if(QT_FEATURE_quick_shadereffect AND TARGET Qt::Quick)
+ add_subdirectory(wavefrontmesh)
+endif()
+if(TARGET Qt::Quick AND TARGET Qt::Test)
+ add_subdirectory(testlib)
+endif()
+if(QT_FEATURE_systemsemaphore AND TARGET Qt::Quick)
+ add_subdirectory(sharedimage)
+endif()
+if(QT_FEATURE_quick_particles AND TARGET Qt::Quick)
+ add_subdirectory(particles)
+endif()
+if(QT_FEATURE_quick_path AND TARGET Qt::Quick)
+ add_subdirectory(shapes)
+endif()
diff --git a/src/imports/builtins/.prev_CMakeLists.txt b/src/imports/builtins/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..088b0b73f0
--- /dev/null
+++ b/src/imports/builtins/.prev_CMakeLists.txt
@@ -0,0 +1,2 @@
+# Generated from builtins.pro.
+
diff --git a/src/imports/builtins/CMakeLists.txt b/src/imports/builtins/CMakeLists.txt
new file mode 100644
index 0000000000..93057d6605
--- /dev/null
+++ b/src/imports/builtins/CMakeLists.txt
@@ -0,0 +1,18 @@
+# Generated from builtins.pro.
+
+# special case begin
+
+set(qml_type_file builtins.qmltypes)
+
+qt_copy_or_install(FILES ${qml_type_file}
+ DESTINATION ${INSTALL_QMLDIR}
+)
+
+if (NOT CMAKE_CROSSCOMPILING)
+
+ add_custom_target(builtins_qmltypes
+ COMMAND qmlplugindump -builtins > ${CMAKE_CURRENT_SOURCE_DIR}/${qml_type_file}
+ )
+endif()
+
+# special case end
diff --git a/src/imports/folderlistmodel/CMakeLists.txt b/src/imports/folderlistmodel/CMakeLists.txt
new file mode 100644
index 0000000000..0bc9f28da6
--- /dev/null
+++ b/src/imports/folderlistmodel/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from folderlistmodel.pro.
+
+#####################################################################
+## qmlfolderlistmodelplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qmlfolderlistmodelplugin
+ URI "Qt.labs.folderlistmodel"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QmlFolderListModelPlugin
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ fileinfothread.cpp fileinfothread_p.h
+ fileproperty_p.h
+ plugin.cpp
+ qquickfolderlistmodel.cpp qquickfolderlistmodel.h
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+)
+
+#### Keys ignored in scope 1:.:.:folderlistmodel.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "Qt/labs/folderlistmodel"
diff --git a/src/imports/labsanimation/CMakeLists.txt b/src/imports/labsanimation/CMakeLists.txt
new file mode 100644
index 0000000000..a4de38267e
--- /dev/null
+++ b/src/imports/labsanimation/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from labsanimation.pro.
+
+#####################################################################
+## labsanimationplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(labsanimationplugin
+ URI "Qt.labs.animation"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QtLabsAnimationPlugin
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ plugin.cpp
+ qquickboundaryrule.cpp qquickboundaryrule_p.h
+ PUBLIC_LIBRARIES
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+)
+
+#### Keys ignored in scope 1:.:.:labsanimation.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "Qt/labs/animation"
diff --git a/src/imports/labsmodels/CMakeLists.txt b/src/imports/labsmodels/CMakeLists.txt
new file mode 100644
index 0000000000..efd3339e2f
--- /dev/null
+++ b/src/imports/labsmodels/CMakeLists.txt
@@ -0,0 +1,37 @@
+# Generated from labsmodels.pro.
+
+#####################################################################
+## labsmodelsplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(labsmodelsplugin
+ URI "Qt.labs.qmlmodels"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QtQmlLabsModelsPlugin
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+)
+
+#### Keys ignored in scope 1:.:.:labsmodels.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "Qt/labs/qmlmodels"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(labsmodelsplugin CONDITION QT_FEATURE_qml_table_model
+ SOURCES
+ qqmltablemodel.cpp qqmltablemodel_p.h
+ qqmltablemodelcolumn.cpp qqmltablemodelcolumn_p.h
+)
+
+qt_extend_target(labsmodelsplugin CONDITION QT_FEATURE_qml_delegate_model
+ SOURCES
+ qqmldelegatecomponent.cpp qqmldelegatecomponent_p.h
+)
diff --git a/src/imports/layouts/CMakeLists.txt b/src/imports/layouts/CMakeLists.txt
new file mode 100644
index 0000000000..ffde82d340
--- /dev/null
+++ b/src/imports/layouts/CMakeLists.txt
@@ -0,0 +1,33 @@
+# Generated from layouts.pro.
+
+#####################################################################
+## qquicklayoutsplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qquicklayoutsplugin
+ URI "QtQuick.Layouts"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQuickLayoutsPlugin
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ plugin.cpp
+ qquickgridlayoutengine.cpp qquickgridlayoutengine_p.h
+ qquicklayout.cpp qquicklayout_p.h
+ qquicklayoutstyleinfo.cpp qquicklayoutstyleinfo_p.h
+ qquicklinearlayout.cpp qquicklinearlayout_p.h
+ qquickstacklayout.cpp qquickstacklayout_p.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+)
+
+#### Keys ignored in scope 1:.:.:layouts.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQuick/Layouts"
diff --git a/src/imports/localstorage/CMakeLists.txt b/src/imports/localstorage/CMakeLists.txt
new file mode 100644
index 0000000000..d3fd8ff290
--- /dev/null
+++ b/src/imports/localstorage/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from localstorage.pro.
+
+#####################################################################
+## qmllocalstorageplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qmllocalstorageplugin
+ URI "QtQuick.LocalStorage"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QQmlLocalStoragePlugin
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ plugin.cpp
+ qquicklocalstorage.cpp qquicklocalstorage_p.h
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ Qt::Sql
+)
+
+#### Keys ignored in scope 1:.:.:localstorage.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# OTHER_FILES = "localstorage.json"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQuick/LocalStorage"
diff --git a/src/imports/models/CMakeLists.txt b/src/imports/models/CMakeLists.txt
new file mode 100644
index 0000000000..a6d4065202
--- /dev/null
+++ b/src/imports/models/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from models.pro.
+
+#####################################################################
+## modelsplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(modelsplugin
+ URI "QtQml.Models"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlModelsPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+)
+
+#### Keys ignored in scope 1:.:.:models.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQml/Models"
diff --git a/src/imports/particles/CMakeLists.txt b/src/imports/particles/CMakeLists.txt
new file mode 100644
index 0000000000..6d5e71f7d1
--- /dev/null
+++ b/src/imports/particles/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from particles.pro.
+
+#####################################################################
+## particlesplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(particlesplugin
+ URI "QtQuick.Particles"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QtQuick2ParticlesPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::QmlPrivate
+ Qt::QuickParticlesPrivate
+ Qt::QuickPrivate
+)
+
+#### Keys ignored in scope 1:.:.:particles.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQuick/Particles"
diff --git a/src/imports/qtqml/.prev_CMakeLists.txt b/src/imports/qtqml/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..4e17431218
--- /dev/null
+++ b/src/imports/qtqml/.prev_CMakeLists.txt
@@ -0,0 +1,41 @@
+# Generated from qtqml.pro.
+
+set(module_dynamic_qml_imports
+ QtQml.Models
+)
+
+if (QT_FEATURE_qml_worker_script)
+ list(APPEND module_dynamic_qml_imports
+ QtQml.WorkerScript
+ )
+endif()
+
+#####################################################################
+## qmlplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qmlplugin
+ URI "QtQml"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlPlugin
+ SKIP_TYPE_REGISTRATION
+ IMPORTS ${module_dynamic_qml_imports}
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+)
+
+#### Keys ignored in scope 1:.:.:qtqml.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# DYNAMIC_QMLDIR = "module QtQml" "plugin qmlplugin" "classname QtQmlPlugin" "typeinfo plugins.qmltypes" "designersupported" "import QtQml.Models"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQml"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qtqml.pro:QT_FEATURE_qml_worker_script:
+# DYNAMIC_QMLDIR = "import QtQml.WorkerScript"
diff --git a/src/imports/qtqml/CMakeLists.txt b/src/imports/qtqml/CMakeLists.txt
new file mode 100644
index 0000000000..f50f2f69f5
--- /dev/null
+++ b/src/imports/qtqml/CMakeLists.txt
@@ -0,0 +1,42 @@
+# Generated from qtqml.pro.
+
+set(module_dynamic_qml_imports
+ QtQml.Models
+)
+
+if (QT_FEATURE_qml_worker_script)
+ list(APPEND module_dynamic_qml_imports
+ QtQml.WorkerScript
+ )
+endif()
+
+#####################################################################
+## qmlplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qmlplugin
+ URI "QtQml"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlPlugin
+ SKIP_TYPE_REGISTRATION
+ IMPORTS ${module_dynamic_qml_imports}
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ Qt::CorePrivate # special case
+)
+
+#### Keys ignored in scope 1:.:.:qtqml.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# DYNAMIC_QMLDIR = "module QtQml" "plugin qmlplugin" "classname QtQmlPlugin" "typeinfo plugins.qmltypes" "designersupported" "import QtQml.Models"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQml"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qtqml.pro:QT_FEATURE_qml_worker_script:
+# DYNAMIC_QMLDIR = "import QtQml.WorkerScript"
diff --git a/src/imports/qtquick2/CMakeLists.txt b/src/imports/qtquick2/CMakeLists.txt
new file mode 100644
index 0000000000..e007c476f8
--- /dev/null
+++ b/src/imports/qtquick2/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Generated from qtquick2.pro.
+
+#####################################################################
+## qtquick2plugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qtquick2plugin
+ URI "QtQuick"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQuick2Plugin
+ SKIP_TYPE_REGISTRATION
+ IMPORTS
+ QtQml
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+)
+
+#### Keys ignored in scope 1:.:.:qtquick2.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQuick"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(qtquick2plugin CONDITION QT_FEATURE_qml_worker_script
+ PUBLIC_LIBRARIES
+ Qt::QmlWorkerScriptPrivate
+)
diff --git a/src/imports/settings/CMakeLists.txt b/src/imports/settings/CMakeLists.txt
new file mode 100644
index 0000000000..0243e2cf8f
--- /dev/null
+++ b/src/imports/settings/CMakeLists.txt
@@ -0,0 +1,24 @@
+# Generated from settings.pro.
+
+#####################################################################
+## qmlsettingsplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qmlsettingsplugin
+ URI "Qt.labs.settings"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QmlSettingsPlugin
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ plugin.cpp
+ qqmlsettings.cpp qqmlsettings_p.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:settings.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "Qt/labs/settings"
diff --git a/src/imports/shapes/CMakeLists.txt b/src/imports/shapes/CMakeLists.txt
new file mode 100644
index 0000000000..92ad133fd8
--- /dev/null
+++ b/src/imports/shapes/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from shapes.pro.
+
+#####################################################################
+## qmlshapesplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qmlshapesplugin
+ URI "QtQuick.Shapes"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QmlShapesPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::GuiPrivate
+ Qt::Qml
+ Qt::QuickPrivate
+ Qt::QuickShapesPrivate
+)
+
+#### Keys ignored in scope 1:.:.:shapes.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQuick/Shapes"
diff --git a/src/imports/sharedimage/CMakeLists.txt b/src/imports/sharedimage/CMakeLists.txt
new file mode 100644
index 0000000000..c840fda85f
--- /dev/null
+++ b/src/imports/sharedimage/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Generated from sharedimage.pro.
+
+#####################################################################
+## sharedimageplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(sharedimageplugin
+ URI "Qt.labs.sharedimage"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QtQuickSharedImagePlugin
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ plugin.cpp
+ qsharedimageloader.cpp qsharedimageloader_p.h
+ sharedimageprovider.cpp sharedimageprovider.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::Qml
+ Qt::QuickPrivate
+)
+
+#### Keys ignored in scope 1:.:.:sharedimage.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "Qt/labs/sharedimage"
diff --git a/src/imports/statemachine/CMakeLists.txt b/src/imports/statemachine/CMakeLists.txt
new file mode 100644
index 0000000000..232f3f28d5
--- /dev/null
+++ b/src/imports/statemachine/CMakeLists.txt
@@ -0,0 +1,30 @@
+# Generated from statemachine.pro.
+
+#####################################################################
+## qtqmlstatemachine Plugin:
+#####################################################################
+
+qt_add_qml_module(qtqmlstatemachine
+ URI "QtQml.StateMachine"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QtQmlStateMachinePlugin
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ childrenprivate.h
+ finalstate.cpp finalstate.h
+ plugin.cpp
+ signaltransition.cpp signaltransition.h
+ state.cpp state.h
+ statemachine.cpp statemachine.h
+ statemachineforeign.h
+ timeouttransition.cpp timeouttransition.h
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+)
+
+#### Keys ignored in scope 1:.:.:statemachine.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQml/StateMachine"
diff --git a/src/imports/testlib/.prev_CMakeLists.txt b/src/imports/testlib/.prev_CMakeLists.txt
new file mode 100644
index 0000000000..b7a6ff468a
--- /dev/null
+++ b/src/imports/testlib/.prev_CMakeLists.txt
@@ -0,0 +1,52 @@
+# Generated from testlib.pro.
+
+#####################################################################
+## qmltestplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qmltestplugin
+ URI "QtTest"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QTestQmlModule
+ DEPENDENCIES
+ QtQuick.Window/2.0
+ GENERATE_QMLTYPES
+ SOURCES
+ main.cpp
+ quicktestevent.cpp quicktestevent_p.h
+ quicktestresultforeign_p.h
+ quicktestutil.cpp quicktestutil_p.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::Quick
+ Qt::QuickTestPrivate
+ Qt::Test
+)
+
+#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# OTHER_FILES = "testlib.json"
+# QML_FILES = "TestCase.qml" "SignalSpy.qml" "testlogger.js"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtTest"
+
+set(qml_files
+ "TestCase.qml"
+ "SignalSpy.qml"
+ "testlogger.js"
+)
+set_source_files_properties(TestCase.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+)
+set_source_files_properties(SignalSpy.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+)
+
+qt6_target_qml_files(qmltestplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/testlib/CMakeLists.txt b/src/imports/testlib/CMakeLists.txt
new file mode 100644
index 0000000000..03801d76eb
--- /dev/null
+++ b/src/imports/testlib/CMakeLists.txt
@@ -0,0 +1,57 @@
+# Generated from testlib.pro.
+
+#####################################################################
+## qmltestplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qmltestplugin
+ URI "QtTest"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QTestQmlModule
+ DEPENDENCIES
+ QtQuick.Window/2.0
+ GENERATE_QMLTYPES
+ SOURCES
+ main.cpp
+ quicktestevent.cpp quicktestevent_p.h
+ quicktestresultforeign_p.h
+ quicktestutil.cpp quicktestutil_p.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::CorePrivate
+ Qt::Gui
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ Qt::Quick
+ Qt::QuickTestPrivate
+ Qt::Test
+)
+
+#### Keys ignored in scope 1:.:.:testlib.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# OTHER_FILES = "testlib.json"
+# QML_FILES = "TestCase.qml" "SignalSpy.qml" "testlogger.js"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtTest"
+
+set(qml_files
+ "TestCase.qml"
+ "SignalSpy.qml"
+ "testlogger.js"
+)
+set_source_files_properties(TestCase.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+)
+set_source_files_properties(SignalSpy.qml PROPERTIES
+ QT_QML_SOURCE_VERSION "1.0"
+)
+# special case begin
+set_source_files_properties(testlogger.js PROPERTIES
+ QT_QML_SOURCE_INSTALL TRUE
+)
+# special case end
+
+qt6_target_qml_files(qmltestplugin
+ FILES
+ ${qml_files}
+)
diff --git a/src/imports/wavefrontmesh/CMakeLists.txt b/src/imports/wavefrontmesh/CMakeLists.txt
new file mode 100644
index 0000000000..3790b7d53e
--- /dev/null
+++ b/src/imports/wavefrontmesh/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from wavefrontmesh.pro.
+
+#####################################################################
+## qmlwavefrontmeshplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(qmlwavefrontmeshplugin
+ URI "Qt.labs.wavefrontmesh"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ CLASSNAME QmlWavefrontMeshPlugin
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ plugin.cpp
+ qwavefrontmesh.cpp qwavefrontmesh.h
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+)
+
+#### Keys ignored in scope 1:.:.:wavefrontmesh.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "Qt/labs/wavefrontmesh"
diff --git a/src/imports/window/CMakeLists.txt b/src/imports/window/CMakeLists.txt
new file mode 100644
index 0000000000..99cedf333c
--- /dev/null
+++ b/src/imports/window/CMakeLists.txt
@@ -0,0 +1,26 @@
+# Generated from window.pro.
+
+#####################################################################
+## windowplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(windowplugin
+ URI "QtQuick.Window"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQuick2WindowPlugin
+ SKIP_TYPE_REGISTRATION
+ GENERATE_QMLTYPES
+ SOURCES
+ plugin.cpp plugin.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::QmlPrivate
+ Qt::QuickPrivate
+)
+
+#### Keys ignored in scope 1:.:.:window.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQuick/Window"
diff --git a/src/imports/workerscript/CMakeLists.txt b/src/imports/workerscript/CMakeLists.txt
new file mode 100644
index 0000000000..57b2739a10
--- /dev/null
+++ b/src/imports/workerscript/CMakeLists.txt
@@ -0,0 +1,23 @@
+# Generated from workerscript.pro.
+
+#####################################################################
+## workerscriptplugin Plugin:
+#####################################################################
+
+qt_add_qml_module(workerscriptplugin
+ URI "QtQml.WorkerScript"
+ VERSION "${CMAKE_PROJECT_VERSION}"
+ DESIGNER_SUPPORTED
+ CLASSNAME QtQmlWorkerScriptPlugin
+ SKIP_TYPE_REGISTRATION
+ SOURCES
+ plugin.cpp
+ PUBLIC_LIBRARIES
+ Qt::QmlPrivate
+ Qt::QmlWorkerScriptPrivate
+)
+
+#### Keys ignored in scope 1:.:.:workerscript.pro:<TRUE>:
+# CXX_MODULE = "qml"
+# QML_IMPORT_VERSION = "$$QT_VERSION"
+# TARGETPATH = "QtQml/WorkerScript"