aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-05 11:39:32 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-05 14:36:38 +0000
commitd15665b69323dd25ac075d60007d47dff3bc824b (patch)
tree35e195322e764399e55d6370e07a792c592e4fa1 /src/imports
parent426585304e8e862dc2209a53a9c800838490154c (diff)
Regenerate projects to handle private deps correctly
Change-Id: Ifcbab0407e93dfc35d0459d7d29dee2cd3508a86 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/folderlistmodel/CMakeLists.txt5
-rw-r--r--src/imports/labsanimation/CMakeLists.txt5
-rw-r--r--src/imports/labsmodels/CMakeLists.txt5
-rw-r--r--src/imports/layouts/CMakeLists.txt9
-rw-r--r--src/imports/localstorage/CMakeLists.txt5
-rw-r--r--src/imports/models/CMakeLists.txt5
-rw-r--r--src/imports/particles/CMakeLists.txt10
-rw-r--r--src/imports/qtqml/.prev_CMakeLists.txt5
-rw-r--r--src/imports/qtqml/CMakeLists.txt5
-rw-r--r--src/imports/qtquick2/CMakeLists.txt14
-rw-r--r--src/imports/shapes/CMakeLists.txt10
-rw-r--r--src/imports/sharedimage/CMakeLists.txt8
-rw-r--r--src/imports/statemachine/CMakeLists.txt5
-rw-r--r--src/imports/testlib/.prev_CMakeLists.txt11
-rw-r--r--src/imports/testlib/CMakeLists.txt11
-rw-r--r--src/imports/wavefrontmesh/CMakeLists.txt6
-rw-r--r--src/imports/window/CMakeLists.txt7
-rw-r--r--src/imports/workerscript/CMakeLists.txt5
18 files changed, 36 insertions, 95 deletions
diff --git a/src/imports/folderlistmodel/CMakeLists.txt b/src/imports/folderlistmodel/CMakeLists.txt
index 56f953d6bc..cc2249c5d0 100644
--- a/src/imports/folderlistmodel/CMakeLists.txt
+++ b/src/imports/folderlistmodel/CMakeLists.txt
@@ -15,12 +15,9 @@ qt_add_qml_module(qmlfolderlistmodelplugin
fileproperty_p.h
plugin.cpp
qquickfolderlistmodel.cpp qquickfolderlistmodel.h
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlPrivate
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Qml
)
#### Keys ignored in scope 1:.:.:folderlistmodel.pro:<TRUE>:
diff --git a/src/imports/labsanimation/CMakeLists.txt b/src/imports/labsanimation/CMakeLists.txt
index f9665cfb27..a8830231da 100644
--- a/src/imports/labsanimation/CMakeLists.txt
+++ b/src/imports/labsanimation/CMakeLists.txt
@@ -13,12 +13,9 @@ qt_add_qml_module(labsanimationplugin
SOURCES
plugin.cpp
qquickboundaryrule.cpp qquickboundaryrule_p.h
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::QmlPrivate
Qt::QuickPrivate
- PUBLIC_LIBRARIES
- Qt::Qml
- Qt::Quick
)
#### Keys ignored in scope 1:.:.:labsanimation.pro:<TRUE>:
diff --git a/src/imports/labsmodels/CMakeLists.txt b/src/imports/labsmodels/CMakeLists.txt
index 06c8a020d7..358bd5df18 100644
--- a/src/imports/labsmodels/CMakeLists.txt
+++ b/src/imports/labsmodels/CMakeLists.txt
@@ -12,12 +12,9 @@ qt_add_qml_module(labsmodelsplugin
GENERATE_QMLTYPES
SOURCES
plugin.cpp
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::QmlModelsPrivate
Qt::QmlPrivate
- PUBLIC_LIBRARIES
- Qt::Qml
- Qt::QmlModels
)
#### Keys ignored in scope 1:.:.:labsmodels.pro:<TRUE>:
diff --git a/src/imports/layouts/CMakeLists.txt b/src/imports/layouts/CMakeLists.txt
index 43637d3d0b..f788bd3f5a 100644
--- a/src/imports/layouts/CMakeLists.txt
+++ b/src/imports/layouts/CMakeLists.txt
@@ -18,16 +18,13 @@ qt_add_qml_module(qquicklayoutsplugin
qquicklayoutstyleinfo.cpp qquicklayoutstyleinfo_p.h
qquicklinearlayout.cpp qquicklinearlayout_p.h
qquickstacklayout.cpp qquickstacklayout_p.h
- LIBRARIES
+ PUBLIC_LIBRARIES
+ Qt::Core
Qt::CorePrivate
+ Qt::Gui
Qt::GuiPrivate
Qt::QmlPrivate
Qt::QuickPrivate
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Gui
- Qt::Qml
- Qt::Quick
)
#### Keys ignored in scope 1:.:.:layouts.pro:<TRUE>:
diff --git a/src/imports/localstorage/CMakeLists.txt b/src/imports/localstorage/CMakeLists.txt
index cc980eb5e0..4727de7f93 100644
--- a/src/imports/localstorage/CMakeLists.txt
+++ b/src/imports/localstorage/CMakeLists.txt
@@ -13,12 +13,9 @@ qt_add_qml_module(qmllocalstorageplugin
SOURCES
plugin.cpp
qquicklocalstorage.cpp qquicklocalstorage_p.h
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlPrivate
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Qml
Qt::Sql
)
diff --git a/src/imports/models/CMakeLists.txt b/src/imports/models/CMakeLists.txt
index 90abdaa743..0efe8eb479 100644
--- a/src/imports/models/CMakeLists.txt
+++ b/src/imports/models/CMakeLists.txt
@@ -12,12 +12,9 @@ qt_add_qml_module(modelsplugin
SKIP_TYPE_REGISTRATION
SOURCES
plugin.cpp
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::QmlModelsPrivate
Qt::QmlPrivate
- PUBLIC_LIBRARIES
- Qt::Qml
- Qt::QmlModels
)
#### Keys ignored in scope 1:.:.:models.pro:<TRUE>:
diff --git a/src/imports/particles/CMakeLists.txt b/src/imports/particles/CMakeLists.txt
index d20d5eecba..8326575cdc 100644
--- a/src/imports/particles/CMakeLists.txt
+++ b/src/imports/particles/CMakeLists.txt
@@ -11,16 +11,12 @@ qt_add_qml_module(particlesplugin
SKIP_TYPE_REGISTRATION
SOURCES
plugin.cpp
- LIBRARIES
- Qt::QmlPrivate
- Qt::QuickParticlesPrivate
- Qt::QuickPrivate
PUBLIC_LIBRARIES
Qt::Core
Qt::Gui
- Qt::Qml
- Qt::Quick
- Qt::QuickParticles
+ Qt::QmlPrivate
+ Qt::QuickParticlesPrivate
+ Qt::QuickPrivate
)
#### Keys ignored in scope 1:.:.:particles.pro:<TRUE>:
diff --git a/src/imports/qtqml/.prev_CMakeLists.txt b/src/imports/qtqml/.prev_CMakeLists.txt
index de771ce3d2..7db224aa44 100644
--- a/src/imports/qtqml/.prev_CMakeLists.txt
+++ b/src/imports/qtqml/.prev_CMakeLists.txt
@@ -23,12 +23,9 @@ qt_add_qml_module(qmlplugin
IMPORTS ${module_dynamic_qml_imports}
SOURCES
plugin.cpp
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::QmlModelsPrivate
Qt::QmlPrivate
- PUBLIC_LIBRARIES
- Qt::Qml
- Qt::QmlModels
)
#### Keys ignored in scope 1:.:.:qtqml.pro:<TRUE>:
diff --git a/src/imports/qtqml/CMakeLists.txt b/src/imports/qtqml/CMakeLists.txt
index 925f39e8b5..705d4c965b 100644
--- a/src/imports/qtqml/CMakeLists.txt
+++ b/src/imports/qtqml/CMakeLists.txt
@@ -23,13 +23,10 @@ qt_add_qml_module(qmlplugin
IMPORTS ${module_dynamic_qml_imports}
SOURCES
plugin.cpp
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::QmlModelsPrivate
Qt::QmlPrivate
Qt::CorePrivate # special case
- PUBLIC_LIBRARIES
- Qt::Qml
- Qt::QmlModels
)
#### Keys ignored in scope 1:.:.:qtqml.pro:<TRUE>:
diff --git a/src/imports/qtquick2/CMakeLists.txt b/src/imports/qtquick2/CMakeLists.txt
index 2973edb02f..6b017885ae 100644
--- a/src/imports/qtquick2/CMakeLists.txt
+++ b/src/imports/qtquick2/CMakeLists.txt
@@ -14,16 +14,12 @@ qt_add_qml_module(qtquick2plugin
QtQml
SOURCES
plugin.cpp
- LIBRARIES
- Qt::QmlModelsPrivate
- Qt::QmlPrivate
- Qt::QuickPrivate
PUBLIC_LIBRARIES
Qt::Core
Qt::Gui
- Qt::Qml
- Qt::QmlModels
- Qt::Quick
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ Qt::QuickPrivate
)
#### Keys ignored in scope 1:.:.:qtquick2.pro:<TRUE>:
@@ -35,8 +31,6 @@ qt_add_qml_module(qtquick2plugin
#####################################################################
qt_extend_target(qtquick2plugin CONDITION QT_FEATURE_qml_worker_script
- LIBRARIES
- Qt::QmlWorkerScriptPrivate
PUBLIC_LIBRARIES
- Qt::QmlWorkerScript
+ Qt::QmlWorkerScriptPrivate
)
diff --git a/src/imports/shapes/CMakeLists.txt b/src/imports/shapes/CMakeLists.txt
index 512b33ff73..c745ccd038 100644
--- a/src/imports/shapes/CMakeLists.txt
+++ b/src/imports/shapes/CMakeLists.txt
@@ -11,16 +11,12 @@ qt_add_qml_module(qmlshapesplugin
SKIP_TYPE_REGISTRATION
SOURCES
plugin.cpp
- LIBRARIES
- Qt::GuiPrivate
- Qt::QuickPrivate
- Qt::QuickShapesPrivate
PUBLIC_LIBRARIES
Qt::Core
- Qt::Gui
+ Qt::GuiPrivate
Qt::Qml
- Qt::Quick
- Qt::QuickShapes
+ Qt::QuickPrivate
+ Qt::QuickShapesPrivate
)
#### Keys ignored in scope 1:.:.:shapes.pro:<TRUE>:
diff --git a/src/imports/sharedimage/CMakeLists.txt b/src/imports/sharedimage/CMakeLists.txt
index 2a5f08af33..b6d61cf1e5 100644
--- a/src/imports/sharedimage/CMakeLists.txt
+++ b/src/imports/sharedimage/CMakeLists.txt
@@ -14,15 +14,13 @@ qt_add_qml_module(sharedimageplugin
plugin.cpp
qsharedimageloader.cpp qsharedimageloader_p.h
sharedimageprovider.cpp sharedimageprovider.h
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::QuickPrivate
PUBLIC_LIBRARIES
Qt::Core
+ Qt::CorePrivate
Qt::Gui
+ Qt::GuiPrivate
Qt::Qml
- Qt::Quick
+ Qt::QuickPrivate
)
#### Keys ignored in scope 1:.:.:sharedimage.pro:<TRUE>:
diff --git a/src/imports/statemachine/CMakeLists.txt b/src/imports/statemachine/CMakeLists.txt
index a20051d148..4e4b73cc7d 100644
--- a/src/imports/statemachine/CMakeLists.txt
+++ b/src/imports/statemachine/CMakeLists.txt
@@ -19,12 +19,9 @@ qt_add_qml_module(qtqmlstatemachine
statemachine.cpp statemachine.h
statemachineforeign.h
timeouttransition.cpp timeouttransition.h
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlPrivate
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Qml
)
#### Keys ignored in scope 1:.:.:statemachine.pro:<TRUE>:
diff --git a/src/imports/testlib/.prev_CMakeLists.txt b/src/imports/testlib/.prev_CMakeLists.txt
index 864afa71d5..43c30c7f39 100644
--- a/src/imports/testlib/.prev_CMakeLists.txt
+++ b/src/imports/testlib/.prev_CMakeLists.txt
@@ -16,17 +16,14 @@ qt_add_qml_module(qmltestplugin
quicktestevent.cpp quicktestevent_p.h
quicktestresultforeign_p.h
quicktestutil.cpp quicktestutil_p.h
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::QmlPrivate
- Qt::QuickTestPrivate
PUBLIC_LIBRARIES
Qt::Core
+ Qt::CorePrivate
Qt::Gui
- Qt::Qml
+ Qt::GuiPrivate
+ Qt::QmlPrivate
Qt::Quick
- Qt::QuickTest
+ Qt::QuickTestPrivate
Qt::Test
)
diff --git a/src/imports/testlib/CMakeLists.txt b/src/imports/testlib/CMakeLists.txt
index cdc3709dd9..18f1751d61 100644
--- a/src/imports/testlib/CMakeLists.txt
+++ b/src/imports/testlib/CMakeLists.txt
@@ -16,17 +16,14 @@ qt_add_qml_module(qmltestplugin
quicktestevent.cpp quicktestevent_p.h
quicktestresultforeign_p.h
quicktestutil.cpp quicktestutil_p.h
- LIBRARIES
- Qt::CorePrivate
- Qt::GuiPrivate
- Qt::QmlPrivate
- Qt::QuickTestPrivate
PUBLIC_LIBRARIES
Qt::Core
+ Qt::CorePrivate
Qt::Gui
- Qt::Qml
+ Qt::GuiPrivate
+ Qt::QmlPrivate
Qt::Quick
- Qt::QuickTest
+ Qt::QuickTestPrivate
Qt::Test
)
diff --git a/src/imports/wavefrontmesh/CMakeLists.txt b/src/imports/wavefrontmesh/CMakeLists.txt
index 9cb11a590d..be083aede5 100644
--- a/src/imports/wavefrontmesh/CMakeLists.txt
+++ b/src/imports/wavefrontmesh/CMakeLists.txt
@@ -13,14 +13,10 @@ qt_add_qml_module(qmlwavefrontmeshplugin
SOURCES
plugin.cpp
qwavefrontmesh.cpp qwavefrontmesh.h
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlPrivate
Qt::QuickPrivate
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Qml
- Qt::Quick
)
#### Keys ignored in scope 1:.:.:wavefrontmesh.pro:<TRUE>:
diff --git a/src/imports/window/CMakeLists.txt b/src/imports/window/CMakeLists.txt
index 17e0496b2c..c300126bac 100644
--- a/src/imports/window/CMakeLists.txt
+++ b/src/imports/window/CMakeLists.txt
@@ -13,14 +13,11 @@ qt_add_qml_module(windowplugin
GENERATE_QMLTYPES
SOURCES
plugin.cpp plugin.h
- LIBRARIES
- Qt::QmlPrivate
- Qt::QuickPrivate
PUBLIC_LIBRARIES
Qt::Core
Qt::Gui
- Qt::Qml
- Qt::Quick
+ Qt::QmlPrivate
+ Qt::QuickPrivate
)
#### Keys ignored in scope 1:.:.:window.pro:<TRUE>:
diff --git a/src/imports/workerscript/CMakeLists.txt b/src/imports/workerscript/CMakeLists.txt
index b711cf4593..ac2b0fda7e 100644
--- a/src/imports/workerscript/CMakeLists.txt
+++ b/src/imports/workerscript/CMakeLists.txt
@@ -12,12 +12,9 @@ qt_add_qml_module(workerscriptplugin
SKIP_TYPE_REGISTRATION
SOURCES
plugin.cpp
- LIBRARIES
+ PUBLIC_LIBRARIES
Qt::QmlPrivate
Qt::QmlWorkerScriptPrivate
- PUBLIC_LIBRARIES
- Qt::Qml
- Qt::QmlWorkerScript
)
#### Keys ignored in scope 1:.:.:workerscript.pro:<TRUE>: