aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorCraig Scott <craig.scott@qt.io>2021-03-03 23:17:17 +1100
committerCraig Scott <craig.scott@qt.io>2021-03-31 21:40:49 +1100
commit3d09e9c2f521c638a312378e3c7f137accfe8212 (patch)
tree9a33804b8f9f8568dff98e2614a4ac83b77eb7b0 /src/imports
parent661f120c1d9e00aff31c432f84f83f58b8aa9c9a (diff)
Use CLASS_NAME rather than CLASSNAME for qt6_add_qml_module()
Task-number: QTBUG-88763 Change-Id: I118227ec418ac59eb6603d236b38b1a4319a51c2 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/folderlistmodel/CMakeLists.txt2
-rw-r--r--src/imports/labsanimation/CMakeLists.txt2
-rw-r--r--src/imports/labsmodels/CMakeLists.txt2
-rw-r--r--src/imports/layouts/CMakeLists.txt2
-rw-r--r--src/imports/localstorage/CMakeLists.txt2
-rw-r--r--src/imports/models/CMakeLists.txt2
-rw-r--r--src/imports/particles/CMakeLists.txt2
-rw-r--r--src/imports/qtqml/CMakeLists.txt2
-rw-r--r--src/imports/qtquick2/CMakeLists.txt2
-rw-r--r--src/imports/settings/CMakeLists.txt2
-rw-r--r--src/imports/shapes/CMakeLists.txt2
-rw-r--r--src/imports/sharedimage/CMakeLists.txt2
-rw-r--r--src/imports/testlib/CMakeLists.txt2
-rw-r--r--src/imports/wavefrontmesh/CMakeLists.txt2
-rw-r--r--src/imports/workerscript/CMakeLists.txt2
-rw-r--r--src/imports/xmllistmodel/CMakeLists.txt2
16 files changed, 16 insertions, 16 deletions
diff --git a/src/imports/folderlistmodel/CMakeLists.txt b/src/imports/folderlistmodel/CMakeLists.txt
index 85a43061f4..a40c33bea3 100644
--- a/src/imports/folderlistmodel/CMakeLists.txt
+++ b/src/imports/folderlistmodel/CMakeLists.txt
@@ -7,7 +7,7 @@
qt_internal_add_qml_module(qmlfolderlistmodelplugin
URI "Qt.labs.folderlistmodel"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QmlFolderListModelPlugin
+ CLASS_NAME QmlFolderListModelPlugin
SKIP_TYPE_REGISTRATION
PLUGIN_OPTIONAL
SOURCES
diff --git a/src/imports/labsanimation/CMakeLists.txt b/src/imports/labsanimation/CMakeLists.txt
index cdf50468ac..bd8d6b1e79 100644
--- a/src/imports/labsanimation/CMakeLists.txt
+++ b/src/imports/labsanimation/CMakeLists.txt
@@ -7,7 +7,7 @@
qt_internal_add_qml_module(labsanimationplugin
URI "Qt.labs.animation"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QtLabsAnimationPlugin
+ CLASS_NAME QtLabsAnimationPlugin
SKIP_TYPE_REGISTRATION
PLUGIN_OPTIONAL
SOURCES
diff --git a/src/imports/labsmodels/CMakeLists.txt b/src/imports/labsmodels/CMakeLists.txt
index 0c59a15a20..c54ae32f1f 100644
--- a/src/imports/labsmodels/CMakeLists.txt
+++ b/src/imports/labsmodels/CMakeLists.txt
@@ -7,7 +7,7 @@
qt_internal_add_qml_module(labsmodelsplugin
URI "Qt.labs.qmlmodels"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QtQmlLabsModelsPlugin
+ CLASS_NAME QtQmlLabsModelsPlugin
SKIP_TYPE_REGISTRATION
PLUGIN_OPTIONAL
SOURCES
diff --git a/src/imports/layouts/CMakeLists.txt b/src/imports/layouts/CMakeLists.txt
index 6cfb911ba9..f912f2db0b 100644
--- a/src/imports/layouts/CMakeLists.txt
+++ b/src/imports/layouts/CMakeLists.txt
@@ -9,7 +9,7 @@ qt_internal_add_qml_module(qquicklayoutsplugin
URI "QtQuick.Layouts"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
- CLASSNAME QtQuickLayoutsPlugin
+ CLASS_NAME QtQuickLayoutsPlugin
SKIP_TYPE_REGISTRATION
DEPENDENCIES
QtQuick
diff --git a/src/imports/localstorage/CMakeLists.txt b/src/imports/localstorage/CMakeLists.txt
index 9d7cd13fe0..90c66d977f 100644
--- a/src/imports/localstorage/CMakeLists.txt
+++ b/src/imports/localstorage/CMakeLists.txt
@@ -7,7 +7,7 @@
qt_internal_add_qml_module(qmllocalstorageplugin
URI "QtQuick.LocalStorage"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QQmlLocalStoragePlugin
+ CLASS_NAME QQmlLocalStoragePlugin
SKIP_TYPE_REGISTRATION
PLUGIN_OPTIONAL
SOURCES
diff --git a/src/imports/models/CMakeLists.txt b/src/imports/models/CMakeLists.txt
index 4070ad365b..1c59a0830d 100644
--- a/src/imports/models/CMakeLists.txt
+++ b/src/imports/models/CMakeLists.txt
@@ -8,7 +8,7 @@ qt_internal_add_qml_module(modelsplugin
URI "QtQml.Models"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
- CLASSNAME QtQmlModelsPlugin
+ CLASS_NAME QtQmlModelsPlugin
SKIP_TYPE_REGISTRATION
PLUGIN_OPTIONAL
SOURCES
diff --git a/src/imports/particles/CMakeLists.txt b/src/imports/particles/CMakeLists.txt
index 7ecdc70544..429f84158a 100644
--- a/src/imports/particles/CMakeLists.txt
+++ b/src/imports/particles/CMakeLists.txt
@@ -7,7 +7,7 @@
qt_internal_add_qml_module(particlesplugin
URI "QtQuick.Particles"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QtQuick2ParticlesPlugin
+ CLASS_NAME QtQuick2ParticlesPlugin
SKIP_TYPE_REGISTRATION
PLUGIN_OPTIONAL
SOURCES
diff --git a/src/imports/qtqml/CMakeLists.txt b/src/imports/qtqml/CMakeLists.txt
index 15e66fd53e..f4586b988d 100644
--- a/src/imports/qtqml/CMakeLists.txt
+++ b/src/imports/qtqml/CMakeLists.txt
@@ -18,7 +18,7 @@ qt_internal_add_qml_module(qmlplugin
URI "QtQml"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
- CLASSNAME QtQmlPlugin
+ CLASS_NAME QtQmlPlugin
SKIP_TYPE_REGISTRATION
IMPORTS ${module_dynamic_qml_imports}
PLUGIN_OPTIONAL
diff --git a/src/imports/qtquick2/CMakeLists.txt b/src/imports/qtquick2/CMakeLists.txt
index e7e29bf9ae..40ea4a85c4 100644
--- a/src/imports/qtquick2/CMakeLists.txt
+++ b/src/imports/qtquick2/CMakeLists.txt
@@ -8,7 +8,7 @@ qt_internal_add_qml_module(qtquick2plugin
URI "QtQuick"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
- CLASSNAME QtQuick2Plugin
+ CLASS_NAME QtQuick2Plugin
SKIP_TYPE_REGISTRATION
IMPORTS
QtQml/auto
diff --git a/src/imports/settings/CMakeLists.txt b/src/imports/settings/CMakeLists.txt
index f49e741106..9f00e79a36 100644
--- a/src/imports/settings/CMakeLists.txt
+++ b/src/imports/settings/CMakeLists.txt
@@ -7,7 +7,7 @@
qt_internal_add_qml_module(qmlsettingsplugin
URI "Qt.labs.settings"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QmlSettingsPlugin
+ CLASS_NAME QmlSettingsPlugin
SKIP_TYPE_REGISTRATION
PLUGIN_OPTIONAL
SOURCES
diff --git a/src/imports/shapes/CMakeLists.txt b/src/imports/shapes/CMakeLists.txt
index fa1eb9297c..99c907cbcc 100644
--- a/src/imports/shapes/CMakeLists.txt
+++ b/src/imports/shapes/CMakeLists.txt
@@ -7,7 +7,7 @@
qt_internal_add_qml_module(qmlshapesplugin
URI "QtQuick.Shapes"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QmlShapesPlugin
+ CLASS_NAME QmlShapesPlugin
SKIP_TYPE_REGISTRATION
DEPENDENCIES
QtQuick
diff --git a/src/imports/sharedimage/CMakeLists.txt b/src/imports/sharedimage/CMakeLists.txt
index b0faea295f..62a3fb4983 100644
--- a/src/imports/sharedimage/CMakeLists.txt
+++ b/src/imports/sharedimage/CMakeLists.txt
@@ -7,7 +7,7 @@
qt_internal_add_qml_module(sharedimageplugin
URI "Qt.labs.sharedimage"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QtQuickSharedImagePlugin
+ CLASS_NAME QtQuickSharedImagePlugin
SKIP_TYPE_REGISTRATION
SOURCES
plugin.cpp
diff --git a/src/imports/testlib/CMakeLists.txt b/src/imports/testlib/CMakeLists.txt
index e94d1edc76..593b8c772c 100644
--- a/src/imports/testlib/CMakeLists.txt
+++ b/src/imports/testlib/CMakeLists.txt
@@ -7,7 +7,7 @@
qt_internal_add_qml_module(qmltestplugin
URI "QtTest"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QTestQmlModule
+ CLASS_NAME QTestQmlModule
DEPENDENCIES
QtQuick.Window/2.0
SOURCES
diff --git a/src/imports/wavefrontmesh/CMakeLists.txt b/src/imports/wavefrontmesh/CMakeLists.txt
index 7dd97c8056..0202f2b08a 100644
--- a/src/imports/wavefrontmesh/CMakeLists.txt
+++ b/src/imports/wavefrontmesh/CMakeLists.txt
@@ -7,7 +7,7 @@
qt_internal_add_qml_module(qmlwavefrontmeshplugin
URI "Qt.labs.wavefrontmesh"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QmlWavefrontMeshPlugin
+ CLASS_NAME QmlWavefrontMeshPlugin
SKIP_TYPE_REGISTRATION
SOURCES
plugin.cpp
diff --git a/src/imports/workerscript/CMakeLists.txt b/src/imports/workerscript/CMakeLists.txt
index b2a6d0f444..39a48e6a05 100644
--- a/src/imports/workerscript/CMakeLists.txt
+++ b/src/imports/workerscript/CMakeLists.txt
@@ -8,7 +8,7 @@ qt_internal_add_qml_module(workerscriptplugin
URI "QtQml.WorkerScript"
VERSION "${CMAKE_PROJECT_VERSION}"
DESIGNER_SUPPORTED
- CLASSNAME QtQmlWorkerScriptPlugin
+ CLASS_NAME QtQmlWorkerScriptPlugin
SKIP_TYPE_REGISTRATION
PLUGIN_OPTIONAL
SOURCES
diff --git a/src/imports/xmllistmodel/CMakeLists.txt b/src/imports/xmllistmodel/CMakeLists.txt
index 387b588e84..84b7234c17 100644
--- a/src/imports/xmllistmodel/CMakeLists.txt
+++ b/src/imports/xmllistmodel/CMakeLists.txt
@@ -1,7 +1,7 @@
qt_internal_add_qml_module(qmlxmllistmodelplugin
URI "QtQml.XmlListModel"
VERSION "${CMAKE_PROJECT_VERSION}"
- CLASSNAME QtQmlXmlListModelPlugin
+ CLASS_NAME QtQmlXmlListModelPlugin
SKIP_TYPE_REGISTRATION
DEPENDENCIES
QtQml