aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2021-03-04 18:10:59 +0100
committerUlf Hermann <ulf.hermann@qt.io>2021-03-12 17:14:56 +0100
commit482b7adcb7b5f399d30230b16bce9eb5bf4d12f7 (patch)
tree2fb00d1f41b0dce15319533683b3f31e713feaeb /src/imports
parent9970ebb277db5f11c8a7e72099fdd056a6d8310c (diff)
CMake: Automatically add prefer directive to qmldir files
In qt6_add_qml_module we know that we are going to put all the QML files listed in the generated qmldir into the resource path. We can thus safely point the QML engine there. This reveals that QtTest's plugin is actually not optional. It does contain the compiled QML code. Change-Id: Ia20f98c481482a851558c7ebeb39c9c365355d0a Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/testlib/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/imports/testlib/CMakeLists.txt b/src/imports/testlib/CMakeLists.txt
index 1e199b947b..e94d1edc76 100644
--- a/src/imports/testlib/CMakeLists.txt
+++ b/src/imports/testlib/CMakeLists.txt
@@ -10,7 +10,6 @@ qt_internal_add_qml_module(qmltestplugin
CLASSNAME QTestQmlModule
DEPENDENCIES
QtQuick.Window/2.0
- PLUGIN_OPTIONAL
SOURCES
main.cpp
PUBLIC_LIBRARIES