aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-04-29 16:22:53 +0200
committerMaximilian Goldstein <max.goldstein@qt.io>2021-04-29 17:56:10 +0200
commit8735afb5be30f888f30438d98281a3bc182f562d (patch)
treed69bb719446e1d1eb8b44b47dec6f9bef99e240f /src/imports
parent5cfce9f41cf5d07d2d61da5157db918ef18de561 (diff)
QtQuick.Particles: Add QtQuick to dependencies
As particles uses QtQuick classes in its code it needs to list it as a dependency or else tooling will get confused. Change-Id: I317d4c05eee3c46214ab0d56d82fc22f4776c696 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/particles/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/imports/particles/CMakeLists.txt b/src/imports/particles/CMakeLists.txt
index 4df5512973..ba2980e6fd 100644
--- a/src/imports/particles/CMakeLists.txt
+++ b/src/imports/particles/CMakeLists.txt
@@ -10,6 +10,8 @@ qt_internal_add_qml_module(particlesplugin
CLASS_NAME QtQuick2ParticlesPlugin
SKIP_TYPE_REGISTRATION
PLUGIN_OPTIONAL
+ DEPENDENCIES
+ QtQuick
SOURCES
plugin.cpp
PUBLIC_LIBRARIES