aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2021-02-16 11:00:04 +0100
committerUlf Hermann <ulf.hermann@qt.io>2021-02-19 08:33:11 +0100
commitfe7318a6cf4398802f919766f2ac585bd844cf48 (patch)
tree0fc10a9a007ff47c6e2ff421056510fda8d2decd /src/imports
parentedf8106be2b94dea5bd3b8a446705521957bf973 (diff)
Layouts: Depend on QtQuick
If we don't declare the dependency our tools won't figure out where QQuickItem comes from when analyzing the dependency hierarchy of layouts. Pick-to: 6.1 Change-Id: I389c9e513a3a65143aa6b6fbf508eee584970181 Reviewed-by: Mitch Curtis <mitch.curtis@qt.io> Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/layouts/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/imports/layouts/CMakeLists.txt b/src/imports/layouts/CMakeLists.txt
index f0f957c024..6cfb911ba9 100644
--- a/src/imports/layouts/CMakeLists.txt
+++ b/src/imports/layouts/CMakeLists.txt
@@ -11,6 +11,8 @@ qt_internal_add_qml_module(qquicklayoutsplugin
DESIGNER_SUPPORTED
CLASSNAME QtQuickLayoutsPlugin
SKIP_TYPE_REGISTRATION
+ DEPENDENCIES
+ QtQuick
PLUGIN_OPTIONAL
SOURCES
plugin.cpp