aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 13:31:06 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-15 12:24:51 +0000
commitba494aaa24defe1401f621b791891e696b308756 (patch)
tree3617f29e9625fafbf94609ac79b2decd4033107c /src/imports
parent91e32f86b53bb930405a58e19c84746ee85cdf89 (diff)
Regenerate all projects with new CMake API version
Change-Id: Ie0db35f674137c229eaf049616f38f8e818f7092 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/folderlistmodel/CMakeLists.txt2
-rw-r--r--src/imports/labsanimation/CMakeLists.txt2
-rw-r--r--src/imports/labsmodels/CMakeLists.txt2
-rw-r--r--src/imports/layouts/CMakeLists.txt2
-rw-r--r--src/imports/localstorage/CMakeLists.txt2
-rw-r--r--src/imports/models/CMakeLists.txt2
-rw-r--r--src/imports/particles/CMakeLists.txt2
-rw-r--r--src/imports/qtqml/.prev_CMakeLists.txt2
-rw-r--r--src/imports/qtqml/CMakeLists.txt2
-rw-r--r--src/imports/qtquick2/CMakeLists.txt4
-rw-r--r--src/imports/settings/CMakeLists.txt2
-rw-r--r--src/imports/shapes/CMakeLists.txt2
-rw-r--r--src/imports/sharedimage/CMakeLists.txt2
-rw-r--r--src/imports/statemachine/CMakeLists.txt2
-rw-r--r--src/imports/testlib/.prev_CMakeLists.txt2
-rw-r--r--src/imports/testlib/CMakeLists.txt2
-rw-r--r--src/imports/wavefrontmesh/CMakeLists.txt2
-rw-r--r--src/imports/window/CMakeLists.txt2
-rw-r--r--src/imports/workerscript/CMakeLists.txt2
19 files changed, 20 insertions, 20 deletions
diff --git a/src/imports/folderlistmodel/CMakeLists.txt b/src/imports/folderlistmodel/CMakeLists.txt
index 7cd8d75653..e7c0ae5f91 100644
--- a/src/imports/folderlistmodel/CMakeLists.txt
+++ b/src/imports/folderlistmodel/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlfolderlistmodelplugin Plugin:
#####################################################################
-add_qml_module(qmlfolderlistmodelplugin
+qt_add_qml_module(qmlfolderlistmodelplugin
URI "Qt.labs.folderlistmodel"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
CLASSNAME QmlFolderListModelPlugin
diff --git a/src/imports/labsanimation/CMakeLists.txt b/src/imports/labsanimation/CMakeLists.txt
index 6b54d02d72..8637496097 100644
--- a/src/imports/labsanimation/CMakeLists.txt
+++ b/src/imports/labsanimation/CMakeLists.txt
@@ -4,7 +4,7 @@
## labsanimationplugin Plugin:
#####################################################################
-add_qml_module(labsanimationplugin
+qt_add_qml_module(labsanimationplugin
URI "Qt.labs.animation"
VERSION "1.0"
CLASSNAME QtLabsAnimationPlugin
diff --git a/src/imports/labsmodels/CMakeLists.txt b/src/imports/labsmodels/CMakeLists.txt
index ce3e290a83..c198f02016 100644
--- a/src/imports/labsmodels/CMakeLists.txt
+++ b/src/imports/labsmodels/CMakeLists.txt
@@ -4,7 +4,7 @@
## labsmodelsplugin Plugin:
#####################################################################
-add_qml_module(labsmodelsplugin
+qt_add_qml_module(labsmodelsplugin
URI "Qt.labs.qmlmodels"
VERSION "1.0"
CLASSNAME QtQmlLabsModelsPlugin
diff --git a/src/imports/layouts/CMakeLists.txt b/src/imports/layouts/CMakeLists.txt
index 666aae5dc0..b7dabd13c9 100644
--- a/src/imports/layouts/CMakeLists.txt
+++ b/src/imports/layouts/CMakeLists.txt
@@ -4,7 +4,7 @@
## qquicklayoutsplugin Plugin:
#####################################################################
-add_qml_module(qquicklayoutsplugin
+qt_add_qml_module(qquicklayoutsplugin
URI "QtQuick.Layouts"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
DESIGNER_SUPPORTED
diff --git a/src/imports/localstorage/CMakeLists.txt b/src/imports/localstorage/CMakeLists.txt
index c785a4bd2e..efbf67e726 100644
--- a/src/imports/localstorage/CMakeLists.txt
+++ b/src/imports/localstorage/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmllocalstorageplugin Plugin:
#####################################################################
-add_qml_module(qmllocalstorageplugin
+qt_add_qml_module(qmllocalstorageplugin
URI "QtQuick.LocalStorage"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
CLASSNAME QQmlLocalStoragePlugin
diff --git a/src/imports/models/CMakeLists.txt b/src/imports/models/CMakeLists.txt
index 1bfb7a35d3..dc4639725d 100644
--- a/src/imports/models/CMakeLists.txt
+++ b/src/imports/models/CMakeLists.txt
@@ -4,7 +4,7 @@
## modelsplugin Plugin:
#####################################################################
-add_qml_module(modelsplugin
+qt_add_qml_module(modelsplugin
TARGET_PATH "QtQml/Models.2"
URI "QtQml.Models"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
diff --git a/src/imports/particles/CMakeLists.txt b/src/imports/particles/CMakeLists.txt
index f2f0ae8a84..5117471776 100644
--- a/src/imports/particles/CMakeLists.txt
+++ b/src/imports/particles/CMakeLists.txt
@@ -4,7 +4,7 @@
## particlesplugin Plugin:
#####################################################################
-add_qml_module(particlesplugin
+qt_add_qml_module(particlesplugin
TARGET_PATH "QtQuick/Particles.2"
URI "QtQuick.Particles"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
diff --git a/src/imports/qtqml/.prev_CMakeLists.txt b/src/imports/qtqml/.prev_CMakeLists.txt
index 281e83242f..827474f2fb 100644
--- a/src/imports/qtqml/.prev_CMakeLists.txt
+++ b/src/imports/qtqml/.prev_CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlplugin Plugin:
#####################################################################
-add_qml_module(qmlplugin
+qt_add_qml_module(qmlplugin
URI "QtQml"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
DESIGNER_SUPPORTED
diff --git a/src/imports/qtqml/CMakeLists.txt b/src/imports/qtqml/CMakeLists.txt
index a8ac5d8b8a..ac1a8e0834 100644
--- a/src/imports/qtqml/CMakeLists.txt
+++ b/src/imports/qtqml/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlplugin Plugin:
#####################################################################
-add_qml_module(qmlplugin
+qt_add_qml_module(qmlplugin
URI "QtQml"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
DESIGNER_SUPPORTED
diff --git a/src/imports/qtquick2/CMakeLists.txt b/src/imports/qtquick2/CMakeLists.txt
index a8dabb3371..3287f5c2a6 100644
--- a/src/imports/qtquick2/CMakeLists.txt
+++ b/src/imports/qtquick2/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtquick2plugin Plugin:
#####################################################################
-add_qml_module(qtquick2plugin
+qt_add_qml_module(qtquick2plugin
TARGET_PATH "QtQuick.2"
URI "QtQuick"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
@@ -35,7 +35,7 @@ add_qml_module(qtquick2plugin
## Scopes:
#####################################################################
-extend_target(qtquick2plugin CONDITION QT_FEATURE_qml_worker_script
+qt_extend_target(qtquick2plugin CONDITION QT_FEATURE_qml_worker_script
LIBRARIES
Qt::QmlWorkerScriptPrivate
PUBLIC_LIBRARIES
diff --git a/src/imports/settings/CMakeLists.txt b/src/imports/settings/CMakeLists.txt
index d3827443e0..1b092331ea 100644
--- a/src/imports/settings/CMakeLists.txt
+++ b/src/imports/settings/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlsettingsplugin Plugin:
#####################################################################
-add_qml_module(qmlsettingsplugin
+qt_add_qml_module(qmlsettingsplugin
URI "Qt.labs.settings"
VERSION "1.1"
CLASSNAME QmlSettingsPlugin
diff --git a/src/imports/shapes/CMakeLists.txt b/src/imports/shapes/CMakeLists.txt
index 525b25e659..717e6af119 100644
--- a/src/imports/shapes/CMakeLists.txt
+++ b/src/imports/shapes/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlshapesplugin Plugin:
#####################################################################
-add_qml_module(qmlshapesplugin
+qt_add_qml_module(qmlshapesplugin
URI "QtQuick.Shapes"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
CLASSNAME QmlShapesPlugin
diff --git a/src/imports/sharedimage/CMakeLists.txt b/src/imports/sharedimage/CMakeLists.txt
index dcf1b3f8e2..b6a676fe7b 100644
--- a/src/imports/sharedimage/CMakeLists.txt
+++ b/src/imports/sharedimage/CMakeLists.txt
@@ -4,7 +4,7 @@
## sharedimageplugin Plugin:
#####################################################################
-add_qml_module(sharedimageplugin
+qt_add_qml_module(sharedimageplugin
URI "Qt.labs.sharedimage"
VERSION "1.0"
CLASSNAME QtQuickSharedImagePlugin
diff --git a/src/imports/statemachine/CMakeLists.txt b/src/imports/statemachine/CMakeLists.txt
index a32278e755..a6e53d2027 100644
--- a/src/imports/statemachine/CMakeLists.txt
+++ b/src/imports/statemachine/CMakeLists.txt
@@ -4,7 +4,7 @@
## qtqmlstatemachine Plugin:
#####################################################################
-add_qml_module(qtqmlstatemachine
+qt_add_qml_module(qtqmlstatemachine
URI "QtQml.StateMachine"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
CLASSNAME QtQmlStateMachinePlugin
diff --git a/src/imports/testlib/.prev_CMakeLists.txt b/src/imports/testlib/.prev_CMakeLists.txt
index dad2b51b83..6e54d1ffcc 100644
--- a/src/imports/testlib/.prev_CMakeLists.txt
+++ b/src/imports/testlib/.prev_CMakeLists.txt
@@ -4,7 +4,7 @@
## qmltestplugin Plugin:
#####################################################################
-add_qml_module(qmltestplugin
+qt_add_qml_module(qmltestplugin
URI "QtTest"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
CLASSNAME QTestQmlModule
diff --git a/src/imports/testlib/CMakeLists.txt b/src/imports/testlib/CMakeLists.txt
index bb33464ba7..eada3b6df6 100644
--- a/src/imports/testlib/CMakeLists.txt
+++ b/src/imports/testlib/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmltestplugin Plugin:
#####################################################################
-add_qml_module(qmltestplugin
+qt_add_qml_module(qmltestplugin
URI "QtTest"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
CLASSNAME QTestQmlModule
diff --git a/src/imports/wavefrontmesh/CMakeLists.txt b/src/imports/wavefrontmesh/CMakeLists.txt
index b43ca7656b..2e708c854e 100644
--- a/src/imports/wavefrontmesh/CMakeLists.txt
+++ b/src/imports/wavefrontmesh/CMakeLists.txt
@@ -4,7 +4,7 @@
## qmlwavefrontmeshplugin Plugin:
#####################################################################
-add_qml_module(qmlwavefrontmeshplugin
+qt_add_qml_module(qmlwavefrontmeshplugin
URI "Qt.labs.wavefrontmesh"
VERSION "1.${CMAKE_PROJECT_VERSION_MINOR}"
CLASSNAME QmlWavefrontMeshPlugin
diff --git a/src/imports/window/CMakeLists.txt b/src/imports/window/CMakeLists.txt
index 0f76e020e9..e031a6a28f 100644
--- a/src/imports/window/CMakeLists.txt
+++ b/src/imports/window/CMakeLists.txt
@@ -4,7 +4,7 @@
## windowplugin Plugin:
#####################################################################
-add_qml_module(windowplugin
+qt_add_qml_module(windowplugin
TARGET_PATH "QtQuick/Window.2"
URI "QtQuick.Window"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"
diff --git a/src/imports/workerscript/CMakeLists.txt b/src/imports/workerscript/CMakeLists.txt
index 86487e5730..b9948cf84e 100644
--- a/src/imports/workerscript/CMakeLists.txt
+++ b/src/imports/workerscript/CMakeLists.txt
@@ -4,7 +4,7 @@
## workerscriptplugin Plugin:
#####################################################################
-add_qml_module(workerscriptplugin
+qt_add_qml_module(workerscriptplugin
TARGET_PATH "QtQml/WorkerScript.2"
URI "QtQml.WorkerScript"
VERSION "2.${CMAKE_PROJECT_VERSION_MINOR}"