aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-01-21 17:07:24 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2021-01-22 08:54:04 +0100
commitdea48b7e47e54236453cf83c8ef5670142fe01a2 (patch)
tree8d79564a86182a2775438030be16b648e0dbb62e /src/imports
parent215d183860b52edd4e05009b3a4f6bdbf239b519 (diff)
Qt.labs.wavefrontmesh: Make plugin optional
This moves the wavefrontmesh types into a new library and is meant to make them availabe to the QML compiler at some point in the future. Task-number: QTBUG-90487 Change-Id: I9ab9dfc62ef9c205ce4649df33a6c1e2ac0ca639 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/wavefrontmesh/CMakeLists.txt5
-rw-r--r--src/imports/wavefrontmesh/plugin.cpp5
2 files changed, 2 insertions, 8 deletions
diff --git a/src/imports/wavefrontmesh/CMakeLists.txt b/src/imports/wavefrontmesh/CMakeLists.txt
index 85065589ec..7dd97c8056 100644
--- a/src/imports/wavefrontmesh/CMakeLists.txt
+++ b/src/imports/wavefrontmesh/CMakeLists.txt
@@ -9,15 +9,12 @@ qt_internal_add_qml_module(qmlwavefrontmeshplugin
VERSION "${CMAKE_PROJECT_VERSION}"
CLASSNAME QmlWavefrontMeshPlugin
SKIP_TYPE_REGISTRATION
- GENERATE_QMLTYPES
- INSTALL_QMLTYPES
SOURCES
plugin.cpp
- qwavefrontmesh.cpp qwavefrontmesh.h
PUBLIC_LIBRARIES
Qt::CorePrivate
Qt::QmlPrivate
- Qt::QuickPrivate
+ Qt::LabsWavefrontMeshPrivate
)
#### Keys ignored in scope 1:.:.:wavefrontmesh.pro:<TRUE>:
diff --git a/src/imports/wavefrontmesh/plugin.cpp b/src/imports/wavefrontmesh/plugin.cpp
index eea0db19db..16c40ae8d5 100644
--- a/src/imports/wavefrontmesh/plugin.cpp
+++ b/src/imports/wavefrontmesh/plugin.cpp
@@ -40,10 +40,7 @@
#include <QtQml/qqmlextensionplugin.h>
#include <QtQml/qqml.h>
-#include "qwavefrontmesh.h"
-
-extern void qml_register_types_Qt_labs_wavefrontmesh();
-
+#include <QtLabsWavefrontMesh/private/qqmlwavefrontmeshglobal_p.h>
QT_BEGIN_NAMESPACE
class QmlWavefrontMeshPlugin : public QQmlEngineExtensionPlugin