aboutsummaryrefslogtreecommitdiffstats
path: root/src/imports
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-06-04 13:52:18 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-06-15 16:56:10 +0200
commit828cdcabf84734a753e3ba8b8e4b089a6e155415 (patch)
tree0bad81fccdc270b28988dc4dc27d047f0354b8c7 /src/imports
parentf2378620e1616a7ec1b277b57da9176ccb7828ae (diff)
Remove QtQuick.Window plugin
We move all the types into QtQuick itself and retain QtQuick.Window only as alias to QtQuick. This requires support for qmldirs that consist of only an import statement. [ChangeLog][QtQuick][Important Behavior Changes] The contents of the QtQuick.Window QML module have been moved into the QtQuick module. QtQuick.Window is merely and alias for QtQuick now. An explicit import of QtQuick will override this alias. Therefore, if you import QtQuick with a different version than QtQuick.Window, you will get the QtQuick.Window types of the version given in the QtQuick import now. Task-number: QTBUG-84639 Change-Id: Ia82afab0ac2faba70cfdaf53dc8dfe4261e1113f Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/imports')
-rw-r--r--src/imports/CMakeLists.txt1
-rw-r--r--src/imports/imports.pro3
-rw-r--r--src/imports/window/CMakeLists.txt26
-rw-r--r--src/imports/window/plugin.cpp79
-rw-r--r--src/imports/window/plugin.h131
-rw-r--r--src/imports/window/qmldir5
-rw-r--r--src/imports/window/window.pro15
7 files changed, 2 insertions, 258 deletions
diff --git a/src/imports/CMakeLists.txt b/src/imports/CMakeLists.txt
index 020f683e41..9970e5a39d 100644
--- a/src/imports/CMakeLists.txt
+++ b/src/imports/CMakeLists.txt
@@ -23,7 +23,6 @@ if(TARGET Qt::Quick)
add_subdirectory(labsanimation)
add_subdirectory(layouts)
add_subdirectory(qtquick2)
- add_subdirectory(window)
endif()
if(QT_FEATURE_quick_shadereffect AND TARGET Qt::Quick)
add_subdirectory(wavefrontmesh)
diff --git a/src/imports/imports.pro b/src/imports/imports.pro
index e0f66838ec..0ea9395179 100644
--- a/src/imports/imports.pro
+++ b/src/imports/imports.pro
@@ -19,8 +19,7 @@ qtHaveModule(quick) {
SUBDIRS += \
labsanimation \
layouts \
- qtquick2 \
- window
+ qtquick2
qtConfig(quick-shadereffect): SUBDIRS += wavefrontmesh
diff --git a/src/imports/window/CMakeLists.txt b/src/imports/window/CMakeLists.txt
deleted file mode 100644
index 99cedf333c..0000000000
--- a/src/imports/window/CMakeLists.txt
+++ /dev/null
@@ -1,26 +0,0 @@
-# Generated from window.pro.
-
-#####################################################################
-## windowplugin Plugin:
-#####################################################################
-
-qt_add_qml_module(windowplugin
- URI "QtQuick.Window"
- VERSION "${CMAKE_PROJECT_VERSION}"
- DESIGNER_SUPPORTED
- CLASSNAME QtQuick2WindowPlugin
- SKIP_TYPE_REGISTRATION
- GENERATE_QMLTYPES
- SOURCES
- plugin.cpp plugin.h
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::Gui
- Qt::QmlPrivate
- Qt::QuickPrivate
-)
-
-#### Keys ignored in scope 1:.:.:window.pro:<TRUE>:
-# CXX_MODULE = "qml"
-# QML_IMPORT_VERSION = "$$QT_VERSION"
-# TARGETPATH = "QtQuick/Window"
diff --git a/src/imports/window/plugin.cpp b/src/imports/window/plugin.cpp
deleted file mode 100644
index 5152fa02ec..0000000000
--- a/src/imports/window/plugin.cpp
+++ /dev/null
@@ -1,79 +0,0 @@
-/****************************************************************************
-**
-** Copyright (C) 2016 The Qt Company Ltd.
-** Contact: https://www.qt.io/licensing/
-**
-** This file is part of the plugins of the Qt Toolkit.
-**
-** $QT_BEGIN_LICENSE:LGPL$
-** Commercial License Usage
-** Licensees holding valid commercial Qt licenses may use this file in
-** accordance with the commercial license agreement provided with the
-** Software or, alternatively, in accordance with the terms contained in
-** a written agreement between you and The Qt Company. For licensing terms
-** and conditions see https://www.qt.io/terms-conditions. For further
-** information use the contact form at https://www.qt.io/contact-us.
-**
-** GNU Lesser General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU Lesser
-** General Public License version 3 as published by the Free Software
-** Foundation and appearing in the file LICENSE.LGPL3 included in the
-** packaging of this file. Please review the following information to
-** ensure the GNU Lesser General Public License version 3 requirements
-** will be met: https://www.gnu.org/licenses/lgpl-3.0.html.
-**
-** GNU General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU
-** General Public License version 2.0 or (at your option) the GNU General
-** Public license version 3 or any later version approved by the KDE Free
-** Qt Foundation. The licenses are as published by the Free Software
-** Foundation and appearing in the file LICENSE.GPL2 and LICENSE.GPL3
-** included in the packaging of this file. Please review the following
-** information to ensure the GNU General Public License requirements will
-** be met: https://www.gnu.org/licenses/gpl-2.0.html and
-** https://www.gnu.org/licenses/gpl-3.0.html.
-**
-** $QT_END_LICENSE$
-**
-****************************************************************************/
-
-#include <QtQml/qqmlextensionplugin.h>
-
-#include "plugin.h"
-
-extern void qml_register_types_QtQuick_Window();
-
-QT_BEGIN_NAMESPACE
-
-/*!
- \qmlmodule QtQuick.Window 2.\QtMinorVersion
- \title Qt Quick Window QML Types
- \ingroup qmlmodules
- \brief Provides QML types for window management
-
- This QML module contains types for creating top-level windows and accessing screen information.
-
- To use the types in this module, import the module with the following line:
-
- \qml \QtMinorVersion
- import QtQuick.Window 2.\1
- \endqml
-*/
-
-//![class decl]
-class QtQuick2WindowPlugin : public QQmlEngineExtensionPlugin
-{
- Q_OBJECT
- Q_PLUGIN_METADATA(IID QQmlEngineExtensionInterface_iid)
-public:
- QtQuick2WindowPlugin(QObject *parent = nullptr) : QQmlEngineExtensionPlugin(parent)
- {
- volatile auto registration = &qml_register_types_QtQuick_Window;
- Q_UNUSED(registration);
- }
-};
-//![class decl]
-
-QT_END_NAMESPACE
-
-#include "plugin.moc"
diff --git a/src/imports/window/plugin.h b/src/imports/window/plugin.h
deleted file mode 100644
index 625a77b12c..0000000000
--- a/src/imports/window/plugin.h
+++ /dev/null
@@ -1,131 +0,0 @@
-/****************************************************************************
-**
-** Copyright (C) 2019 The Qt Company Ltd.
-** Contact: https://www.qt.io/licensing/
-**
-** This file is part of the QtQuick module of the Qt Toolkit.
-**
-** $QT_BEGIN_LICENSE:LGPL$
-** Commercial License Usage
-** Licensees holding valid commercial Qt licenses may use this file in
-** accordance with the commercial license agreement provided with the
-** Software or, alternatively, in accordance with the terms contained in
-** a written agreement between you and The Qt Company. For licensing terms
-** and conditions see https://www.qt.io/terms-conditions. For further
-** information use the contact form at https://www.qt.io/contact-us.
-**
-** GNU Lesser General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU Lesser
-** General Public License version 3 as published by the Free Software
-** Foundation and appearing in the file LICENSE.LGPL3 included in the
-** packaging of this file. Please review the following information to
-** ensure the GNU Lesser General Public License version 3 requirements
-** will be met: https://www.gnu.org/licenses/lgpl-3.0.html.
-**
-** GNU General Public License Usage
-** Alternatively, this file may be used under the terms of the GNU
-** General Public License version 2.0 or (at your option) the GNU General
-** Public license version 3 or any later version approved by the KDE Free
-** Qt Foundation. The licenses are as published by the Free Software
-** Foundation and appearing in the file LICENSE.GPL2 and LICENSE.GPL3
-** included in the packaging of this file. Please review the following
-** information to ensure the GNU General Public License requirements will
-** be met: https://www.gnu.org/licenses/gpl-2.0.html and
-** https://www.gnu.org/licenses/gpl-3.0.html.
-**
-** $QT_END_LICENSE$
-**
-****************************************************************************/
-
-#ifndef PLUGIN_H
-#define PLUGIN_H
-
-//
-// W A R N I N G
-// -------------
-//
-// This file is not part of the Qt API. It exists purely as an
-// implementation detail. This header file may change from version to
-// version without notice, or even be removed.
-//
-// We mean it.
-//
-
-#include <QtGui/private/qwindow_p.h>
-#include <QtQuick/private/qquickwindow_p.h>
-#include <QtQuick/private/qquickwindowattached_p.h>
-#include <QtQuick/private/qquickscreen_p.h>
-#include <QtQuick/private/qquickwindowmodule_p.h>
-#include <QtQml/qqml.h>
-
-QT_BEGIN_NAMESPACE
-
-struct QWindowForeign
-{
- Q_GADGET
- QML_FOREIGN(QWindow)
- QML_ANONYMOUS
- QML_ADDED_IN_VERSION(2, 1)
-};
-
-struct QQuickWindowForeign
-{
- Q_GADGET
- QML_FOREIGN(QQuickWindow)
- QML_NAMED_ELEMENT(Window)
- QML_ADDED_IN_VERSION(2, 0)
- QML_REMOVED_IN_VERSION(2, 1)
-};
-
-struct QQuickWindowForeignAttached
-{
- Q_GADGET
- QML_FOREIGN(QQuickWindowAttached)
- QML_ANONYMOUS
- QML_ADDED_IN_VERSION(2, 0)
-};
-
-struct QQuickScreenInfoForeign
-{
- Q_GADGET
- QML_FOREIGN(QQuickScreenInfo)
- QML_NAMED_ELEMENT(ScreenInfo)
- QML_ADDED_IN_VERSION(2, 3)
- QML_UNCREATABLE("ScreenInfo can only be used via the attached property.")
-};
-
-struct QQuickScreenForeignAttached
-{
- Q_GADGET
- QML_FOREIGN(QQuickScreenAttached)
- QML_ANONYMOUS
- QML_ADDED_IN_VERSION(2, 0)
-};
-
-struct QQuickScreenForeign
-{
- Q_GADGET
- QML_FOREIGN(QQuickScreen)
- QML_NAMED_ELEMENT(Screen)
- QML_ADDED_IN_VERSION(2, 0)
- QML_UNCREATABLE("Screen can only be used via the attached property.")
-};
-
-struct QQuickWindowQmlImplForeign
-{
- Q_GADGET
- QML_FOREIGN(QQuickWindowQmlImpl)
- QML_NAMED_ELEMENT(Window)
- QML_ADDED_IN_VERSION(2, 1)
-};
-
-struct QQuickRootItemForeign
-{
- Q_GADGET
- QML_FOREIGN(QQuickRootItem)
- QML_ANONYMOUS
-};
-
-QT_END_NAMESPACE
-
-#endif // PLUGIN_H
diff --git a/src/imports/window/qmldir b/src/imports/window/qmldir
index fb6202b3bb..859cd341a1 100644
--- a/src/imports/window/qmldir
+++ b/src/imports/window/qmldir
@@ -1,5 +1,2 @@
module QtQuick.Window
-plugin windowplugin
-classname QtQuick2WindowPlugin
-typeinfo plugins.qmltypes
-designersupported
+import QtQuick
diff --git a/src/imports/window/window.pro b/src/imports/window/window.pro
deleted file mode 100644
index d8f9b16df4..0000000000
--- a/src/imports/window/window.pro
+++ /dev/null
@@ -1,15 +0,0 @@
-CXX_MODULE = qml
-TARGET = windowplugin
-TARGETPATH = QtQuick/Window
-QML_IMPORT_VERSION = $$QT_VERSION
-
-SOURCES += \
- plugin.cpp
-
-HEADERS += \
- plugin.h
-
-QT += quick-private qml-private
-
-CONFIG += qmltypes install_qmltypes
-load(qml_plugin)