aboutsummaryrefslogtreecommitdiffstats
path: root/src/labs/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-01-20 17:23:23 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2021-01-21 10:35:52 +0100
commiteb5bb9e7f547a7e222b5dbb848774639ab11f243 (patch)
tree7c4377e7b272025a4240e5707365a50b49898cc9 /src/labs/CMakeLists.txt
parent3fadfb2c3fa7d4b22d0d0269c645c1086fa56619 (diff)
Qt.labs.folderlistmodel: Make plugin optional
This moves the folderlistmodel types into a new library and is meant to make them availabe to the QML compiler at some point in the future. Task-number: QTBUG-90487 Change-Id: Iee84a4804a241aa1dee5f896a02ccc9f0ecc0d8d Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/labs/CMakeLists.txt')
-rw-r--r--src/labs/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/labs/CMakeLists.txt b/src/labs/CMakeLists.txt
index b1f8c7c142..5dc715db60 100644
--- a/src/labs/CMakeLists.txt
+++ b/src/labs/CMakeLists.txt
@@ -1 +1,4 @@
add_subdirectory(settings)
+if(QT_FEATURE_qml_itemmodel)
+ add_subdirectory(folderlistmodel)
+endif()