aboutsummaryrefslogtreecommitdiffstats
path: root/src/labs/wavefrontmesh/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2021-01-21 17:07:24 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2021-01-22 08:54:04 +0100
commitdea48b7e47e54236453cf83c8ef5670142fe01a2 (patch)
tree8d79564a86182a2775438030be16b648e0dbb62e /src/labs/wavefrontmesh/CMakeLists.txt
parent215d183860b52edd4e05009b3a4f6bdbf239b519 (diff)
Qt.labs.wavefrontmesh: Make plugin optional
This moves the wavefrontmesh types into a new library and is meant to make them availabe to the QML compiler at some point in the future. Task-number: QTBUG-90487 Change-Id: I9ab9dfc62ef9c205ce4649df33a6c1e2ac0ca639 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/labs/wavefrontmesh/CMakeLists.txt')
-rw-r--r--src/labs/wavefrontmesh/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/labs/wavefrontmesh/CMakeLists.txt b/src/labs/wavefrontmesh/CMakeLists.txt
new file mode 100644
index 0000000000..88e753ab24
--- /dev/null
+++ b/src/labs/wavefrontmesh/CMakeLists.txt
@@ -0,0 +1,23 @@
+qt_internal_add_module(LabsWavefrontMesh
+ GENERATE_METATYPES
+ SOURCES
+ qwavefrontmesh.cpp qwavefrontmesh.h
+ qqmlwavefrontmeshglobal_p.h
+ DEFINES
+ QT_BUILD_LABSWAVEFRONTMESH_LIB
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QuickPrivate
+)
+
+
+set_target_properties(LabsWavefrontMesh PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION ${CMAKE_PROJECT_VERSION}
+ QT_QML_MODULE_URI Qt.labs.wavefrontmesh
+ QT_QMLTYPES_FILENAME plugins.qmltypes
+ QT_QML_MODULE_INSTALL_DIR "${INSTALL_QMLDIR}/Qt/labs/wavefrontmesh"
+)
+
+qt6_qml_type_registration(LabsWavefrontMesh)