aboutsummaryrefslogtreecommitdiffstats
path: root/src/particles/CMakeLists.txt
diff options
context:
space:
mode:
authorEirik Aavitsland <eirik.aavitsland@qt.io>2020-05-28 14:21:52 +0200
committerEirik Aavitsland <eirik.aavitsland@qt.io>2020-06-02 11:15:44 +0200
commitff293f3afc0a9fe892124af4a10d29f2410569e4 (patch)
treef4200a4be4fab1252184d9db58bd874f76da3063 /src/particles/CMakeLists.txt
parent0d0f6ab80349963f3aaa387992b0edfadddb62a4 (diff)
Remove CustomParticle
The implementation is intertwined with the direct GL path and not really portable to RHI. Fixes: QTBUG-78574 Change-Id: I6ac8707544c19a24661f07e0e6d2fc405e49cbff Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
Diffstat (limited to 'src/particles/CMakeLists.txt')
-rw-r--r--src/particles/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/src/particles/CMakeLists.txt b/src/particles/CMakeLists.txt
index 4f3ed5daf4..085b4d27f1 100644
--- a/src/particles/CMakeLists.txt
+++ b/src/particles/CMakeLists.txt
@@ -64,12 +64,6 @@ qt_add_resource(QuickParticles "particles"
${particles_resource_files}
)
set(particles1_resource_files
- "shaders/customparticle.frag"
- "shaders/customparticle.vert"
- "shaders/customparticle_core.frag"
- "shaders/customparticle_core.vert"
- "shaders/customparticletemplate.vert"
- "shaders/customparticletemplate_core.vert"
"shaders/imageparticle.frag"
"shaders/imageparticle.vert"
"shaders/imageparticle_core.frag"
@@ -121,11 +115,6 @@ qt_extend_target(QuickParticles CONDITION EXISTS "qqml_enable_gcov"
-ftest-coverage
)
-qt_extend_target(QuickParticles CONDITION QT_FEATURE_quick_shadereffect
- SOURCES
- qquickcustomparticle.cpp qquickcustomparticle_p.h
-)
-
set_target_properties(QuickParticles PROPERTIES
QT_QML_MODULE_INSTALL_QMLTYPES TRUE
QT_QML_MODULE_VERSION ${CMAKE_PROJECT_VERSION}