aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2021-04-15 12:19:01 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2021-04-16 18:37:05 +0200
commit3ba6fe4b620f8147d3152e8ae33c3a0e6a360332 (patch)
tree5c2a44c201f42907a1d8e9730141e8ef1fd24743 /src/qml/CMakeLists.txt
parentfe83d6afe557ac4b08e72899942f0422983c67ce (diff)
CMake: Fix qml module version to use the repo project version
Use PROJECT_VERSION instead of CMAKE_PROJECT_VERSION, so that the repo project version is used in a top-level build, rather than the version of the qt5 project. Task-number: QTBUG-92861 Change-Id: I5a7a09baf81353558e512800746ac24e8e8b9a47 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> (cherry picked from commit cd7bd71d08f1c21648756d0a9fd501ce37a8cc0c) Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index 8e977687cc..8d76f5949d 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -651,7 +651,7 @@ qt_internal_add_docs(Qml
set_target_properties(Qml PROPERTIES
QT_QML_MODULE_INSTALL_QMLTYPES TRUE
- QT_QML_MODULE_VERSION ${CMAKE_PROJECT_VERSION}
+ QT_QML_MODULE_VERSION ${PROJECT_VERSION}
QT_QML_MODULE_URI QtQml
QT_QMLTYPES_FILENAME plugins.qmltypes
QT_QML_MODULE_INSTALL_DIR "${INSTALL_QMLDIR}/QtQml"