aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2020-02-06 11:37:31 +0100
committerLeander Beernaert <leander.beernaert@qt.io>2020-02-06 12:25:55 +0000
commit3e9efb41197d09d04155934793eaae420c09e804 (patch)
treeadb0a80a1c6c5052d54898b67385677b63e1410b /src/qml/CMakeLists.txt
parent754bfec430313dd47314e1a70f86e1b95c01878b (diff)
Add Qt6QmlBuildInternals.cmake and qt_add_qml_module()
Add the qt_add_qml_module() which was originally present in QtBuild.cmake in QtBase. Change-Id: If053c0581dd14a6dcf4ef2013c9266e7dd828a76 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index 5b2f8c46fc..765b038acb 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -624,3 +624,5 @@ set_target_properties(Qml PROPERTIES
)
qt6_qml_type_registration(Qml)
+
+include(Qt6QmlBuildInternals.cmake) # special case