aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2021-02-26 10:22:33 +0100
committerFabian Kosmale <fabian.kosmale@qt.io>2021-03-04 12:53:46 +0100
commit50e984c07229b753d6558610e7fa7c7df733fe50 (patch)
tree3c802a88a36ea081988c454cebb59fa5648ac417 /src/qml/CMakeLists.txt
parent776d1f0bf02c5dc2a9dac4c5bd906f4421abf2f4 (diff)
Introduce QQmlAnyBinding as an abstraction over bindings
QQmlAnyBinding is meant to abstract over the differences between classical, QQmlAbstractBinding derived bindings and the newer QPropertyBindingPrivate based ones. It can be used to store, receive, remove, create and set bindings of both types. In addition, this patches adds the functionality to create a QQmlPropertyBinding from a code string, which was so far only possible with QQmlBinding; and adds a few methods to QBiPointer to ease the implementation of QQmlAnyBinding. Task-number: QTBUG-91000 Change-Id: I7076d6fb426f315f32c1b054c5c3ba56312bed29 Reviewed-by: Andrei Golubev <andrei.golubev@qt.io> Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index a96ddc2ab7..0d87869d00 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -269,6 +269,7 @@ qt_internal_add_module(Qml
qml/qqmlprivate.h
qml/qqmlproperty.cpp qml/qqmlproperty.h qml/qqmlproperty_p.h
qml/qqmlpropertybinding.cpp qml/qqmlpropertybinding_p.h
+ qml/qqmlanybinding_p.h
qml/qqmlpropertycache.cpp qml/qqmlpropertycache_p.h
qml/qqmlpropertycachecreator.cpp qml/qqmlpropertycachecreator_p.h
qml/qqmlpropertycachemethodarguments_p.h