aboutsummaryrefslogtreecommitdiffstats
path: root/src/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-05 11:39:32 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-05 14:36:38 +0000
commitd15665b69323dd25ac075d60007d47dff3bc824b (patch)
tree35e195322e764399e55d6370e07a792c592e4fa1 /src/qml/CMakeLists.txt
parent426585304e8e862dc2209a53a9c800838490154c (diff)
Regenerate projects to handle private deps correctly
Change-Id: Ifcbab0407e93dfc35d0459d7d29dee2cd3508a86 Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/qml/CMakeLists.txt')
-rw-r--r--src/qml/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/qml/CMakeLists.txt b/src/qml/CMakeLists.txt
index b61850f610..5b2f8c46fc 100644
--- a/src/qml/CMakeLists.txt
+++ b/src/qml/CMakeLists.txt
@@ -313,6 +313,8 @@ qt_add_module(Qml
Qt::CorePrivate
PUBLIC_LIBRARIES
Qt::Core
+ PRIVATE_MODULE_INTERFACE
+ Qt::CorePrivate
)
# special case begin remove the block, handled manually