aboutsummaryrefslogtreecommitdiffstats
path: root/src/qmlcompiler/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-10-01 12:40:01 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-10-05 14:58:32 +0200
commit767dd738d3de9306062707fe05d32c91ed755da3 (patch)
treeebadcc9809322d5d78ce28f9b82bad1db949f232 /src/qmlcompiler/CMakeLists.txt
parente7d90fc5268cdca6aa10f422f00ad4a0049ea157 (diff)
Long live libQtQmlCompiler!
Move all the code from tools/shared into src/qmlcompiler and build a static library from it so that we can re-use it in external tools. Change-Id: I7c8d8e59063dc7c711f4072f103a01095e6f5997 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/qmlcompiler/CMakeLists.txt')
-rw-r--r--src/qmlcompiler/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/src/qmlcompiler/CMakeLists.txt b/src/qmlcompiler/CMakeLists.txt
new file mode 100644
index 0000000000..d6895704a4
--- /dev/null
+++ b/src/qmlcompiler/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Generated from qmlcompiler.pro.
+
+#####################################################################
+## QmlCompiler Module:
+#####################################################################
+
+qt_add_module(QmlCompiler
+ STATIC
+ INTERNAL_MODULE
+ SOURCES
+ importedmembersvisitor.cpp importedmembersvisitor_p.h
+ metatypes_p.h
+ qmljsimporter.cpp qmljsimporter_p.h
+ qmljstypereader.cpp qmljstypereader_p.h
+ qmlstreamwriter.cpp qmlstreamwriter_p.h
+ resourcefilemapper.cpp resourcefilemapper_p.h
+ scopetree.cpp scopetree_p.h
+ typedescriptionreader.cpp typedescriptionreader_p.h
+ PUBLIC_LIBRARIES
+ Qt::CorePrivate
+ Qt::QmlDevToolsPrivate
+)
+
+#### Keys ignored in scope 1:.:.:qmlcompiler.pro:<TRUE>:
+# _OPTION = "host_build"