aboutsummaryrefslogtreecommitdiffstats
path: root/src/qmlcompiler/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-10-20 16:01:05 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-10-23 13:31:26 +0200
commit8528bd527f91f4717ec502f311e34aa5acbc946e (patch)
treea635ea892f56957d59b248d32c80e41e65ed80cf /src/qmlcompiler/CMakeLists.txt
parentdb131539058aee18b65110fd2c42698e4894b05e (diff)
qmlcachegen: Move functions to compile QML/JS files to QmlCompiler
We need to re-use them. Also, provide a way to insert AOT compiled functions into the C++ code. Change-Id: I7b0d13cb307e8f979745f096a9614f087d135f68 Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/qmlcompiler/CMakeLists.txt')
-rw-r--r--src/qmlcompiler/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/qmlcompiler/CMakeLists.txt b/src/qmlcompiler/CMakeLists.txt
index 82810165a9..d7eb39ebdb 100644
--- a/src/qmlcompiler/CMakeLists.txt
+++ b/src/qmlcompiler/CMakeLists.txt
@@ -9,6 +9,7 @@ qt_internal_add_module(QmlCompiler
INTERNAL_MODULE
SOURCES
qdeferredpointer_p.h
+ qqmljscompiler.cpp qqmljscompiler_p.h
qqmljsimporter.cpp qqmljsimporter_p.h
qqmljsimportvisitor.cpp qqmljsimportvisitor_p.h
qqmljsloadergenerator.cpp qqmljsloadergenerator_p.h