aboutsummaryrefslogtreecommitdiffstats
path: root/src/qmldevtools/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-07-24 16:19:48 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-07-24 16:26:35 +0200
commit09cc372a3a14906aa2130f44c4950dcdd8c9bf0d (patch)
tree20064c825a30c63d46c45203880eef364ca20a00 /src/qmldevtools/CMakeLists.txt
parent78254be6cbd239a3de332c5660b2c408d9f3e674 (diff)
parent487d22bcde7e9d06162d44e7c5dca31d3afac694 (diff)
Merge remote-tracking branch 'origin/wip/qt6' into wip/cmake
Diffstat (limited to 'src/qmldevtools/CMakeLists.txt')
-rw-r--r--src/qmldevtools/CMakeLists.txt32
1 files changed, 25 insertions, 7 deletions
diff --git a/src/qmldevtools/CMakeLists.txt b/src/qmldevtools/CMakeLists.txt
index 9ed5aad94a..f906df4cc9 100644
--- a/src/qmldevtools/CMakeLists.txt
+++ b/src/qmldevtools/CMakeLists.txt
@@ -11,29 +11,31 @@ add_qt_module(QmlDevTools
SOURCES
../qml/common/qqmlapiversion_p.h
../qml/common/qqmljsdiagnosticmessage_p.h
+ ../qml/common/qqmljsfixedpoolarray_p.h
+ ../qml/common/qqmljsmemorypool_p.h
+ ../qml/common/qv4alloca_p.h
+ ../qml/common/qv4calldata_p.h
+ ../qml/common/qv4compileddata_p.h
+ ../qml/common/qv4staticvalue_p.h
+ ../qml/common/qv4stringtoarrayindex_p.h
../qml/compiler/qqmlirbuilder.cpp ../qml/compiler/qqmlirbuilder_p.h
- ../qml/compiler/qv4alloca_p.h
../qml/compiler/qv4bytecodegenerator.cpp ../qml/compiler/qv4bytecodegenerator_p.h
../qml/compiler/qv4bytecodehandler.cpp ../qml/compiler/qv4bytecodehandler_p.h
- ../qml/compiler/qv4calldata_p.h
../qml/compiler/qv4codegen.cpp ../qml/compiler/qv4codegen_p.h
- ../qml/compiler/qv4compileddata_p.h
../qml/compiler/qv4compiler.cpp ../qml/compiler/qv4compiler_p.h
../qml/compiler/qv4compilercontext.cpp ../qml/compiler/qv4compilercontext_p.h
../qml/compiler/qv4compilercontrolflow_p.h
+ ../qml/compiler/qv4compilerglobal_p.h
../qml/compiler/qv4compilerscanfunctions.cpp ../qml/compiler/qv4compilerscanfunctions_p.h
../qml/compiler/qv4instr_moth.cpp ../qml/compiler/qv4instr_moth_p.h
- ../qml/compiler/qv4staticvalue_p.h
- ../qml/compiler/qv4stringtoarrayindex_p.h
../qml/compiler/qv4util_p.h
../qml/parser/qqmljsast.cpp ../qml/parser/qqmljsast_p.h
../qml/parser/qqmljsastfwd_p.h
../qml/parser/qqmljsastvisitor.cpp ../qml/parser/qqmljsastvisitor_p.h
../qml/parser/qqmljsengine_p.cpp ../qml/parser/qqmljsengine_p.h ../qml/parser/qqmljsengine_p.h
- ../qml/parser/qqmljsglobal_p.h ../qml/parser/qqmljsglobal_p.h
+ ../qml/parser/qqmljsglobal_p.h
../qml/parser/qqmljskeywords_p.h
../qml/parser/qqmljslexer.cpp ../qml/parser/qqmljslexer_p.h
- ../qml/parser/qqmljsmemorypool_p.h
../qml/parser/qqmljssourcelocation_p.h
../qml/qmldirparser/qqmldirparser.cpp ../qml/qmldirparser/qqmldirparser_p.h
INCLUDE_DIRECTORIES
@@ -81,6 +83,22 @@ target_include_directories(QmlDevToolsPrivate INTERFACE ${_qml_dev_tools_private
#### Keys ignored in scope 3:.:.:qmldevtools.pro:CLANG AND greaterThan(QT_CLANG_MAJOR_VERSION,3 OR greaterThan(QT_CLANG_MINOR_VERSION,3)):
# WERROR = "-Wno-error=unused-const-variable"
+#### Keys ignored in scope 5:.:../qml/common:../qml/common/common.pri:NOT build_pass:
+# compile_hash_contents = "// Generated file, DO NOT EDIT" "$${LITERAL_HASH}define QML_COMPILE_HASH "$$QML_COMPILE_HASH"" "$${LITERAL_HASH}define QML_COMPILE_HASH_LENGTH $$str_size($$QML_COMPILE_HASH)"
+# tag = <EMPTY>
+# tagFile = "$$PWD/../../.tag"
+
+#### Keys ignored in scope 6:.:../qml/common:../qml/common/common.pri:EXISTS _ss_tagFile:
+# QMAKE_INTERNAL_INCLUDED_FILES = "$$tagFile"
+# tag = "$$cat$$tagFile,singleline"
+
+#### Keys ignored in scope 7:.:../qml/common:../qml/common/common.pri:NOT tag___equals____ss_{LITERAL_DOLLAR}Format AND %H_ss_{LITERAL_DOLLAR}:
+# QML_COMPILE_HASH = "$$tag"
+
+#### Keys ignored in scope 9:.:../qml/common:../qml/common/common.pri:EXISTS _ss_PWD/../../.git:
+# QML_COMPILE_HASH = "$$commit"
+# commit = "$$systemgitrev-parseHEAD"
+
extend_target(QmlDevTools CONDITION (GCC) AND ((QT_COMPILER_VERSION_MAJOR STREQUAL 5))
COMPILE_OPTIONS
-fno-strict-aliasing