aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-06-04 13:52:18 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-06-15 16:56:10 +0200
commit828cdcabf84734a753e3ba8b8e4b089a6e155415 (patch)
tree0bad81fccdc270b28988dc4dc27d047f0354b8c7 /src/quick/CMakeLists.txt
parentf2378620e1616a7ec1b277b57da9176ccb7828ae (diff)
Remove QtQuick.Window plugin
We move all the types into QtQuick itself and retain QtQuick.Window only as alias to QtQuick. This requires support for qmldirs that consist of only an import statement. [ChangeLog][QtQuick][Important Behavior Changes] The contents of the QtQuick.Window QML module have been moved into the QtQuick module. QtQuick.Window is merely and alias for QtQuick now. An explicit import of QtQuick will override this alias. Therefore, if you import QtQuick with a different version than QtQuick.Window, you will get the QtQuick.Window types of the version given in the QtQuick import now. Task-number: QTBUG-84639 Change-Id: Ia82afab0ac2faba70cfdaf53dc8dfe4261e1113f Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index 8bf934ef05..74e1f494d7 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -287,6 +287,8 @@ endif()
# QMLTYPES_INSTALL_DIR = "$$[QT_INSTALL_QML]/QtQuick"
# QML_IMPORT_NAME = "QtQuick"
# QML_IMPORT_VERSION = "$$QT_VERSION"
+# qmldir.files = "$$PWD/../imports/window/qmldir"
+# qmldir.path = "$$[QT_INSTALL_QML]/QtQuick/Window"
## Scopes:
#####################################################################
@@ -358,6 +360,12 @@ qt_extend_target(Quick CONDITION QT_FEATURE_accessibility
Qt::QmlPrivate
)
+#### Keys ignored in scope 10:.:.:quick.pro:prefix_build:
+# INSTALLS = "qmldir"
+
+#### Keys ignored in scope 11:.:.:quick.pro:else:
+# COPIES = "qmldir"
+
qt_extend_target(Quick CONDITION QT_FEATURE_qml_debug
SOURCES
util/qquickprofiler.cpp
@@ -533,3 +541,11 @@ set_target_properties(Quick PROPERTIES
)
qt6_qml_type_registration(Quick)
+
+#special case begin
+if (QT_WILL_INSTALL)
+ install(FILES ../imports/window/qmldir DESTINATION "${INSTALL_QMLDIR}/QtQuick/Window")
+else()
+ file(COPY ../imports/window/qmldir DESTINATION "${QT_BUILD_DIR}/${INSTALL_QMLDIR}/QtQuick/Window")
+endif()
+#special case end