aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-08-10 13:13:38 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-08-10 13:51:02 +0200
commitd1a43e4a37cb6bbe0dfcbacd4ce975b0ce0090f0 (patch)
tree567a010c0947f8668d7b3b0977c16621f846b4b5 /src/quick/CMakeLists.txt
parent02caa659dad5e28b95029e28a40912cabeaf6a9b (diff)
Quick: Make sure the module initialization runs in static builds
We need to keep a reference to the module initialization function somewhere in order to prevent the linker from removing it. In order to avoid further littering of the namespace, the QQuick_initializeProviders function is transformed to cover all of the initialization. Task-number: QTBUG-85693 Change-Id: Ie93e5abd1dfb5a425b87c70d8ec6327bb68880cb Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Shawn Rutledge <shawn.rutledge@qt.io>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index 412f13e808..67b6969467 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -89,7 +89,6 @@ qt_add_module(Quick
items/qquickwindowattached.cpp items/qquickwindowattached_p.h
items/qquickwindowmodule.cpp items/qquickwindowmodule_p.h
items/qquickwindowmodule_p_p.h
- qtquick2.cpp
qtquickglobal.h qtquickglobal_p.h
scenegraph/adaptations/software/qsgabstractsoftwarerenderer.cpp scenegraph/adaptations/software/qsgabstractsoftwarerenderer_p.h
scenegraph/adaptations/software/qsgsoftwareadaptation.cpp scenegraph/adaptations/software/qsgsoftwareadaptation_p.h