aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorGiuseppe D'Angelo <giuseppe.dangelo@kdab.com>2020-06-18 03:56:00 +0200
committerGiuseppe D'Angelo <giuseppe.dangelo@kdab.com>2020-06-23 17:44:03 +0200
commitd5d6a56809032796444fe63c220a2e940ce237c0 (patch)
treeec7bd06c514ba413f28c031b58db69b89b92b2bf /src/quick/CMakeLists.txt
parent1aea94e58f572fe6dbd1146a80ecf5be6602a7af (diff)
Move resetOpenGLState out of QQFBO
QQFBO is not the only client of resetOpenGLState. Although in theory third-party GL code that integrates with QtQuick should reset its state, in practice it doesn't. By making resetOpenGLState only available into QQFBO, now we're blocking a Qt5->6 upgrade path. There's also no compelling reason for this function to be in QQFBO at all, so move it out to as a free function in a ad-hoc new namespace. Change-Id: Ic8e5c7e244db37a5b6257d516e6aea3a9db44898 Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index 07a9927250..3fc9110d0c 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -484,6 +484,7 @@ qt_extend_target(Quick CONDITION QT_FEATURE_quick_shadereffect
qt_extend_target(Quick CONDITION QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR QT_FEATURE_opengles3
SOURCES
items/qquickframebufferobject.cpp items/qquickframebufferobject.h
+ util/qquickopenglutils.cpp util/qquickopenglutils.h
)
qt_extend_target(Quick CONDITION QT_FEATURE_quick_canvas