aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-07-09 14:09:06 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-07-09 15:51:40 +0200
commit0f19f571ee307dbe5fdebeb489d0c6cfcc8fa5ef (patch)
tree838ebcbebc0429dfeba724a1b052e577f5908b06 /src/quick/CMakeLists.txt
parent360a22838a9f6127702c35d9feb67560692df128 (diff)
CMake: Regenerate projects
We need the qt_add_tool changes to successfully configure qemu builds. The rest of the changes are just to be in sync with the .pro files. Change-Id: I7bcc08ac58f57a5761aedef09761428c55235289 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index 4eb0738c8d..74c1600a40 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -392,6 +392,12 @@ qt_extend_target(Quick CONDITION QT_FEATURE_quick_path
util/qquickpathinterpolator.cpp util/qquickpathinterpolator_p.h
)
+qt_extend_target(Quick CONDITION QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR QT_FEATURE_opengles3
+ SOURCES
+ items/qquickframebufferobject.cpp items/qquickframebufferobject.h
+ util/qquickopenglutils.cpp util/qquickopenglutils.h
+)
+
qt_extend_target(Quick CONDITION QT_FEATURE_thread
SOURCES
scenegraph/adaptations/software/qsgsoftwarethreadedrenderloop.cpp scenegraph/adaptations/software/qsgsoftwarethreadedrenderloop_p.h
@@ -481,12 +487,6 @@ qt_extend_target(Quick CONDITION QT_FEATURE_quick_shadereffect
items/qquickshadereffectsource.cpp items/qquickshadereffectsource_p.h
)
-qt_extend_target(Quick CONDITION QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR QT_FEATURE_opengles3
- SOURCES
- items/qquickframebufferobject.cpp items/qquickframebufferobject.h
- util/qquickopenglutils.cpp util/qquickopenglutils.h
-)
-
qt_extend_target(Quick CONDITION QT_FEATURE_quick_canvas
SOURCES
items/context2d/qquickcanvascontext.cpp items/context2d/qquickcanvascontext_p.h