aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-05-24 15:35:20 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-06-03 11:03:46 +0000
commit6c69a6ab7c61d03150ed2e58725c3a61a443fdc0 (patch)
treed6afabf14cc77b22b01b0a4f3e484ac83be31271 /src/quick/CMakeLists.txt
parent677d336def1686d0d6d8f6d55bf8e2686ed27e07 (diff)
Initial CMake port
Crude port of QtQml, QtQmlModels, QtQuick and a few tests and a few examples. Task-number: QTBUG-74136 Change-Id: I5de4d8215b33d1a4a72c2c0e7951e4b384f27e3e Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt500
1 files changed, 500 insertions, 0 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
new file mode 100644
index 0000000000..f375b56657
--- /dev/null
+++ b/src/quick/CMakeLists.txt
@@ -0,0 +1,500 @@
+# Generated from quick.pro.
+
+#####################################################################
+## Quick Module:
+#####################################################################
+
+add_qt_module(Quick
+ SOURCES
+ handlers/qquickdragaxis.cpp handlers/qquickdragaxis_p.h
+ handlers/qquickdraghandler.cpp handlers/qquickdraghandler_p.h
+ handlers/qquickhandlerpoint.cpp handlers/qquickhandlerpoint_p.h
+ handlers/qquickhoverhandler.cpp handlers/qquickhoverhandler_p.h
+ handlers/qquickmultipointhandler.cpp handlers/qquickmultipointhandler_p.h
+ handlers/qquickmultipointhandler_p_p.h
+ handlers/qquickpinchhandler.cpp handlers/qquickpinchhandler_p.h
+ handlers/qquickpointerdevicehandler.cpp handlers/qquickpointerdevicehandler_p.h
+ handlers/qquickpointerdevicehandler_p_p.h
+ handlers/qquickpointerhandler.cpp handlers/qquickpointerhandler_p.h
+ handlers/qquickpointerhandler_p_p.h
+ handlers/qquickpointhandler.cpp handlers/qquickpointhandler_p.h
+ handlers/qquicksinglepointhandler.cpp handlers/qquicksinglepointhandler_p.h
+ handlers/qquicksinglepointhandler_p_p.h
+ handlers/qquicktaphandler.cpp handlers/qquicktaphandler_p.h
+ items/qquickaccessibleattached.cpp items/qquickaccessibleattached_p.h
+ items/qquickanchors.cpp items/qquickanchors_p.h
+ items/qquickanchors_p_p.h
+ items/qquickborderimage.cpp items/qquickborderimage_p.h
+ items/qquickborderimage_p_p.h
+ items/qquickclipnode.cpp items/qquickclipnode_p.h
+ items/qquickevents.cpp
+ items/qquickevents_p_p.h
+ items/qquickflickable.cpp items/qquickflickable_p.h
+ items/qquickflickable_p_p.h
+ items/qquickflickablebehavior_p.h
+ items/qquickfocusscope.cpp items/qquickfocusscope_p.h
+ items/qquickgraphicsinfo.cpp items/qquickgraphicsinfo_p.h
+ items/qquickimage.cpp items/qquickimage_p.h
+ items/qquickimage_p_p.h
+ items/qquickimagebase.cpp items/qquickimagebase_p.h
+ items/qquickimagebase_p_p.h
+ items/qquickimplicitsizeitem.cpp items/qquickimplicitsizeitem_p.h
+ items/qquickimplicitsizeitem_p_p.h
+ items/qquickitem.cpp items/qquickitem.h items/qquickitem_p.h
+ items/qquickitemanimation.cpp items/qquickitemanimation_p.h
+ items/qquickitemanimation_p_p.h
+ items/qquickitemchangelistener_p.h
+ items/qquickitemgrabresult.cpp items/qquickitemgrabresult.h
+ items/qquickitemsmodule.cpp items/qquickitemsmodule_p.h
+ items/qquickloader.cpp items/qquickloader_p.h
+ items/qquickloader_p_p.h
+ items/qquickmousearea.cpp items/qquickmousearea_p.h
+ items/qquickmousearea_p_p.h
+ items/qquickmultipointtoucharea.cpp items/qquickmultipointtoucharea_p.h
+ items/qquickpainteditem.cpp items/qquickpainteditem.h items/qquickpainteditem_p.h
+ items/qquickpincharea.cpp items/qquickpincharea_p.h
+ items/qquickpincharea_p_p.h
+ items/qquickrectangle.cpp items/qquickrectangle_p.h
+ items/qquickrectangle_p_p.h
+ items/qquickrendercontrol.cpp items/qquickrendercontrol.h items/qquickrendercontrol_p.h
+ items/qquickscalegrid.cpp
+ items/qquickscalegrid_p_p.h
+ items/qquickscreen.cpp items/qquickscreen_p.h
+ items/qquickstateoperations.cpp items/qquickstateoperations_p.h
+ items/qquicktext.cpp items/qquicktext_p.h
+ items/qquicktext_p_p.h
+ items/qquicktextcontrol.cpp items/qquicktextcontrol_p.h
+ items/qquicktextcontrol_p_p.h
+ items/qquicktextdocument.cpp items/qquicktextdocument.h items/qquicktextdocument_p.h
+ items/qquicktextedit.cpp items/qquicktextedit_p.h
+ items/qquicktextedit_p_p.h
+ items/qquicktextinput.cpp items/qquicktextinput_p.h
+ items/qquicktextinput_p_p.h
+ items/qquicktextnode.cpp items/qquicktextnode_p.h
+ items/qquicktextnodeengine.cpp items/qquicktextnodeengine_p.h
+ items/qquicktextutil.cpp items/qquicktextutil_p.h
+ items/qquicktranslate.cpp items/qquicktranslate_p.h
+ items/qquickview.cpp items/qquickview.h items/qquickview_p.h
+ items/qquickwindow.cpp items/qquickwindow.h items/qquickwindow_p.h
+ items/qquickwindowattached.cpp items/qquickwindowattached_p.h
+ items/qquickwindowmodule.cpp items/qquickwindowmodule_p.h
+ qtquick2.cpp qtquick2_p.h
+ qtquickglobal.h qtquickglobal_p.h
+ scenegraph/adaptations/software/qsgabstractsoftwarerenderer.cpp scenegraph/adaptations/software/qsgabstractsoftwarerenderer_p.h
+ scenegraph/adaptations/software/qsgsoftwareadaptation.cpp scenegraph/adaptations/software/qsgsoftwareadaptation_p.h
+ scenegraph/adaptations/software/qsgsoftwarecontext.cpp scenegraph/adaptations/software/qsgsoftwarecontext_p.h
+ scenegraph/adaptations/software/qsgsoftwareglyphnode.cpp scenegraph/adaptations/software/qsgsoftwareglyphnode_p.h
+ scenegraph/adaptations/software/qsgsoftwareinternalimagenode.cpp scenegraph/adaptations/software/qsgsoftwareinternalimagenode_p.h
+ scenegraph/adaptations/software/qsgsoftwareinternalrectanglenode.cpp scenegraph/adaptations/software/qsgsoftwareinternalrectanglenode_p.h
+ scenegraph/adaptations/software/qsgsoftwarelayer.cpp scenegraph/adaptations/software/qsgsoftwarelayer_p.h
+ scenegraph/adaptations/software/qsgsoftwarepainternode.cpp scenegraph/adaptations/software/qsgsoftwarepainternode_p.h
+ scenegraph/adaptations/software/qsgsoftwarepixmaprenderer.cpp scenegraph/adaptations/software/qsgsoftwarepixmaprenderer_p.h
+ scenegraph/adaptations/software/qsgsoftwarepixmaptexture.cpp scenegraph/adaptations/software/qsgsoftwarepixmaptexture_p.h
+ scenegraph/adaptations/software/qsgsoftwarepublicnodes.cpp scenegraph/adaptations/software/qsgsoftwarepublicnodes_p.h
+ scenegraph/adaptations/software/qsgsoftwarerenderablenode.cpp scenegraph/adaptations/software/qsgsoftwarerenderablenode_p.h
+ scenegraph/adaptations/software/qsgsoftwarerenderablenodeupdater.cpp scenegraph/adaptations/software/qsgsoftwarerenderablenodeupdater_p.h
+ scenegraph/adaptations/software/qsgsoftwarerenderer.cpp scenegraph/adaptations/software/qsgsoftwarerenderer_p.h
+ scenegraph/adaptations/software/qsgsoftwarerenderlistbuilder.cpp scenegraph/adaptations/software/qsgsoftwarerenderlistbuilder_p.h
+ scenegraph/adaptations/software/qsgsoftwarerenderloop.cpp scenegraph/adaptations/software/qsgsoftwarerenderloop_p.h
+ scenegraph/coreapi/qsgabstractrenderer.cpp scenegraph/coreapi/qsgabstractrenderer.h scenegraph/coreapi/qsgabstractrenderer_p.h
+ scenegraph/coreapi/qsggeometry.cpp scenegraph/coreapi/qsggeometry.h scenegraph/coreapi/qsggeometry_p.h
+ scenegraph/coreapi/qsgmaterial.cpp scenegraph/coreapi/qsgmaterial.h
+ scenegraph/coreapi/qsgmaterialshader_p.h
+ scenegraph/coreapi/qsgnode.cpp scenegraph/coreapi/qsgnode.h scenegraph/coreapi/qsgnode_p.h
+ scenegraph/coreapi/qsgnodeupdater.cpp scenegraph/coreapi/qsgnodeupdater_p.h
+ scenegraph/coreapi/qsgrenderer.cpp scenegraph/coreapi/qsgrenderer_p.h
+ scenegraph/coreapi/qsgrendererinterface.cpp scenegraph/coreapi/qsgrendererinterface.h
+ scenegraph/coreapi/qsgrendernode.cpp scenegraph/coreapi/qsgrendernode.h scenegraph/coreapi/qsgrendernode_p.h
+ scenegraph/qsgadaptationlayer.cpp scenegraph/qsgadaptationlayer_p.h
+ scenegraph/qsgbasicglyphnode.cpp scenegraph/qsgbasicglyphnode_p.h
+ scenegraph/qsgbasicinternalimagenode.cpp scenegraph/qsgbasicinternalimagenode_p.h
+ scenegraph/qsgbasicinternalrectanglenode.cpp scenegraph/qsgbasicinternalrectanglenode_p.h
+ scenegraph/qsgcontext.cpp scenegraph/qsgcontext_p.h
+ scenegraph/qsgcontextplugin.cpp scenegraph/qsgcontextplugin_p.h
+ scenegraph/qsgrenderloop.cpp scenegraph/qsgrenderloop_p.h
+ scenegraph/util/qsgareaallocator.cpp scenegraph/util/qsgareaallocator_p.h
+ scenegraph/util/qsgengine.cpp scenegraph/util/qsgengine.h scenegraph/util/qsgengine_p.h
+ scenegraph/util/qsgflatcolormaterial.cpp scenegraph/util/qsgflatcolormaterial.h
+ scenegraph/util/qsgimagenode.cpp scenegraph/util/qsgimagenode.h
+ scenegraph/util/qsgninepatchnode.cpp scenegraph/util/qsgninepatchnode.h
+ scenegraph/util/qsgrectanglenode.cpp scenegraph/util/qsgrectanglenode.h
+ scenegraph/util/qsgsimplematerial.cpp scenegraph/util/qsgsimplematerial.h
+ scenegraph/util/qsgsimplerectnode.cpp scenegraph/util/qsgsimplerectnode.h
+ scenegraph/util/qsgsimpletexturenode.cpp scenegraph/util/qsgsimpletexturenode.h
+ scenegraph/util/qsgtexture.cpp scenegraph/util/qsgtexture.h scenegraph/util/qsgtexture_p.h
+ scenegraph/util/qsgtexturematerial.cpp scenegraph/util/qsgtexturematerial.h scenegraph/util/qsgtexturematerial_p.h
+ scenegraph/util/qsgtextureprovider.cpp scenegraph/util/qsgtextureprovider.h
+ scenegraph/util/qsgtexturereader.cpp scenegraph/util/qsgtexturereader_p.h
+ scenegraph/util/qsgvertexcolormaterial.cpp scenegraph/util/qsgvertexcolormaterial.h
+ util/qquickanimation.cpp util/qquickanimation_p.h
+ util/qquickanimation_p_p.h
+ util/qquickanimationcontroller.cpp util/qquickanimationcontroller_p.h
+ util/qquickanimator.cpp util/qquickanimator_p.h
+ util/qquickanimator_p_p.h
+ util/qquickanimatorcontroller.cpp util/qquickanimatorcontroller_p.h
+ util/qquickanimatorjob.cpp util/qquickanimatorjob_p.h
+ util/qquickapplication.cpp util/qquickapplication_p.h
+ util/qquickbehavior.cpp util/qquickbehavior_p.h
+ util/qquickboundaryrule.cpp util/qquickboundaryrule_p.h
+ util/qquickfontloader.cpp util/qquickfontloader_p.h
+ util/qquickfontmetrics.cpp util/qquickfontmetrics_p.h
+ util/qquickglobal.cpp
+ util/qquickimageprovider.cpp util/qquickimageprovider.h util/qquickimageprovider_p.h
+ util/qquickpixmapcache.cpp util/qquickpixmapcache_p.h
+ util/qquickprofiler_p.h
+ util/qquickpropertychanges.cpp util/qquickpropertychanges_p.h
+ util/qquicksmoothedanimation.cpp util/qquicksmoothedanimation_p.h
+ util/qquicksmoothedanimation_p_p.h
+ util/qquickspringanimation.cpp util/qquickspringanimation_p.h
+ util/qquickstate.cpp util/qquickstate_p.h
+ util/qquickstate_p_p.h
+ util/qquickstatechangescript.cpp util/qquickstatechangescript_p.h
+ util/qquickstategroup.cpp util/qquickstategroup_p.h
+ util/qquickstyledtext.cpp util/qquickstyledtext_p.h
+ util/qquicksvgparser.cpp util/qquicksvgparser_p.h
+ util/qquicksystempalette.cpp util/qquicksystempalette_p.h
+ util/qquicktextmetrics.cpp util/qquicktextmetrics_p.h
+ util/qquicktimeline.cpp
+ util/qquicktimeline_p_p.h
+ util/qquicktransition.cpp util/qquicktransition_p.h
+ util/qquicktransitionmanager.cpp
+ util/qquicktransitionmanager_p_p.h
+ util/qquickutilmodule.cpp util/qquickutilmodule_p.h
+ util/qquickvalidator.cpp util/qquickvalidator_p.h
+ util/qquickvaluetypes.cpp util/qquickvaluetypes_p.h
+ DEFINES
+ QT_NO_FOREACH
+ QT_NO_INTEGER_EVENT_COORDINATES
+ QT_NO_URL_CAST_FROM_STRING
+ INCLUDE_DIRECTORIES
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlModelsPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+ Qt::QmlModels
+)
+
+# Resources:
+add_qt_resource(Quick "scenegraph" PREFIX "/qt-project.org/scenegraph" BASE "scenegraph" FILES
+ shaders/24bittextmask.frag
+ shaders/24bittextmask_core.frag
+ shaders/32bitcolortext.frag
+ shaders/32bitcolortext_core.frag
+ shaders/8bittextmask.frag
+ shaders/8bittextmask_core.frag
+ shaders/distancefieldoutlinetext.frag
+ shaders/distancefieldoutlinetext_core.frag
+ shaders/distancefieldshiftedtext.frag
+ shaders/distancefieldshiftedtext.vert
+ shaders/distancefieldshiftedtext_core.frag
+ shaders/distancefieldshiftedtext_core.vert
+ shaders/distancefieldtext.frag
+ shaders/distancefieldtext.vert
+ shaders/distancefieldtext_core.frag
+ shaders/distancefieldtext_core.vert
+ shaders/flatcolor.frag
+ shaders/flatcolor.vert
+ shaders/flatcolor_core.frag
+ shaders/flatcolor_core.vert
+ shaders/hiqsubpixeldistancefieldtext.frag
+ shaders/hiqsubpixeldistancefieldtext.vert
+ shaders/hiqsubpixeldistancefieldtext_core.frag
+ shaders/hiqsubpixeldistancefieldtext_core.vert
+ shaders/loqsubpixeldistancefieldtext.frag
+ shaders/loqsubpixeldistancefieldtext.vert
+ shaders/loqsubpixeldistancefieldtext_core.frag
+ shaders/loqsubpixeldistancefieldtext_core.vert
+ shaders/opaquetexture.frag
+ shaders/opaquetexture.vert
+ shaders/opaquetexture_core.frag
+ shaders/opaquetexture_core.vert
+ shaders/outlinedtext.frag
+ shaders/outlinedtext.vert
+ shaders/outlinedtext_core.frag
+ shaders/outlinedtext_core.vert
+ shaders/rendernode.frag
+ shaders/rendernode.vert
+ shaders/rendernode_core.frag
+ shaders/rendernode_core.vert
+ shaders/smoothcolor.frag
+ shaders/smoothcolor.vert
+ shaders/smoothcolor_core.frag
+ shaders/smoothcolor_core.vert
+ shaders/smoothtexture.frag
+ shaders/smoothtexture.vert
+ shaders/smoothtexture_core.frag
+ shaders/smoothtexture_core.vert
+ shaders/sprite.frag
+ shaders/sprite.vert
+ shaders/sprite_core.frag
+ shaders/sprite_core.vert
+ shaders/stencilclip.frag
+ shaders/stencilclip.vert
+ shaders/stencilclip_core.frag
+ shaders/stencilclip_core.vert
+ shaders/styledtext.frag
+ shaders/styledtext.vert
+ shaders/styledtext_core.frag
+ shaders/styledtext_core.vert
+ shaders/textmask.frag
+ shaders/textmask.vert
+ shaders/textmask_core.frag
+ shaders/textmask_core.vert
+ shaders/texture.frag
+ shaders/texture_core.frag
+ shaders/vertexcolor.frag
+ shaders/vertexcolor.vert
+ shaders/vertexcolor_core.frag
+ shaders/vertexcolor_core.vert
+ shaders/visualization.frag
+ shaders/visualization.vert)
+add_qt_resource(Quick "items" PREFIX "/qt-project.org/items" BASE "items" FILES
+ shaders/shadereffect.frag
+ shaders/shadereffect.vert
+ shaders/shadereffect_core.frag
+ shaders/shadereffect_core.vert
+ shaders/shadereffectfallback.frag
+ shaders/shadereffectfallback.vert
+ shaders/shadereffectfallback_core.frag
+ shaders/shadereffectfallback_core.vert)
+
+
+#### Keys ignored in scope 1:.:.:quick.pro:<TRUE>:
+# ANDROID_BUNDLED_FILES = "qml" "lib/libQt5QuickParticles.so"
+# ANDROID_LIB_DEPENDENCIES = "lib/libQt5QuickParticles.so"
+# MODULE_PLUGIN_TYPES = "scenegraph"
+# _LOADED = "qt_module"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:quick.pro:QT_FEATURE_qml_network:
+# QT_PRIVATE = "network"
+
+extend_target(Quick CONDITION MSVC
+ DEFINES
+ _CRT_SECURE_NO_WARNINGS
+)
+
+#### Keys ignored in scope 4:.:.:quick.pro:solaris-cc_x_:
+# QMAKE_CXXFLAGS_RELEASE = "--O2"
+
+extend_target(Quick CONDITION WIN32 AND NOT WINRT
+ PUBLIC_LIBRARIES
+ user32
+)
+
+extend_target(Quick CONDITION EXISTS "qqml_enable_gcov"
+ LIBRARIES
+ gcov
+ COMPILE_OPTIONS
+ -fno-elide-constructors
+ -fprofile-arcs
+ -ftest-coverage
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_designer
+ SOURCES
+ designer/qqmldesignermetaobject.cpp designer/qqmldesignermetaobject_p.h
+ designer/qquickdesignercustomobjectdata.cpp designer/qquickdesignercustomobjectdata_p.h
+ designer/qquickdesignercustomparserobject.cpp designer/qquickdesignercustomparserobject_p.h
+ designer/qquickdesignersupport.cpp designer/qquickdesignersupport_p.h
+ designer/qquickdesignersupportitems.cpp designer/qquickdesignersupportitems_p.h
+ designer/qquickdesignersupportmetainfo.cpp designer/qquickdesignersupportmetainfo_p.h
+ designer/qquickdesignersupportproperties.cpp designer/qquickdesignersupportproperties_p.h
+ designer/qquickdesignersupportpropertychanges.cpp designer/qquickdesignersupportpropertychanges_p.h
+ designer/qquickdesignersupportstates.cpp designer/qquickdesignersupportstates_p.h
+ designer/qquickdesignerwindowmanager.cpp designer/qquickdesignerwindowmanager_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_accessibility
+ SOURCES
+ accessible/qaccessiblequickitem.cpp accessible/qaccessiblequickitem_p.h
+ accessible/qaccessiblequickview.cpp accessible/qaccessiblequickview_p.h
+ accessible/qquickaccessiblefactory.cpp accessible/qquickaccessiblefactory_p.h
+ LIBRARIES
+ Qt::CorePrivate
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+)
+
+extend_target(Quick CONDITION QT_FEATURE_qml_debug
+ SOURCES
+ util/qquickprofiler.cpp
+)
+
+extend_target(Quick CONDITION QT_FEATURE_shortcut
+ SOURCES
+ util/qquickshortcut.cpp util/qquickshortcut_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_path
+ SOURCES
+ util/qquickpath.cpp util/qquickpath_p.h
+ util/qquickpath_p_p.h
+ util/qquickpathinterpolator.cpp util/qquickpathinterpolator_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR QT_FEATURE_opengles3
+ SOURCES
+ items/qquickframebufferobject.cpp items/qquickframebufferobject.h
+ items/qquickopenglinfo.cpp items/qquickopenglinfo_p.h
+ scenegraph/compressedtexture/qsgcompressedatlastexture.cpp scenegraph/compressedtexture/qsgcompressedatlastexture_p.h
+ scenegraph/compressedtexture/qsgcompressedtexture.cpp scenegraph/compressedtexture/qsgcompressedtexture_p.h
+ scenegraph/coreapi/qsgbatchrenderer.cpp scenegraph/coreapi/qsgbatchrenderer_p.h
+ scenegraph/coreapi/qsgshaderrewriter.cpp
+ scenegraph/qsgdefaultcontext.cpp scenegraph/qsgdefaultcontext_p.h
+ scenegraph/qsgdefaultdistancefieldglyphcache.cpp scenegraph/qsgdefaultdistancefieldglyphcache_p.h
+ scenegraph/qsgdefaultglyphnode.cpp scenegraph/qsgdefaultglyphnode_p.cpp scenegraph/qsgdefaultglyphnode_p.h
+ scenegraph/qsgdefaultglyphnode_p_p.h
+ scenegraph/qsgdefaultinternalimagenode.cpp scenegraph/qsgdefaultinternalimagenode_p.h
+ scenegraph/qsgdefaultinternalrectanglenode.cpp scenegraph/qsgdefaultinternalrectanglenode_p.h
+ scenegraph/qsgdefaultlayer.cpp scenegraph/qsgdefaultlayer_p.h
+ scenegraph/qsgdefaultrendercontext.cpp scenegraph/qsgdefaultrendercontext_p.h
+ scenegraph/qsgdistancefieldglyphnode.cpp scenegraph/qsgdistancefieldglyphnode_p.cpp scenegraph/qsgdistancefieldglyphnode_p.h
+ scenegraph/qsgdistancefieldglyphnode_p_p.h
+ scenegraph/qsgwindowsrenderloop.cpp scenegraph/qsgwindowsrenderloop_p.h
+ scenegraph/util/qsgatlastexture.cpp scenegraph/util/qsgatlastexture_p.h
+ scenegraph/util/qsgdefaultimagenode.cpp scenegraph/util/qsgdefaultimagenode_p.h
+ scenegraph/util/qsgdefaultninepatchnode.cpp scenegraph/util/qsgdefaultninepatchnode_p.h
+ scenegraph/util/qsgdefaultpainternode.cpp scenegraph/util/qsgdefaultpainternode_p.h
+ scenegraph/util/qsgdefaultrectanglenode.cpp scenegraph/util/qsgdefaultrectanglenode_p.h
+ scenegraph/util/qsgdepthstencilbuffer.cpp scenegraph/util/qsgdepthstencilbuffer_p.h
+ scenegraph/util/qsgshadersourcebuilder.cpp scenegraph/util/qsgshadersourcebuilder_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_thread AND (QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR QT_FEATURE_opengles3)
+ SOURCES
+ scenegraph/qsgthreadedrenderloop.cpp scenegraph/qsgthreadedrenderloop_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_sprite AND (QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR QT_FEATURE_opengles3)
+ SOURCES
+ scenegraph/qsgdefaultspritenode.cpp scenegraph/qsgdefaultspritenode_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_sprite
+ SOURCES
+ items/qquickanimatedsprite.cpp items/qquickanimatedsprite_p.h
+ items/qquickanimatedsprite_p_p.h
+ items/qquicksprite.cpp items/qquicksprite_p.h
+ items/qquickspriteengine.cpp items/qquickspriteengine_p.h
+ items/qquickspritesequence.cpp items/qquickspritesequence_p.h
+ items/qquickspritesequence_p_p.h
+ scenegraph/adaptations/software/qsgsoftwarespritenode.cpp scenegraph/adaptations/software/qsgsoftwarespritenode_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_thread
+ SOURCES
+ scenegraph/adaptations/software/qsgsoftwarethreadedrenderloop.cpp scenegraph/adaptations/software/qsgsoftwarethreadedrenderloop_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_draganddrop
+ SOURCES
+ items/qquickdrag.cpp items/qquickdrag_p.h
+ items/qquickdroparea.cpp items/qquickdroparea_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_animatedimage
+ SOURCES
+ items/qquickanimatedimage.cpp items/qquickanimatedimage_p.h
+ items/qquickanimatedimage_p_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_gridview
+ SOURCES
+ items/qquickgridview.cpp items/qquickgridview_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_itemview
+ SOURCES
+ items/qquickitemview.cpp items/qquickitemview_p.h
+ items/qquickitemview_p_p.h
+ items/qquickitemviewfxitem.cpp
+ items/qquickitemviewfxitem_p_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_viewtransitions
+ SOURCES
+ items/qquickitemviewtransition.cpp items/qquickitemviewtransition_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_listview
+ SOURCES
+ items/qquicklistview.cpp items/qquicklistview_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_tableview
+ SOURCES
+ items/qquicktableview.cpp items/qquicktableview_p.h
+ items/qquicktableview_p_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_pathview
+ SOURCES
+ items/qquickpathview.cpp items/qquickpathview_p.h
+ items/qquickpathview_p_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_positioners
+ SOURCES
+ items/qquickpositioners.cpp items/qquickpositioners_p.h
+ items/qquickpositioners_p_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_flipable
+ SOURCES
+ items/qquickflipable.cpp items/qquickflipable_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_repeater
+ SOURCES
+ items/qquickrepeater.cpp items/qquickrepeater_p.h
+ items/qquickrepeater_p_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_quick_shadereffect
+ SOURCES
+ items/qquickgenericshadereffect.cpp items/qquickgenericshadereffect_p.h
+ items/qquickshadereffect.cpp items/qquickshadereffect_p.h
+ items/qquickshadereffectmesh.cpp items/qquickshadereffectmesh_p.h
+ items/qquickshadereffectsource.cpp items/qquickshadereffectsource_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_opengl AND QT_FEATURE_quick_shadereffect
+ SOURCES
+ items/qquickopenglshadereffect.cpp items/qquickopenglshadereffect_p.h
+ items/qquickopenglshadereffectnode.cpp items/qquickopenglshadereffectnode_p.h
+)
+
+#### Keys ignored in scope 40:.:items:items/items.pri:QT_FEATURE_opengl:
+# OTHER_FILES = "$$PWD/shaders/shadereffect.vert" "$$PWD/shaders/shadereffect.frag" "$$PWD/shaders/shadereffectfallback.vert" "$$PWD/shaders/shadereffectfallback.frag" "$$PWD/shaders/shadereffect_core.vert" "$$PWD/shaders/shadereffect_core.frag" "$$PWD/shaders/shadereffectfallback_core.vert" "$$PWD/shaders/shadereffectfallback_core.frag"
+
+extend_target(Quick CONDITION QT_FEATURE_quick_canvas
+ SOURCES
+ items/context2d/qquickcanvascontext.cpp items/context2d/qquickcanvascontext_p.h
+ items/context2d/qquickcanvasitem.cpp items/context2d/qquickcanvasitem_p.h
+ items/context2d/qquickcontext2d.cpp items/context2d/qquickcontext2d_p.h
+ items/context2d/qquickcontext2dcommandbuffer.cpp items/context2d/qquickcontext2dcommandbuffer_p.h
+ items/context2d/qquickcontext2dtexture.cpp items/context2d/qquickcontext2dtexture_p.h
+ items/context2d/qquickcontext2dtile.cpp items/context2d/qquickcontext2dtile_p.h
+)
+
+extend_target(Quick CONDITION QT_FEATURE_wheelevent
+ SOURCES
+ handlers/qquickwheelhandler.cpp handlers/qquickwheelhandler_p.h
+ handlers/qquickwheelhandler_p_p.h
+)
+add_qt_docs(
+ doc/qtquick.qdocconf
+)