aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorUlf Hermann <ulf.hermann@qt.io>2020-06-23 17:25:52 +0200
committerUlf Hermann <ulf.hermann@qt.io>2020-07-02 17:03:24 +0200
commit7814e1dbfd09ead88951d95f72e71f45fd27c920 (patch)
tree6bad033792bffbf03f7bb7611dace1358e8a0a10 /src/quick/CMakeLists.txt
parent974f52fc815f62868ddfe63f7391e3090f96b226 (diff)
Make the qtquick and qtqml plugins optional
We can do the initialization and de-initialization as constructor and destructor functions. Then we don't need to load the plugins. Task-number: QTBUG-84639 Change-Id: I2aeeee7e8d028555e3af91e93518c2c2afd70dbb Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index 3fc9110d0c..4eb0738c8d 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -89,7 +89,7 @@ qt_add_module(Quick
items/qquickwindowattached.cpp items/qquickwindowattached_p.h
items/qquickwindowmodule.cpp items/qquickwindowmodule_p.h
items/qquickwindowmodule_p_p.h
- qtquick2.cpp qtquick2_p.h
+ qtquick2.cpp
qtquickglobal.h qtquickglobal_p.h
scenegraph/adaptations/software/qsgabstractsoftwarerenderer.cpp scenegraph/adaptations/software/qsgabstractsoftwarerenderer_p.h
scenegraph/adaptations/software/qsgsoftwareadaptation.cpp scenegraph/adaptations/software/qsgsoftwareadaptation_p.h