aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-11-03 17:06:36 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-11-12 18:06:39 +0100
commit89f9ddc93fd8b2f6d2ca36f045d5a09a4813fb6c (patch)
tree2190983eca791c2b75d388811b5d9b462fc3b3ff /src/quick/CMakeLists.txt
parent8cdbcee614dbb34d4ac770bee1734c18ea27fa12 (diff)
CMake: Change Quick.Window into a pure Qml module
This fixes apps using Qt.Window with static Qt builds when deployed to a machine that doesn't have Qt installed. This will need a counterpart fix in qmake land. Change-Id: Ife11f9d1f1826e1188ef3dc3933af2f243860b6f Reviewed-by: Fabian Kosmale <fabian.kosmale@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index 5be34f3295..e9e456c949 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -525,10 +525,3 @@ set_target_properties(Quick PROPERTIES
qt6_qml_type_registration(Quick)
-#special case begin
-if (QT_WILL_INSTALL)
- install(FILES ../imports/window/qmldir DESTINATION "${INSTALL_QMLDIR}/QtQuick/Window")
-else()
- file(COPY ../imports/window/qmldir DESTINATION "${QT_BUILD_DIR}/${INSTALL_QMLDIR}/QtQuick/Window")
-endif()
-#special case end