aboutsummaryrefslogtreecommitdiffstats
path: root/src/quick/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Olav Tvete <paul.tvete@qt.io>2020-06-08 13:01:04 +0200
committerPaul Olav Tvete <paul.tvete@qt.io>2020-06-10 06:02:04 +0200
commitbb906cecec40b7de6a39d97f7c07a883de40195d (patch)
treec7fd7711bd24500ea4e5e941082504decad4f525 /src/quick/CMakeLists.txt
parent4fd3ad8c4689fc40c4ca549bba95632dc4d1a990 (diff)
Remove QQuickGenericShaderEffect
Keep it as an internal class for now, with the name QQuickShaderEffectImpl, and move it to qquickshadereffect.cpp. In the long term, we want to get rid of the extra QObject, but that requires careful untangling of the connections and the timing of cleanup at destruction. Task-number: QTBUG-83977 Change-Id: I6513bd0d8fc8522a15049b70ab43fc222088e7d0 Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
Diffstat (limited to 'src/quick/CMakeLists.txt')
-rw-r--r--src/quick/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/quick/CMakeLists.txt b/src/quick/CMakeLists.txt
index c1362e5bb6..f045a5f05d 100644
--- a/src/quick/CMakeLists.txt
+++ b/src/quick/CMakeLists.txt
@@ -495,7 +495,6 @@ qt_extend_target(Quick CONDITION QT_FEATURE_quick_repeater
qt_extend_target(Quick CONDITION QT_FEATURE_quick_shadereffect
SOURCES
- items/qquickgenericshadereffect.cpp items/qquickgenericshadereffect_p.h
items/qquickshadereffect.cpp items/qquickshadereffect_p.h
items/qquickshadereffectmesh.cpp items/qquickshadereffectmesh_p.h
items/qquickshadereffectsource.cpp items/qquickshadereffectsource_p.h