aboutsummaryrefslogtreecommitdiffstats
path: root/src/quicklayouts/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2021-01-15 10:45:18 +0100
committerFabian Kosmale <fabian.kosmale@qt.io>2021-01-18 09:45:44 +0100
commit12115bbda219a651ef86a4e91fd5e52eb54ed29b (patch)
tree08c17ec1b5064603ebf3943abd3147216026aeb9 /src/quicklayouts/CMakeLists.txt
parent704df6f14137d7e91cccb6f895d07fabcdb10f69 (diff)
Quick.Layouts: Make plugin optional
This moves the Layouts types into a new library and is meant to make them availabe to the QML compiler at some point in the future. Change-Id: I9b2b31a78b0e9ca8b6c0db1fc9272d9941c61814 Reviewed-by: Maximilian Goldstein <max.goldstein@qt.io> Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'src/quicklayouts/CMakeLists.txt')
-rw-r--r--src/quicklayouts/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/quicklayouts/CMakeLists.txt b/src/quicklayouts/CMakeLists.txt
new file mode 100644
index 0000000000..3524f5e4ba
--- /dev/null
+++ b/src/quicklayouts/CMakeLists.txt
@@ -0,0 +1,28 @@
+ qt_internal_add_module(QuickLayouts
+ GENERATE_METATYPES
+ SOURCES
+ qquickgridlayoutengine.cpp qquickgridlayoutengine_p.h
+ qquicklayout.cpp qquicklayout_p.h
+ qquicklayoutstyleinfo.cpp qquicklayoutstyleinfo_p.h
+ qquicklinearlayout.cpp qquicklinearlayout_p.h
+ qquickstacklayout.cpp qquickstacklayout_p.h
+ qquicklayoutglobal_p.h
+ DEFINES
+ QT_BUILD_QUICKLAYOUTS_LIB
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::GuiPrivate
+ Qt::QuickPrivate
+ Qt::Qml
+)
+
+
+set_target_properties(QuickLayouts PROPERTIES
+ QT_QML_MODULE_INSTALL_QMLTYPES TRUE
+ QT_QML_MODULE_VERSION ${CMAKE_PROJECT_VERSION}
+ QT_QML_MODULE_URI QtQuick.Layouts
+ QT_QMLTYPES_FILENAME plugins.qmltypes
+ QT_QML_MODULE_INSTALL_DIR "${INSTALL_QMLDIR}/QtQuick/Layouts"
+)
+
+qt6_qml_type_registration(QuickLayouts)