aboutsummaryrefslogtreecommitdiffstats
path: root/src/quicktemplates2/CMakeLists.txt
diff options
context:
space:
mode:
authorRichard Moe Gustavsen <richard.gustavsen@qt.io>2021-11-19 17:00:10 +0100
committerRichard Moe Gustavsen <richard.gustavsen@qt.io>2021-12-09 23:16:37 +0100
commit0ddb0d4b9b0c70c4fd4058ef4660e38fd933523e (patch)
treea1edb527abb0038e1be4092f3e875689840f9433 /src/quicktemplates2/CMakeLists.txt
parent8ec849646d8bd590e64bda6105021bde58fa7ae3 (diff)
controls: add TreeViewDelegate
This patch adds TreeViewDelegate to Controls. TreeViewDelegate is a ready-made delegate that can be assigned to TreeView. It takes care of drawing the tree using the style, and can be used directly without the need for customization. It implements all the required properties set by TreeView, and offers in addition a small API that lets the developer change the indicator and the label. [ChangeLog][Controls] New delegate added: TreeViewDelegate Change-Id: I50fbc059afbc2b896d23d9d59717c8571e94bae6 Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'src/quicktemplates2/CMakeLists.txt')
-rw-r--r--src/quicktemplates2/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/quicktemplates2/CMakeLists.txt b/src/quicktemplates2/CMakeLists.txt
index 21a26c335e..af4125f3ea 100644
--- a/src/quicktemplates2/CMakeLists.txt
+++ b/src/quicktemplates2/CMakeLists.txt
@@ -156,6 +156,11 @@ qt_internal_extend_target(QuickTemplates2 CONDITION QT_FEATURE_quick_tableview
qquickheaderview_p_p.h
)
+qt_internal_extend_target(QuickTemplates2 CONDITION QT_FEATURE_quick_treeview
+ SOURCES
+ qquicktreeviewdelegate.cpp qquicktreeviewdelegate_p.h
+)
+
qt_internal_extend_target(QuickTemplates2 CONDITION QT_FEATURE_quick_listview AND QT_FEATURE_quick_pathview
SOURCES
qquicktumbler.cpp qquicktumbler_p.h