aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-08-07 16:25:52 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-08-14 14:01:58 +0000
commit4e14f6e70abb4a02a570a390f462736666b234a7 (patch)
treeabd6ccb232ab16eabe1b41e6e76435ad248fb766 /tests/CMakeLists.txt
parent494dc05ea1758f2bee49ddb98712a030336acbd2 (diff)
Add QtDeclarative Test Coverage
All tests compile and run on a developer build. These tests are failing: tst_qqmlsqldatabase Fails due to missing sql driver tst_qqmlsqldatabase Fails in wip/qt6 tst_ququicklayouts Fails in wip/qt6 tst_flickableinterop Fails in wip/qt6 tst_qquickpinchandler Fails in wip/qt6 tst_qquickflickable Fails in wip/qt6 tst_qquickgridview Fails in wip/qt6 tst_qquickimage Fails due to missing jpeg plugin tst_qquicklistview Fails in wip/qt6 tst_qquicktext Fails in wip/qt6 tst_qquickcanvasitem Fails in wip/qt6 tst_scenegraph Fails due to missing jpeg plugin tst_TestFiltering Fails in wip/qt6 Change-Id: I4b9d69c118e23c095cb72ad5a67653fc30943bb1 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index ebb34d2d18..33a89765dd 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,7 +1,13 @@
# Generated from tests.pro.
-add_subdirectory(auto)
+# special case begin
+find_package(Qt6 REQUIRED Concurrent)
+# special case end
-if(QT_CONFIG___contains___release)
- add_subdirectory(benchmarks)
-endif()
+add_subdirectory(auto)
+# special case begin
+# benchmarks not yet ported
+# if(QT_CONFIG___contains___release)
+# add_subdirectory(benchmarks)
+# endif()
+# special case end