aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-09 13:53:53 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-12 14:05:23 +0000
commit14492ecee2e34843efd3ef070503a43a48552055 (patch)
tree37432296f2f6bbc596d2470f79c99ce68801567c /tests/auto/CMakeLists.txt
parent26c5243491f495194f04b449128dae36118e28da (diff)
CMake: Regenerate and adapt to merge from devwip/cmake
Change-Id: If8daa6152a563d4309d7342414780ef75b9f5589 Reviewed-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io> Reviewed-by: Leander Beernaert <leander.beernaert@qt.io>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 106a7fe10e..702f646bd4 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -4,17 +4,17 @@ add_subdirectory(qml)
add_subdirectory(quick)
add_subdirectory(quicktest)
add_subdirectory(qmldevtools)
-# add_subdirectory(cmake) # special case remove
# special case begin
+# add_subdirectory(cmake)
# add_subdirectory(installed_cmake)
# special case end
add_subdirectory(toolsupport)
if(NOT APPLE_UIKIT)
add_subdirectory(qmltest)
endif()
-if(QT_FEATURE_opengles2 OR QT_FEATURE_opengles3 OR (QT_FEATURE_opengl AND TARGET Qt::Gui))
+if(TARGET Qt::Gui AND (QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR QT_FEATURE_opengles3))
add_subdirectory(particles)
endif()
-if(QT_FEATURE_opengles2 OR (QT_FEATURE_opengl AND TARGET Qt::Gui) OR (QT_FEATURE_opengles3 AND TARGET Qt::Widgets))
+if(TARGET Qt::Gui AND TARGET Qt::Widgets AND (QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR QT_FEATURE_opengles3))
add_subdirectory(quickwidgets)
endif()