aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorFawzi Mohamed <fawzi.mohamed@qt.io>2020-04-06 19:13:39 +0200
committerFawzi Mohamed <fawzi.mohamed@qt.io>2020-11-23 16:44:12 +0100
commitfbba765e2372cf21d8c37b2a78bbbc74f8128331 (patch)
tree121168de6dab63c0018267ca414d30f25280865e /tests/auto/CMakeLists.txt
parent7b89ae6ef4158dcbd1940e088c84eba747c166bc (diff)
qmldom: Start of the Qml Dom library
The goal of the Dom library is to provide a nicer to use basis for the Qml Code model, to be used by the various QML tools, the designer and the new compiler. This commit just adds some common utilities used by the library, to output strings to a Sink, i.e. a function<void(QStringView). This allows writing without allocations of extra temporary strings. The more interesting parts are added in subsequent commits Task-number: QTBUG-74840 Change-Id: I8fa43d5b622f59c8761b2469551127c0508c23c3 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index cdec7346eb..e3102d18c4 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -1,6 +1,7 @@
# Generated from auto.pro.
add_subdirectory(qml)
+add_subdirectory(qmldom)
add_subdirectory(quick)
add_subdirectory(quicktest)
add_subdirectory(qmldevtools)