aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-06-23 10:52:03 +0200
committerQt by Nokia <qt-info@nokia.com>2012-07-19 05:49:18 +0200
commit13b35de9d19664f22ca6bf97e6bb6b9b95a1aa45 (patch)
tree5184a082f693c4f047a126cd47b205ee1ef9861b /tests/auto/cmake/CMakeLists.txt
parent535249b9998e0925eab05ee48225b38aa128719a (diff)
Test that the package configs for QtDeclarative work.
Change-Id: I514e2c6bb1ad7f3d7b72f58e335e3d3dcf0f1542 Reviewed-by: Rohan McGovern <rohan.mcgovern@nokia.com>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
new file mode 100644
index 0000000000..4f15a69ec8
--- /dev/null
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -0,0 +1,12 @@
+
+cmake_minimum_required(VERSION 2.8)
+
+project(qmake_cmake_files)
+
+enable_testing()
+
+find_package(Qt5Core REQUIRED)
+
+include("${_Qt5CTestMacros}")
+
+expect_pass(test_modules)