aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kevin.funk@kdab.com>2015-11-02 07:18:01 +0100
committerKevin Funk <kevin.funk@kdab.com>2015-11-02 08:42:52 +0000
commit2f2dd3b0c28db210ea1f00d569f6c1626894c5f4 (patch)
tree6fe67c0d680bd95ca9d9ea41bf1c1edee18ace4e /tests/auto/cmake/CMakeLists.txt
parenteab47802925acb34a6785639bb34bfa97e58643f (diff)
CMake: Make sure to export all plugins
Also export plugins ending on "Factory". CMake by default only picks up plugins which have a PLUGIN_CLASS_NAME ending on "Plugin" Task-number: QTBUG-43438 Change-Id: Ib954276dc0eee83f9d48bed0502a16df8194ce9b Reviewed-by: Tim Blechmann <tim@klingt.org> Reviewed-by: Stephen Kelly <steveire@gmail.com>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index f62d2f3bdb..4b9fbe75ac 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -13,3 +13,5 @@ test_module_includes(
Qml QQmlEngine
Quick QQuickWindow
)
+
+expect_pass(test_plugins)