aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_modules/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-10-31 14:51:49 +0100
committerThe Qt Project <gerrit-noreply@qt-project.org>2012-11-01 01:42:40 +0100
commit732db404eac8982a69f4cf0c99378c54914be684 (patch)
tree82ec41cf6a7874eeb2f622e10f5f823931c9bb6d /tests/auto/cmake/test_modules/CMakeLists.txt
parent8ce7d6a319c1fca735ecf7faff2127fb3aca1a72 (diff)
CMake: Remove obsolete test_modules test
The generated module_includes test is a super-set of this test. Change-Id: I086d81806cdbc3c4afbeae0f8683a5b693b6f85a Reviewed-by: Rohan McGovern <rohan.mcgovern@nokia.com>
Diffstat (limited to 'tests/auto/cmake/test_modules/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_modules/CMakeLists.txt33
1 files changed, 0 insertions, 33 deletions
diff --git a/tests/auto/cmake/test_modules/CMakeLists.txt b/tests/auto/cmake/test_modules/CMakeLists.txt
deleted file mode 100644
index 509320bfb5..0000000000
--- a/tests/auto/cmake/test_modules/CMakeLists.txt
+++ /dev/null
@@ -1,33 +0,0 @@
-
-cmake_minimum_required(VERSION 2.8)
-
-project(test_modules)
-
-# We have to find the dependencies separately because they are installed,
-# whereas the modules under test are not installed yet, and are found in the
-# build directory. Normally the Qt5 CMake files expect all modules in one
-# installation prefix, so we work around that by finding the dependencies
-# explicitly first.
-find_package(Qt5Network REQUIRED)
-find_package(Qt5Gui REQUIRED)
-
-find_package(Qt5Qml REQUIRED)
-find_package(Qt5Quick REQUIRED)
-
-include_directories(
- ${Qt5Qml_INCLUDE_DIRS}
- ${Qt5Quick_INCLUDE_DIRS}
-)
-
-add_definitions(
- ${Qt5Qml_DEFINITIONS}
- ${Qt5Quick_DEFINITIONS}
-)
-
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
-
-add_executable(mainapp main.cpp)
-target_link_libraries(mainapp
- ${Qt5Qml_LIBRARIES}
- ${Qt5Quick_LIBRARIES}
-)