aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-05-28 16:42:25 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-05-29 10:01:25 +0200
commit350a2f48c15d7766a58f13c9625e32e766ecdf80 (patch)
treeb6e05e3ae5d8e0db8e06d56df71e877124a00afd /tests/auto/qml/CMakeLists.txt
parent965984771d1c146a01fbaab3f6dae2461eabf78e (diff)
CMake: Regenerate qtdeclarative/tests
Includes: - new api calls - some new dependencies - some TARGET_DESCRIPTION - some additional tool directory exclusion when cross-compiling (qmlplugindump) - some missing add_subdirectory calls Change-Id: Iea43e45b94f37367ffc1d8dd6ce0ff1021a31b1a Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'tests/auto/qml/CMakeLists.txt')
-rw-r--r--tests/auto/qml/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/auto/qml/CMakeLists.txt b/tests/auto/qml/CMakeLists.txt
index dec41a2219..af8859f4d9 100644
--- a/tests/auto/qml/CMakeLists.txt
+++ b/tests/auto/qml/CMakeLists.txt
@@ -1,5 +1,10 @@
# Generated from qml.pro.
+
+qt_exclude_tool_directories_from_default_target(
+ qmlplugindump
+)
+
add_subdirectory(parserstress)
add_subdirectory(qjsvalueiterator)
add_subdirectory(qjsonbinding)
@@ -90,3 +95,6 @@ if(QT_FEATURE_private_tests)
add_subdirectory(bindingdependencyapi)
add_subdirectory(v4misc)
endif()
+if(NOT CMAKE_CROSSCOMPILING)
+ # add_subdirectory(qmltyperegistrar) # special case need to port
+endif()