aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qjsengine/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2019-08-07 16:25:52 +0200
committerLeander Beernaert <leander.beernaert@qt.io>2019-08-14 14:01:58 +0000
commit4e14f6e70abb4a02a570a390f462736666b234a7 (patch)
treeabd6ccb232ab16eabe1b41e6e76435ad248fb766 /tests/auto/qml/qjsengine/CMakeLists.txt
parent494dc05ea1758f2bee49ddb98712a030336acbd2 (diff)
Add QtDeclarative Test Coverage
All tests compile and run on a developer build. These tests are failing: tst_qqmlsqldatabase Fails due to missing sql driver tst_qqmlsqldatabase Fails in wip/qt6 tst_ququicklayouts Fails in wip/qt6 tst_flickableinterop Fails in wip/qt6 tst_qquickpinchandler Fails in wip/qt6 tst_qquickflickable Fails in wip/qt6 tst_qquickgridview Fails in wip/qt6 tst_qquickimage Fails due to missing jpeg plugin tst_qquicklistview Fails in wip/qt6 tst_qquicktext Fails in wip/qt6 tst_qquickcanvasitem Fails in wip/qt6 tst_scenegraph Fails due to missing jpeg plugin tst_TestFiltering Fails in wip/qt6 Change-Id: I4b9d69c118e23c095cb72ad5a67653fc30943bb1 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/qml/qjsengine/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qjsengine/CMakeLists.txt57
1 files changed, 57 insertions, 0 deletions
diff --git a/tests/auto/qml/qjsengine/CMakeLists.txt b/tests/auto/qml/qjsengine/CMakeLists.txt
new file mode 100644
index 0000000000..2d5980760f
--- /dev/null
+++ b/tests/auto/qml/qjsengine/CMakeLists.txt
@@ -0,0 +1,57 @@
+# Generated from qjsengine.pro.
+
+#####################################################################
+## tst_qjsengine Test:
+#####################################################################
+
+# Collect test data
+
+file(GLOB test_data_glob
+ LIST_DIRECTORIES true
+ RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
+ "script/*")
+list(APPEND test_data ${test_data_glob})
+
+add_qt_test(tst_qjsengine
+ GUI
+ SOURCES
+ tst_qjsengine.cpp
+ LIBRARIES
+ Qt::GuiPrivate
+ Qt::QmlPrivate
+ PUBLIC_LIBRARIES
+ Qt::Gui
+ Qt::Qml
+ Qt::Widgets
+ TESTDATA ${test_data}
+)
+
+# Resources:
+add_qt_resource(tst_qjsengine "qjsengine"
+ PREFIX
+ "/"
+ FILES
+ translations/idtranslatable-unicode.qm
+ translations/idtranslatable_la.qm
+ translations/translatable-unicode.qm
+ translations/translatable_la.qm
+)
+add_qt_resource(tst_qjsengine "qmake_immediate"
+ PREFIX
+ "/"
+ FILES
+ exporterror1.mjs
+ importerror1.mjs
+ modulewithlexicals.mjs
+ testmodule.mjs
+)
+
+
+#### Keys ignored in scope 1:.:.:qjsengine.pro:<TRUE>:
+# CONFIG = "testcase"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 2:.:.:qjsengine.pro:APPLE_OSX:
+# CONFIG = "-app_bundle"