aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmlplugindump/data/dumper/ExtendedType/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-03-12 15:27:58 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-03-12 15:28:15 +0100
commit8592ae4096f3f9c2b08b87ad2fcbbbfadf75f2d7 (patch)
treea757c1d80ec77952eae2cc4de5d89c01f14760fc /tests/auto/qml/qmlplugindump/data/dumper/ExtendedType/CMakeLists.txt
parente7decc7637e9eb7e66a0d19705090f18488028c0 (diff)
parent14492ecee2e34843efd3ef070503a43a48552055 (diff)
Merge remote-tracking branch 'origin/wip/cmake' into dev
Conflicts: dependencies.yaml Change-Id: Ifff48b9d0e7962d481e63c49399e2d304e1011e5
Diffstat (limited to 'tests/auto/qml/qmlplugindump/data/dumper/ExtendedType/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmlplugindump/data/dumper/ExtendedType/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/tests/auto/qml/qmlplugindump/data/dumper/ExtendedType/CMakeLists.txt b/tests/auto/qml/qmlplugindump/data/dumper/ExtendedType/CMakeLists.txt
new file mode 100644
index 0000000000..9e934eff60
--- /dev/null
+++ b/tests/auto/qml/qmlplugindump/data/dumper/ExtendedType/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Generated from extendedtype.pro.
+
+#####################################################################
+## ExtendedType Generic Library:
+#####################################################################
+
+qt_add_cmake_library(ExtendedType
+ MODULE
+ OUTPUT_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} # special case
+ SOURCES
+ plugin.cpp plugin.h
+ types.h
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::Gui
+ Qt::Qml
+)
+
+#### Keys ignored in scope 1:.:.:extendedtype.pro:<TRUE>:
+# TEMPLATE = "lib"
+
+## Scopes:
+#####################################################################
+
+#### Keys ignored in scope 3:.:.:extendedtype.pro:NOT _PRO_FILE_PWD____equals____ss_OUT_PWD:
+# COPIES = "cp"
+# cp.files = "qmldir" "plugins.qmltypes"
+# cp.path = "$$OUT_PWD"
+
+qt_autogen_tools_initial_setup(ExtendedType)
+# special case begin
+get_target_property(binary_dir ExtendedType BINARY_DIR)
+file(COPY qmldir plugins.qmltypes
+ DESTINATION ${binary_dir}
+)
+# special case end