aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qmltyperegistrar/CMakeLists.txt
diff options
context:
space:
mode:
authorMaximilian Goldstein <max.goldstein@qt.io>2020-11-04 15:19:03 +0100
committerMaximilian Goldstein <max.goldstein@qt.io>2020-11-10 18:14:48 +0100
commita4d956048b4679bf5b448340d1f3428793699990 (patch)
treefd382c2b6cadb813ac1939bf8a6149beecb60b2e /tests/auto/qml/qmltyperegistrar/CMakeLists.txt
parentd01ec7ebe3853faabc8843d169d288b4998bb209 (diff)
qmltyperegistrar: Add past-major-version option
Adds the option to specify past major versions of modules to be registered. This is necessary for modules that don't export any types themselves to work when built statically. Change-Id: I4b4a379f92707ec64cbb32f91db9d010440b95a2 Reviewed-by: Fawzi Mohamed <fawzi.mohamed@qt.io>
Diffstat (limited to 'tests/auto/qml/qmltyperegistrar/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qmltyperegistrar/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/qml/qmltyperegistrar/CMakeLists.txt b/tests/auto/qml/qmltyperegistrar/CMakeLists.txt
index d581589f4d..db8fa4b1d6 100644
--- a/tests/auto/qml/qmltyperegistrar/CMakeLists.txt
+++ b/tests/auto/qml/qmltyperegistrar/CMakeLists.txt
@@ -32,6 +32,7 @@ target_compile_definitions(tst_qmltyperegistrar PRIVATE BUILD_WITH_CMAKE) # spec
set_target_properties(tst_qmltyperegistrar PROPERTIES
QT_QML_MODULE_VERSION 1.0
QT_QML_MODULE_URI QmlTypeRegistrarTest
+ QT_QML_PAST_MAJOR_VERSIONS 0 # special case
QT_QMLTYPES_FILENAME tst_qmltyperegistrar.qmltypes
)