aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlbinding/CMakeLists.txt
diff options
context:
space:
mode:
authorFabian Kosmale <fabian.kosmale@qt.io>2021-01-21 20:02:17 +0100
committerFabian Kosmale <fabian.kosmale@qt.io>2021-02-03 09:28:40 +0100
commit0deb3961e6b0a1f15a491f7a19085df3a7a506b1 (patch)
tree28c9db4fd4bd0a334a1848d852f6394f83bc97d9 /tests/auto/qml/qqmlbinding/CMakeLists.txt
parentb322a971f06823a4356f2b3aa331501aa4d0dc7f (diff)
QmlBind: support bindable properties
This patch ensures that the QML Binding element can also save and restore C++ bindings. Should QQuickItem's x and y property be ported to the new property system, we'd need new test cases to verify that "old-style" bindings are still handled correctly. This task is however left for the change porting the properties. Task-number: QTBUG-90493 Change-Id: I506ffa1060ff32a7d722214e5ccd469bdaa61ff8 Reviewed-by: Ulf Hermann <ulf.hermann@qt.io>
Diffstat (limited to 'tests/auto/qml/qqmlbinding/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlbinding/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/tests/auto/qml/qqmlbinding/CMakeLists.txt b/tests/auto/qml/qqmlbinding/CMakeLists.txt
index c95d3e6f29..6bf1668970 100644
--- a/tests/auto/qml/qqmlbinding/CMakeLists.txt
+++ b/tests/auto/qml/qqmlbinding/CMakeLists.txt
@@ -14,6 +14,7 @@ qt_internal_add_test(tst_qqmlbinding
SOURCES
../../shared/util.cpp ../../shared/util.h
tst_qqmlbinding.cpp
+ WithBindableProperties.h
INCLUDE_DIRECTORIES
../../shared
PUBLIC_LIBRARIES
@@ -25,6 +26,14 @@ qt_internal_add_test(tst_qqmlbinding
TESTDATA ${test_data}
)
+set_target_properties(tst_qqmlbinding PROPERTIES
+ QT_QML_MODULE_URI "test"
+ QT_QML_MODULE_VERSION 1.0
+)
+
+qt6_qml_type_registration(tst_qqmlbinding)
+
+
## Scopes:
#####################################################################