aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlcomponent/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 13:31:06 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-15 12:24:51 +0000
commitba494aaa24defe1401f621b791891e696b308756 (patch)
tree3617f29e9625fafbf94609ac79b2decd4033107c /tests/auto/qml/qqmlcomponent/CMakeLists.txt
parent91e32f86b53bb930405a58e19c84746ee85cdf89 (diff)
Regenerate all projects with new CMake API version
Change-Id: Ie0db35f674137c229eaf049616f38f8e818f7092 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/qml/qqmlcomponent/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlcomponent/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/auto/qml/qqmlcomponent/CMakeLists.txt b/tests/auto/qml/qqmlcomponent/CMakeLists.txt
index 0ee7103dc6..41f844d369 100644
--- a/tests/auto/qml/qqmlcomponent/CMakeLists.txt
+++ b/tests/auto/qml/qqmlcomponent/CMakeLists.txt
@@ -10,7 +10,7 @@ file(GLOB_RECURSE test_data_glob
data/*)
list(APPEND test_data ${test_data_glob})
-add_qt_test(tst_qqmlcomponent
+qt_add_test(tst_qqmlcomponent
SOURCES
../../shared/testhttpserver.cpp ../../shared/testhttpserver.h
../../shared/util.cpp ../../shared/util.h
@@ -35,7 +35,7 @@ set(qmake_immediate_resource_files
"data/QtObjectComponent.qml"
)
-add_qt_resource(tst_qqmlcomponent "qmake_immediate"
+qt_add_resource(tst_qqmlcomponent "qmake_immediate"
PREFIX
"/"
FILES
@@ -46,12 +46,12 @@ add_qt_resource(tst_qqmlcomponent "qmake_immediate"
## Scopes:
#####################################################################
-extend_target(tst_qqmlcomponent CONDITION ANDROID OR APPLE_IOS
+qt_extend_target(tst_qqmlcomponent CONDITION ANDROID OR APPLE_IOS
DEFINES
QT_QMLTEST_DATADIR=\\\":/data\\\"
)
-extend_target(tst_qqmlcomponent CONDITION NOT ANDROID AND NOT APPLE_IOS
+qt_extend_target(tst_qqmlcomponent CONDITION NOT ANDROID AND NOT APPLE_IOS
DEFINES
QT_QMLTEST_DATADIR=\\\"${CMAKE_CURRENT_SOURCE_DIR}/data\\\"
)