aboutsummaryrefslogtreecommitdiffstats
path: root/tests/auto/qml/qqmlecmascript/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 11:39:42 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-15 12:24:38 +0000
commit91e32f86b53bb930405a58e19c84746ee85cdf89 (patch)
tree3419986b62355e718551b83a514c1169480a8ed0 /tests/auto/qml/qqmlecmascript/CMakeLists.txt
parent387f360b3b2634094889478f2b258e65a70b9aa6 (diff)
Regenerate remaining tests to be in sync
Change-Id: I200c8f58ad13bc1bc78409a3ce49348584ba5b51 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/qml/qqmlecmascript/CMakeLists.txt')
-rw-r--r--tests/auto/qml/qqmlecmascript/CMakeLists.txt35
1 files changed, 13 insertions, 22 deletions
diff --git a/tests/auto/qml/qqmlecmascript/CMakeLists.txt b/tests/auto/qml/qqmlecmascript/CMakeLists.txt
index 693fa90c00..d467791e87 100644
--- a/tests/auto/qml/qqmlecmascript/CMakeLists.txt
+++ b/tests/auto/qml/qqmlecmascript/CMakeLists.txt
@@ -5,15 +5,12 @@
#####################################################################
# Collect test data
-
-file(GLOB test_data_glob
- LIST_DIRECTORIES true
+file(GLOB_RECURSE test_data_glob
RELATIVE ${CMAKE_CURRENT_SOURCE_DIR}
- "data/*")
+ data/*)
list(APPEND test_data ${test_data_glob})
add_qt_test(tst_qqmlecmascript
- GUI
SOURCES
../../shared/testhttpserver.cpp ../../shared/testhttpserver.h
../../shared/util.cpp ../../shared/util.h
@@ -33,37 +30,31 @@ add_qt_test(tst_qqmlecmascript
)
# Resources:
+set(qqmlecmascript_resource_files
+ "data/include.js"
+ "data/include.qml"
+ "data/js/include2.js"
+ "data/js/include3.js"
+)
+
# special case begin
set_source_files_properties(
- data/include.js
- data/include.qml
- data/js/include2.js
- data/js/include3.js
+ ${qqmlecmascript_resource_files}
PROPERTIES
- QT_SKIP_QUICKCOMPILER 1
-)
-
+ QT_SKIP_QUICKCOMPILER 1)
# special case end
+
add_qt_resource(tst_qqmlecmascript "qqmlecmascript"
PREFIX
"/"
FILES
- data/include.js
- data/include.qml
- data/js/include2.js
- data/js/include3.js
+ ${qqmlecmascript_resource_files}
)
-#### Keys ignored in scope 1:.:.:qqmlecmascript.pro:<TRUE>:
-# CONFIG = "testcase"
-
## Scopes:
#####################################################################
-#### Keys ignored in scope 2:.:.:qqmlecmascript.pro:APPLE_OSX:
-# CONFIG = "-app_bundle"
-
extend_target(tst_qqmlecmascript CONDITION TARGET Qt::Widgets
PUBLIC_LIBRARIES
Qt::Widgets